Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't send mail in Thunderbird with new account using Authentication method: OAuth2

  • 16 replies
  • 1 has this problem
  • 1272 views
  • Last reply by SomeGirl

more options

Hi,

My old Gmail account works in Thunderbird 68.12.1 (32-bit) with no problems, that is, it sends and receives mail. Now I decided to add another Gmail account to Thunderbird. It receives mail without problems, but it can't send mail. If that matters, I have total 4 accounts in Thunderbird (the other 2 aren't Gmail accounts and they're working).

Both accounts have identical settings:

1) both are Gmail mails, that is, mail address is like name1.name2@gmail.com and those mails aren't new (I've had them for several years, but in Thunderderbird was using just one of them).

2) the option for "Less secure app access allowed" is turned ON in Gmail account security

3) POP mail server settings: Server Name: pop.gmail.com Port: 995 Connection security: SSL/TLS Authentication method: Normal password

4) SMTP server settings in Thunderbird: Server Name: smtp.gmail.com Port: 465 Connection security: SSL/TLS Authentication method: OAuth2

So why my new account can't send mails with Authentication method: OAuth2 (it can only send mails using Authentication method: Normal password).

Isn't that the opposite of what should be happening? I thought that Gmail was supposed require OAuth2 method. Anyway, what I'm missing to make those accounts identical for Gmail?

Chosen solution

The attached picture shows the cookies settings in TB Options/Privacy. Make sure 'Accept cookies from sites' is checked for OAuth2 to work.

Read this answer in context 👍 1

All Replies (16)

more options
Can't send mail

What prevents you from sending messages? Is there any error message? Please be more specific.

Helpful?

more options

Change the authentication on the incoming POP server to OAuth2, to match the outgoing. In Tools/Account Settings, select each gmail account in the left pane, then make sure each Outgoing Server (SMTP) has the same User Name as the selected account (Edit SMTP server... to check). Remove all passwords and oauth tokens from Options/Security/Passwords/Saved Passwords, restart TB, enter the account password in the OAuth browser window.

Helpful?

more options

christ1 said

What prevents you from sending messages? Is there any error message? Please be more specific.

When I try to send message on my second Gmail account from Thunderbird using OAuth2 I'm getting this window "One account. All of Google." (see the picture below), but if I enter my e-mail there and press Next nothing happens, it opens the same window where I have to enter e-mail again and it doesn't ask to enter password (I can join that Google account from any browser, but not from this window, which pops up from Thunderbird). I don't get any of this bug on my first Gmail account in Thunderbird.

Helpful?

more options

When nothing happens after clicking Next, it's usually because cookies aren't allowed in TB Options/Privacy; they are needed for OAuth2.

Helpful?

more options

sfhowes said

Change the authentication on the incoming POP server to OAuth2, to match the outgoing. In Tools/Account Settings, select each gmail account in the left pane, then make sure each Outgoing Server (SMTP) has the same User Name as the selected account (Edit SMTP server... to check). Remove all passwords and oauth tokens from Options/Security/Passwords/Saved Passwords, restart TB, enter the account password in the OAuth browser window.

Did all these steps, still the same result (now I also can't receive mails when OAuth2 is set for POP, the same window pops up).

sfhowes said

When nothing happens after clicking Next, it's usually because cookies aren't allowed in TB Options/Privacy; they are needed for OAuth2.

I'm using Google Chrome and all cookies are allowed (look at image below).

I think it's a problem with Thunderbird. Have to tried to add a new Gmail account to Thunderbird? Can you confirm that OAuth2 is working for POP and SMTP on that new account?

Helpful?

more options

Chrome or any other browser's cookies are not relevant. The relevant ones are in TB Options/Privacy. Allow all cookies or at least for *.google.com.

Helpful?

more options

sfhowes said

Chrome or any other browser's cookies are not relevant. The relevant ones are in TB Options/Privacy. Allow all cookies or at least for *.google.com.

My default browser is Chrome. If Firefox cookie settings matter for Thunderbird then does it mean that Thunderbird can't be securely used without installed Firefox? Anyway, here is my cookie settings in Firefox:

Helpful?

more options

Chosen Solution

The attached picture shows the cookies settings in TB Options/Privacy. Make sure 'Accept cookies from sites' is checked for OAuth2 to work.

Helpful?

more options

sfhowes said

The attached picture shows the cookies settings in TB Options/Privacy. Make sure 'Accept cookies from sites' is checked for OAuth2 to work.

Thank you very much, now it's working as expected! Somehow I've misunderstood what you've already clearly explained in previous post :) (now it all makes sense)

A small mystery: why my first account was working without these cookies?

Helpful?

more options

Cookies are not required for normal password authentication.

Helpful?

more options

Hello, I have this problem now, too, I followed all of the steps including allowing cookies (all settings were already entered the way they should be according to this thread but it is still not sending any emails from my yahoo account using firefox). I have no idea what I should do -- I have restarted about 100 times now.

Helpful?

more options

spamalot said

Hello, I have this problem now, too, I followed all of the steps including allowing cookies (all settings were already entered the way they should be according to this thread but it is still not sending any emails from my yahoo account using firefox). I have no idea what I should do -- I have restarted about 100 times now.

Check that OAuth2 is also the authentication method for the outgoing server.

Helpful?

more options

Hi, actually that was the problem. As mentioned, I had all the right settings and also OAuth2 on the outgoing server but I thought that maybe considering this is yahoo business mail we're dealing with and knowing how awful they are, they may have it upside down. And they do. The trick was to set the outgoing to "normal password". It has since worked fine and has not asked me to enter passwords again. Thanks for responding though!

Helpful?

more options

I have this problem as well -- often (say one in three attempts) to either read IMAP or send SMTP is rejected due to "authentication error".

Cookies are (and were before) allowed in TB -> privacy, and OAuth2 is the authentication method for IMAP and SMTP.

Something is definitely broken in TB.

(I read and write to the same GMAIL servers on my ANDROID devices using a3rd party app (AQUAMAIL), and there is never any authentication problem there.)

Modified by AY

Helpful?

more options

AY said

I have this problem as well -- often (say one in three attempts) to either read IMAP or send SMTP is rejected due to "authentication error". Cookies are (and were before) allowed in TB -> privacy, and OAuth2 is the authentication method for IMAP and SMTP. Something is definitely broken in TB. (I read and write to the same GMAIL servers on my ANDROID devices using a3rd party app (AQUAMAIL), and there is never any authentication problem there.)

There are millions of TB users with working gmail accounts, so I highly doubt TB is broken. If you've followed all the instructions and it's not working, there is probably some other program (antivirus, VPN) interfering with the connection. Start your computer in safe mode and then run TB, and see if it works.

Helpful?

more options

Mine is broken as well. Same issue, gmail accounts broken right after update. OATH2 is correctly selected, cookies enabled as per the guidance here (both were already the case) and I'm constantly getting this message, so something is wrong. I checked all of the settings mentioned 3 times. It's complaining about the incoming imap settings which again have been checked 3 times. So time for me to move away from TB unfortunately, since I have several gmail accounts affected by this. I have also checked the google documentation, all is as it should be. Next I'll be removing and re-adding an account (letting TB grab the settings automatically).

Edit: Yep, when re-adding the account, I had to reconnect thunderbird to gmail as an "allowed app" again, so the previous "allowed" connection to Thunderbird was somehow insufficient or wiped out. So now I have to remove, re-auth, and re-add all my accounts, which is a pain in the butt with 2 factor auth set on all of them. If this happens again, thunderbird is going in the bin.

Modified by SomeGirl

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.