Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

netflix.com returns server not found, any other browser it works ok.

  • 3 replies
  • 1 has this problem
  • 25 views
  • Last reply by apeg

more options

Hi,

I have a bit of an odd one. I have Firefox installed and Debian OS. For the last two or three weeks I haven't been able to access netflix.com, returns "Server not found" only on the firefox browser. Trying another browser and I can get to the site without issue. Any other site I firefox can access without issue. Same issue in a Private window. I have two debian PC's, both do the same thing. Any other windows, android phone is ok ( using firefox ).

If I connect to my vpn provider on the problem PC's, firefox can access netflix.

Any help appreciated.

Thanks,

Attached screenshots

Chosen solution

Note that the Firefox 60.0 version you appear to be using according to the System Details list is rather old and is no longer supported.

Try to disable IPv6 (check for other possible causes as well).

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Check also the DNS Lookup tool on the about:networking#dnslookuptool page..

Read this answer in context 👍 1

All Replies (3)

more options

Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings

Helpful?

more options

Chosen Solution

Note that the Firefox 60.0 version you appear to be using according to the System Details list is rather old and is no longer supported.

Try to disable IPv6 (check for other possible causes as well).

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Check also the DNS Lookup tool on the about:networking#dnslookuptool page..

Helpful?

more options

Thank you very much! Disabling ipv6 did the trick!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.