Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TB 68.12.0 doesn't cache unsaved password during session

  • 14 replies
  • 1 has this problem
  • 29 views
  • Last reply by svlad2009

more options

Hello everybody.

I'm experiencing a behaviour of Thunderbird different than usual (I use it from the first version). I don't save e-mail passwords and there are no saved password in the password manager. With previous TB versions, I used to type password once for each account's POP/IMAP server (incoming messages) and once for each account's SMTP server (outgoing). With 68.12.0, it seems that password are cached for a limited amount of time and I need to retype them more times during session, but moreover it asks for password only if I click on an IMAP folder: this means that accounts which are setup to look for new messages each 10 minutes, silently fail to look for new messages because password isn't cached and there is no request for password; so I think that I have no new messages while instead there are a lot of them! This happens with different servers from different providers. I've looked in the release notes but find nothing, looked in the community but there are mainly issues with saved passwords. Any advise?

Thank you. Matteo

Hello everybody. I'm experiencing a behaviour of Thunderbird different than usual (I use it from the first version). I don't save e-mail passwords and there are no saved password in the password manager. With previous TB versions, I used to type password once for each account's POP/IMAP server (incoming messages) and once for each account's SMTP server (outgoing). With 68.12.0, it seems that password are cached for a limited amount of time and I need to retype them more times during session, but moreover it asks for password only if I click on an IMAP folder: this means that accounts which are setup to look for new messages each 10 minutes, '''silently fail''' to look for new messages because password isn't cached and there is no request for password; so I think that I have no new messages while instead there are a lot of them! This happens with different servers from different providers. I've looked in the release notes but find nothing, looked in the community but there are mainly issues with saved passwords. Any advise? Thank you. Matteo

All Replies (14)

more options

There is no password caching with Thunderbird. If you want to avoid typing the password again and again you can tell Thunderbird to remember the password (or the OAuth2 authentication token respectively).

more options

Ok, thank you.

Do you know when this behaviour changed? A link to release notes? I never had in over 15 years to type passwords again and again...

more options

Onelli said

I never had in over 15 years to type passwords again and again...

Out of curiousity, what is your reason for not having Tbird remember/store your passwords?

more options

Stans said

Out of curiousity, what is your reason for not having Tbird remember/store your passwords?
  1. memory exercise  :-)
  2. pc at work with also personal accounts (I don't want that anybody hits "show saved passwords"; I know that from version 72 TB should ask for OS password when doing, I will check this when I will upgrade, waiting for extensions porting... Never wanted to set a master password, I preferred this way)
  3. ability to choose day by day for which accounts I want to download and read new messages, by typing the password or not (since some are personal, sometimes I don't need to read them at work)
more options

Have you ever considered using multiple Thunderbird profiles, one for work and another for personal accounts? Did you know you could even store your Thunderbird profiles in an encrypted container, which you mount (only after supplying the decryption password) before starting Tbird, then unmount it after you're done with Tbird? This way, the only password you keep entering is the decryption password, then you choose which Tbird profile to launch (work or personal, via convenient shortcuts; one for each profile). You won't have to worry about someone else accessing the Tbird password store, even if they had file access to the encrypted container, they would not be able to mount or unlock it without the decryption key.

more options

Another option can be that somehow the passwords to fail to be saved/read because of some corrupted data or files. So then I will try this: First be sure that you have all your passwords (backup them somewhere). After that close TB and delete all saved passwords by moving* to desktop(?) key3.db, key4.db, cert9.db and logins.json files - start TB and it should ask again for all passwords.

To find those files - in TB at the top right of the Thunderbird window, click the menu button (or use the regular menu at the top), then select Help -> Troubleshooting Information. On profile area click Open Folder

p.s. moving* to desktop (but not just delete) it's important so you can have though a backup for those settings in case something is not right

Modified by svlad2009

more options

Stans said

Have you ever considered using multiple Thunderbird profiles, one for work and another for personal accounts?

Yes but I can't use them at the same time.

Did you know you could even store your Thunderbird profiles in an encrypted container, which you mount (only after supplying the decryption password) before starting Tbird, then unmount it after you're done with Tbird?

I know, but it's complicated and doesn't make any difference if I leave my pc for some minutes without locking; with the way TB worked the past years, everything was simple and reliable, now at least for me it's a little less reliable.

Regards. Matteo

more options

Onelli said

Yes but I can't use them at the same time.

Yes you can.

more options

svlad2009 said

So then I will try this: First be sure that you have all your passwords (backup them somewhere). After that close TB and delete all saved passwords by moving* to desktop(?) key3.db, key4.db, cert9.db and logins.json files - start TB and it should ask again for all passwords.

Thank you very much for the suggestion. I removed the four files but unfortunately no difference. It even asks for password for IMAP inbox, then again if I click on IMAP Drafts of the same account, then again if I click on IMAP Sent, and so on; the second time I click on an IMAP folder, it doesn't ask again for password for some time (still I don't know exactly how long). Could it be a network setting, related to connection with IMAP servers?

Bye. Matteo

more options

Can you post here your Thunderbird Troubleshooting information, so we can see your settings and try to duplicate on a same settings (on other servers, if it will be possible)?

At the top right of the Thunderbird window, click the menu button (or use the regular menu at the top), then select Help: Troubleshooting Information. Click the "Copy text to clipboard" button. Do not check the box "Include account names" Then paste (Ctrl-V), the text into your response here. We only need to see the sections down to and including the "Extensions" section, so you can delete the rest. Also, please mention us, from those accounts (will be account2, account3, and so on) which one(s) is/are with that issue and I would try to duplicate on a same settings (on other servers, if it will be possible).

more options

svlad2009 said

Can you post here your Thunderbird Troubleshooting information, so we can see your settings and try to duplicate on a same settings (on other servers, if it will be possible)?

Of course; sorry but the log is in italian. Thank you.

Informazioni di base Nome: Thunderbird Versione: 68.12.0 ID build: 20200820223055 Canale di aggiornamento: release User agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Thunderbird/68.12.0 SO: Windows_NT 10.0 Processo launcher: Attivo Finestre multiprocesso: 0/0 Disattivato Processi remoti: 0 Criteri a livello aziendale: Disattivati Chiave servizio Google Location: Non presente Chiave servizio Google Safebrowsing: Non presente Chiave per georilevazione di Mozilla: Non presente Modalità provvisoria: false Account di posta e news account2: INCOMING: account2, , (none) Local Folders, plain, passwordCleartext account3: INCOMING: account3, , (rss) News & Blogs, plain, passwordCleartext account4: INCOMING: account4, , (imap) imaps.aruba.it:993, SSL, passwordCleartext OUTGOING: , smtps.aruba.it:465, SSL, passwordCleartext, true account5: INCOMING: account5, , (imap) imap.mail.yahoo.com:993, SSL, OAuth2 OUTGOING: , smtp.mail.yahoo.com:465, SSL, passwordCleartext, true account6: INCOMING: account6, , (imap) imaps.securesites.it:993, SSL, passwordCleartext OUTGOING: , out.postassl.it:465, SSL, passwordCleartext, true account7: INCOMING: account7, , (nntp) cnews.corel.com:119, plain, passwordCleartext OUTGOING: , out.postassl.it:465, SSL, passwordCleartext, true account12: INCOMING: account12, , (nntp) discussion.autodesk.com:119, plain, passwordCleartext OUTGOING: , out.postassl.it:465, SSL, passwordCleartext, true account14: INCOMING: account14, , (imap) in.postassl.it:993, SSL, passwordCleartext OUTGOING: , out.postassl.it:465, SSL, passwordCleartext, true OUTGOING: , out.postassl.it:465, SSL, passwordCleartext, false account16: INCOMING: account16, , (imap) imapmail.libero.it:993, SSL, passwordCleartext OUTGOING: , smtp.libero.it:465, SSL, passwordCleartext, true account17: INCOMING: account17, , (imap) imap.gmail.com:993, SSL, OAuth2 OUTGOING: , smtp.gmail.com:465, SSL, OAuth2, true account21: INCOMING: account21, , (imap) mbox.cert.legalmail.it:993, SSL, passwordCleartext OUTGOING: , sendm.cert.legalmail.it:465, SSL, passwordCleartext, true Segnalazioni di arresto anomalo degli ultimi 3 giorni Processi remoti Tipo: Numero Estensioni Nome Versione Attiva ID Amazon.it 1.1 true amazon@search.mozilla.org Bing 1.0 true bing@search.mozilla.org CompactHeader 3.0.0beta5 true {58D4392A-842E-11DE-B51A-C7B855D89593} DeepDark 13.1.5 true {d5e81018-f07b-4719-b893-3dc450504672} DuckDuckGo 1.0 true ddg@search.mozilla.org duplicateContactsManager 2.1.1 true duplicateContactsManager@ddvo.net Enigmail 2.1.7 true {847b3a00-7ab1-11d4-8f02-006008948af5} Folder Pane View Switcher 3.1.4 true FolderPaneSwitcher@kamens.us gContactSync 3.1.7 true gContactSync@pirules.net Google 1.0 true google@search.mozilla.org ImportExportTools NG 4.1.0 true ImportExportToolsNG@cleidigh.kokkini.net Lightning 68.12.0 true {e2fda1a4-762b-4020-b5ad-a41df1933103} LookOut (fix version) 2.0.4 true lookout@s3_fix_version Manually sort folders 2.0.2 true tbsortfolders@xulforum.org PrintingTools NG 0.1.3 true PrintingToolsNG@cleidigh.kokkini.net Remove Duplicate Messages (Alternate) 0.4.1 true {a300a000-5e21-4ee0-a115-9ec8f4eaa92b} ShowFolderSize-T 0.2.9.2 true ShowFolderSize-T@Toshi_ Subject Cleaner 2.0.0 true subjectcleaner@mozilla.extensions Wikipedia (it) 1.0 true wikipedia@search.mozilla.org Software di sicurezza Tipo: Nome Antivirus: Windows Defender Antivirus Antispyware: Firewall: Windows Firewall Preferenze importanti modificate accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.amount_written: 0 browser.cache.disk.capacity: 25600 browser.cache.disk.enable: false browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.enabled: false browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.memory.capacity: 30720 browser.cache.offline.capacity: 5120 browser.cache.offline.enable: false browser.display.background_color: #323232 browser.display.document_color_use: 2 browser.display.foreground_color: #c8c8c8 dom.apps.reset-permissions: true extensions.lastAppVersion: 68.12.0 general.autoScroll: false gfx.blacklist.suggested-driver-version: 257.21 gfx.crash-guard.d3d11layers.appVersion: 68.12.0 gfx.crash-guard.d3d11layers.deviceID: 0x06dd gfx.crash-guard.d3d11layers.driverVersion: 21.21.13.7783 gfx.crash-guard.d3d11layers.feature-d2d: true gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.d3d11video.appVersion: 68.12.0 gfx.crash-guard.d3d11video.deviceID: 0x06dd gfx.crash-guard.d3d11video.driverVersion: 21.21.13.7783 gfx.crash-guard.status.d3d11layers: 2 gfx.crash-guard.status.d3d11video: 2 gfx.crash-guard.status.d3d9video: 2 gfx.crash-guard.status.wmfvpxvideo: 2 gfx.crash-guard.wmfvpxvideo.appVersion: 68.12.0 gfx.crash-guard.wmfvpxvideo.deviceID: 0x06dd gfx.crash-guard.wmfvpxvideo.driverVersion: 21.21.13.7783 gfx.direct2d.disabled: false gfx.direct3d.last_used_feature_level_idx: 0 idle.lastDailyNotification: 1601457744 layers.acceleration.disabled: false layers.mlgpu.sanity-test-failed: true media.benchmark.vp9.fps: 227 media.benchmark.vp9.versioncheck: 4 media.gmp.storage.version.observed: 1 media.hardware-video-decoding.failed: false network.cookie.cookieBehavior: 1 network.cookie.lifetimePolicy: 2 network.cookie.prefsMigrated: true network.predictor.cleaned-up: true network.protocol-handler.warn-external.http: true network.protocol-handler.warn-external.https: true places.database.lastMaintenance: 1600939119 places.history.enabled: false places.history.expiration.transient_current_max_pages: 112348 plugin.importedState: true plugin.state.flash: 0 plugin.state.npctrl: 0 plugin.state.npdeployjava: 0 plugin.state.npnv3dv: 0 plugin.state.npnv3dvstreaming: 0 plugin.state.nppdf: 0 plugin.state.npspwrap: 0 plugins.update.notifyUser: true print.always_print_silent: false privacy.donottrackheader.enabled: true security.disable_button.openCertManager: false security.disable_button.openDeviceManager: false security.OCSP.disable_button.managecrl: false security.sandbox.content.tempDirSuffix: {3c11020d-ba61-4c50-b350-d818c0914e69} security.sandbox.plugin.tempDirSuffix: {4428b082-9a95-45d0-b6d1-b6ae82c10359} signon.importedFromSqlite: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1598968137 ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.
more options

And you have this issue for all imap accounts from above or only for some of them?

more options

svlad2009 said

And you have this issue for all imap accounts from above or only for some of them?

All of them. But today working at home I see that TB 60.3.2 I have at home, that always did as I told (password not saved, typed one time for session for each account), does the same! So it could be something related to network (a windows update??) or to providers' servers that all together (strange...) changed something in IMAP connections configuration, and not depending from Thunderbird... When I will have time I will recreate from scratch the user profile to see if something changes.

Thank you. Matteo

more options

I just tried to duplicate your case on an imap account on v78.3.1 but I could not do it... Once the password was saved for that account I could not get on the same session a request for pass.

I have found though on my computer these lines different: network.cookie.cookieBehavior: 1 --> mine is 0 network.cookie.lifetimePolicy: 2 --> mine is 0 The values from my computer are default ones which are mentioned on https://developer.mozilla.org/en-US/docs/Mozilla/Cookies_Preferences while yours should mean some "restrictions"... Can you check on your 60.3 version how are those? Or maybe you can play directly on this non-working TB?