Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird Linux keeps asking for passwords where it didn't before

  • 27 replies
  • 6 have this problem
  • 158 views
  • Last reply by Toad-Hall

more options

Here's how it used to work and how I would like it to work: I start Thunderbird, it requests password(s). After I enter them correctly, Thunderbird scans for new mail and will periodically scan for new mail. I could scan sub-folders like sent or trash without entering a password. Sending email requires inputting the password the first time. This behavior used to persist until I closed Thunderbird.

Here's how it is working now: I start Thunderbird, it requests password(s). After I enter them correctly, Thunderbird scans for new mail. Initially I can enter sub-folders soon after startup without entering a password. After some number of minutes if I click on the inbox or do a "get new mail" or enter a sub-folder, it requires I enter the password again. Thunderbird no longer checks for new mail as it seems to have forgotten the password(s) I entered. Sending an email requires entering the password every time to send, and entering the password again every time so it can be copied to the sent folder.

I've been using Thunderbird for decades and this new behavior is very frustrating. 

I recently converted one of my emails (yahoo) to oauth2 as yahoo imap will soon be disabled. I noticed the new behavior after this change, but cannot definitely attribute the undesirable behaviour to this change. After this change, the yahoo account no longer requires entering the password upon opening Thunderbird, for entering sub-folders or sending mail. This appears to be persistent.

What I've tried with no success: Run Thunderbird with addons disabled - undesired behaviour. Reinstall current version of Thunderbird - undesired behaviour. Reinstall older version of Thunderbird (clean profile forced) - undesired behaviour. Reinstall current version of Thunderbird with no yahoo account - undesired behaviour. Reinstall older version of Thunderbird (clean profile forced) with no yahoo account - undesired behaviour.

Any assistance that could be provided would be greatly appreciated.

Here's the pertinent troubleshooting info: Name Thunderbird Version 68.12.0 Build ID 20200820223055 User Agent Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.12.0 OS Linux 4.19.0-10-amd64 Profile Directory (Local drive) Build Configuration about:buildconfig Memory Use about:memory Performance about:performance Registered Service Workers about:serviceworkers Multiprocess Windows 0/0 Disabled Remote Processes 0 Enterprise Policies Inactive Google Location Service Key Missing Google Safebrowsing Key Missing Mozilla Location Service Key Missing Safe Mode false Profiles about:profiles Mail and News Accounts ID Incoming server Outgoing servers Name Connection security Authentication method Name Connection security Authentication method Default? account2 (none) Local Folders None Normal password account3 (imap) imap.gmx.net:993 SSL/TLS Normal password mail.gmx.net:587 SSL/TLS Normal password true account4 (imap) imap.googlemail.com:993 SSL/TLS Normal password smtp.googlemail.com:587 SSL/TLS Normal password true account5 (imap) imap.mail.yahoo.com:993 SSL/TLS OAuth2 smtp.mail.yahoo.com:465 SSL/TLS Normal password true

All Replies (20)

more options

I have this issue with Thunderbird 78.2.2 (64-bit) on MacOS 10.14.6.

more options

First, the authentication on the gmail account should be OAuth2, for incoming and outgoing, and same for the Yahoo account, which currently has 'normal password' for the smtp. The gmx smtp security should be either STARTTLS on port 587 or SSL/TLS on port 465.

https://support.gmx.com/pop-imap/imap/server.html

Check that cookies are enabled in TB Options/Privacy to ensure OAuth works properly. From Help/Troubleshooting, click Open Directory (Show in Finder on OS X, Open Folder on Win) for Profile Folder, close TB, delete or rename key4.db, logins.json, cert9.db and pkcs11.txt to remove all password data, then restart TB and enter the password when prompted in the normal password box or the OAuth browser window.

http://kb.mozillazine.org/Password_not_remembered_-_Thunderbird

more options

sfhowes said

First, the authentication on the gmail account should be OAuth2, for incoming and outgoing, and same for the Yahoo account, which currently has 'normal password' for the smtp. The gmx smtp security should be either STARTTLS on port 587 or SSL/TLS on port 465. https://support.gmx.com/pop-imap/imap/server.html Check that cookies are enabled in TB Options/Privacy to ensure OAuth works properly. From Help/Troubleshooting, click Open Directory (Show in Finder on OS X, Open Folder on Win) for Profile Folder, close TB, delete or rename key4.db, logins.json, cert9.db and pkcs11.txt to remove all password data, then restart TB and enter the password when prompted in the normal password box or the OAuth browser window. http://kb.mozillazine.org/Password_not_remembered_-_Thunderbird

Thanks for the response.

Changing the gmail acct to OAuth made that account no longer "forget" the login password. This is totally understandable since it now bypasses the TB password logic. This account was working with the config above (normal password) before whatever caused this problem.

The GMX acct's problem is with forgetting the IMAP password, so changing the SMTP port/security has no effect. Even after deleting the 4 files, this account is still not working, acting the same as described above in post 1. Here's the new current config:

Mail and News Accounts ID Incoming server Outgoing servers Name Connection security Authentication method Name Connection security Authentication method Default? account2 (none) Local Folders None Normal password account3 (imap) imap.gmx.net:993 SSL/TLS Normal password mail.gmx.net:465 SSL/TLS Normal password true account4 (imap) imap.googlemail.com:993 SSL/TLS OAuth2 smtp.googlemail.com:465 SSL/TLS Normal password true account5 (imap) imap.mail.yahoo.com:993 SSL/TLS OAuth2 smtp.mail.yahoo.com:465 SSL/TLS Normal password true

Nothing else has changed from the config in the first post. To keep it usable, however, I'm having to save the password for the GMX acct when I'm not testing to try and resolve the problem.

more options

sfhowes said

First, the authentication on the gmail account should be OAuth2, for incoming and outgoing, and same for the Yahoo account, which currently has 'normal password' for the smtp. The gmx smtp security should be either STARTTLS on port 587 or SSL/TLS on port 465. https://support.gmx.com/pop-imap/imap/server.html Check that cookies are enabled in TB Options/Privacy to ensure OAuth works properly. From Help/Troubleshooting, click Open Directory (Show in Finder on OS X, Open Folder on Win) for Profile Folder, close TB, delete or rename key4.db, logins.json, cert9.db and pkcs11.txt to remove all password data, then restart TB and enter the password when prompted in the normal password box or the OAuth browser window. http://kb.mozillazine.org/Password_not_remembered_-_Thunderbird

Thanks for the input.

Changing the gmail acct to OAuth, of course, caused that account to no longer forget the password. This is obvious since it now no longer uses the TB password logic. The gmail acct was not forgetting the password with the config in post 1 before whatever caused this issue happened.

The GMX acct problem is with the IMAP side, not the SMTP side, so changing the SMTP config did not affect that. Even after renaming the 4 profile files, the problem persists.

Here's the current accounts config:

Mail and News Accounts ID Incoming server Outgoing servers Name Connection security Authentication method Name Connection security Authentication method Default? account2 (none) Local Folders None Normal password account3 (imap) imap.gmx.net:993 SSL/TLS Normal password mail.gmx.net:465 SSL/TLS Normal password true account4 (imap) imap.googlemail.com:993 SSL/TLS OAuth2 smtp.googlemail.com:465 SSL/TLS Normal password true account5 (imap) imap.mail.yahoo.com:993 SSL/TLS OAuth2 smtp.mail.yahoo.com:465 SSL/TLS Normal password true

Nothing else has changed in the config in post 1 except that when not testing this issue, I have saved the password so that TB still functions reasonably.

more options

I don't know why my quote reply doesn't get posted. Is there a moderator needing to approve them? Sorry if this is repeated

Thanks for the input.

Changing the gmail acct to OAuth, of course, caused that account to no longer forget the password. This is obvious since it now no longer uses the TB password logic. The gmail acct was not forgetting the password with the config in post 1 before whatever caused this issue happened.

The GMX acct problem is with the IMAP side, not the SMTP side, so changing the SMTP config did not affect that. Even after renaming the 4 profile files, the problem persists.

Here's the current accounts config:

Mail and News Accounts ID Incoming server Outgoing servers Name Connection security Authentication method Name Connection security Authentication method Default? account2 (none) Local Folders None Normal password account3 (imap) imap.gmx.net:993 SSL/TLS Normal password mail.gmx.net:465 SSL/TLS Normal password true account4 (imap) imap.googlemail.com:993 SSL/TLS OAuth2 smtp.googlemail.com:465 SSL/TLS Normal password true account5 (imap) imap.mail.yahoo.com:993 SSL/TLS OAuth2 smtp.mail.yahoo.com:465 SSL/TLS Normal password true

Nothing else has changed in the config in post 1 except that when not testing this issue, I have saved the password so that TB still functions reasonably.

Modified by gargamon

more options

Messages with links are moderated, which delays their appearance.

I don't know why the gmx account isn't working (does it have 2-factor authentication?), but your last post shows 'normal password' for the gmail and yahoo smtp servers. If it's OAuth2, the smtp will apply the same oauth token stored in Saved Passwords that is applied by the incoming server.

more options

It's very strange. GMX and Gmail have been working the way I want for years and now the strange operation. Since the same issues were there when using an entered password for gmail before changing it to OAuth, it must be an issue with TB. The other Mac user indicated he had similar problems, but we have no details so it's hard to determine the accuracy of that.

Is there some way we can debug this with logging? Is there a debug TB I can install that can give more info?

more options

There is a support article on logging:

http://kb.mozillazine.org/Session_logging_for_mail/news

but I wouldn't get too optimistic about this helping with the problem. There are many TB users with gmx and gmail accounts, and if this were a TB issue, we would see many more complaints.

You might want to create a new profile from Help/Troubleshooting, about:profiles, add an account, and see if the problem remains.

more options

I have created a new clean profile and tested with no addons as described in post 1. The problem was still not as desired.

I think there may not be many TB users from GMX or Gmail that don't use OAuth or save their passwords, which may explain why there aren't a lot of complaints. I have always entered my password(s) every time I start TB, and it has worked fine until recently...

more options

To emphasise that I have the same problem (running Linux 5.4.0-48-generic #52-Ubuntu, and Thunderbird 68.10.0 64-bit). Exactly as "gargamon" describes, Yahoo required OAuth to be set as the IMAP authentication factor, but after that the other four accounts I have attached to Thunderbird (none of them is Gmail), which all have "Normal Password" IMAP authentication, frequently re-prompt for password and fail to save draft messages to the remote server if I take too long to compose an email. I haven't measured the timeout period but fancy it's about ten minutes.

Yahoo does not prompt for its (imap) password at startup. The other accounts do, and I do not really want to switch this off (and can't find out how to), as an extra layer of security to prevent unauthorised access to my emails. I solved the problem only by removing Yahoo from the accounts attached to Thunderbird, which is inconvenient since now I have to log on to Yahoo webmail to get my emails.

more options

Since updating to 78.4.0 I have this problem too in Windows 10 on a pop3 email account. Password is not saved on this account. TB used to require I enter the password only upon TB launch then it would remember the password as long as my TB session was open. Now in a single TB session TB is asking me for the password what seems like all the time.

more options

I had exactly the same problem which also started when a yahoo account was changed to Oauth2. Running Thunderbird with addons disabled made no difference. Removing the yahoo Oauth2 password that had automatically been saved, turning cookies off and resetting the yahoo account back to the original settings before the Oauth2 change has restored everything to normal. My btinternet and gmx accounts and the yahoo account all work again as they did originally.

January 2021 The yahoo account has started rejecting the password and the same account on my mobile phone, which never had a problem before, has stopped working and reports an authentication failure. Yahoo apparently considers some email apps to be insecure but by logging in using the yahoo mail website it is possible to generate a password for a particular app which can be used to login from e.g Thunderbird. Unfortunately the generated passwords are not easy to remember. The original password must still be used to login to the yahoo mail website.

Modified by f.9

more options

I too have this issue but in Windows: W7 78.5.1 (32-bit) I think it started when I updated to this release but I'm not sure.

I have 5 accounts on 3 servers. The only one that does not seem to have an issue is the yahoo one. The others are SSL/TLS Normal Password. The issue affects SMTP as well as IMAP.

Modified by Befuddled

more options

It seems like it does not remember pw when switching from one folder to another, but I'm not sure.

Most disturbingly, when it forgets, it simply does not get new mail. If I use the Get Messages, nothing happens, no pw request, no Activity.

I have not blocked cookies.

more options

Well, it looks like *MANY* people have the same issue. As a work-around, I have set TB to remember all my passwords. As this is not the desirable situation, it is only a work-around.

I will not be setting this issue to *SOLVED* while the issue still exists...

more options

In OSX, after creating an Oauth POP account, TBird is suddenly asking me for the passwords to my previously existing POP accounts, EVERY TIME I Send or Download. Previously (that's for many years) it only asked once, after restarting TBird.

So why does the existance of an Oauth authentication cause everything else to screw up?

https://support.mozilla.org/en-US/questions/1318778

more options

I somewhat recently updated to thunderbird 78 and also see this issue. My email provider is kolabnow and I use the Normal Password authentication method, and it doesn't remember my password throughout the entire session anymore. Used to be able to login once at startup and then not have to worry about it. I don't want thunderbird remembering this password but I also am tired of typing it in every 10 minutes. Would love to see a solution.

Befuddled said

It seems like it does not remember pw when switching from one folder to another, but I'm not sure.

I think it might be because when you switch folders, it triggers a message download from the server, which it needs the password for if it has been forgotten since you last typed it in.

more options

@f.9 offered an updated post/solution which worked for me after Thunderbird started rejecting my Yahoo! password yesterday: Went into my Yahoo! Mail account through the web... > Account > Security > Generate Password (-OR- App Password > Add Password). The pulldown menu does not offer "Thunderbird" as an app, so I needed to pull down to "Other" and add "Thunderbird". I went back to Thunderbird and used the weird generated password and saved it as well. One can "regenerate" a new password at any time.

Everything is fine now.

Thank you, @f.9

more options

It was working as the op described up to yesterday, with Thunderbird 78.7.1. While wrangling an issue with Yahoo mails (in the end I just deleted the account and recreated them with OAuth) and possibly after entering Safe Mode once, everything broke.

I use an external password manager for security since it's my work machine, and Thunderbird keeps ignoring the sessions. While before it would ask the password once, and use it/use the sessions over and over again without asking more than once, it now asks for e-Mails every single time it needs to check or download new e-Mails, effectively breaking all usage of the app.

Several of the mail accounts are internal, so there's no OAuth provider, and letting Thunderbird save the passwords is a no go either. If anyone has any idea how to restore basic functionality, let me know, this is ultra bad.

more options

Found the culprit, this is one hell of a bug. Out of pure hatred I removed the OAuth account which is the least important. Everything works again, passwords are remembered.

When I add the account back it sort of works, but not quite, and then I find it: all the passwords are forgotten as soon as any OAuth connection is made.

So in the meanwhile I limited the OAuth accounts to just download the e-Mails once, when ThunderBird starts, and then never more. That way I only have to input the same passwords once or twice, and then it works as intended. Here's the bug filed 6 months ago: https://bugzilla.mozilla.org/show_bug.cgi?id=1661337

  1. 1
  2. 2