Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

To, CC and BCC

  • 64 replies
  • 13 have this problem
  • 3041 views
  • Last reply by thomas8

more options

I've read a lot of help on this - almost all of them say, "As you have discovered there are three visible TO/Cc/Bcc fields..." and: " type or select email address and press enter to move to next TO field".

None of that works. I have only ONE visible "To" field. It has no controls to change it to a Cc or Bcc one. There is a "CC" or "BCC" option beside the "From" field. Pressing Enter at the end of an address does precisely nothing.

Another copy of TB on another computer has all the features you gaily point to - but mine doesn't. Where do I find it?

Chosen solution

Thunderbird 78 has changed compared to Thunderbird 68, that's why you see this discrepancy. In 68, the field name is a dropdown list, and you can change To to CC/BCC. In 78, however, you can add CCs and BCCs by clicking on the text buttons beside the To field.

Read this answer in context 👍 1

All Replies (20)

more options

Chosen Solution

Thunderbird 78 has changed compared to Thunderbird 68, that's why you see this discrepancy. In 68, the field name is a dropdown list, and you can change To to CC/BCC. In 78, however, you can add CCs and BCCs by clicking on the text buttons beside the To field.

Helpful?

more options

Meskó Balázs; Thanks!

Helpful?

more options

The solution offered does not let you have more than one CC and another single BCC per message. How do you overcome this please?

Helpful?

more options

You can add more recipients, just put a semicolon between them, and press Enter after the last one (this will turn the text into bubbles). E.g.:

   test1@example.com; test2@example.com <Enter>

will like the one in the screenshot

Helpful?

more options

Thank you, easy when you see how it is done. i was stumped

Helpful?

more options

Hi me again, I tried this but this (for me at least) does not auto fill from your address book once you are past the first one eg test@gmail.com; f the f wont bring up an address book entry.

Helpful?

more options

I have the same problem with more than one CC or/and BCC. I do what the moderator describes. I select CC,enter the first e-mail address which is no problem. When I enter then ; this becomes red and when I type the next addres it stays red and no automatic addresses apear. I tried i with a space after the first cc e-mail address but does not work either. I get a message that the second address is not known. Hope that soon a solution is coming. How can I return to a previous version?

Helpful?

more options

I suppose the only not so good interim solution is to create ""New Lists"in the Address Book with e mail addresses in there. This is messy and subject to error. You would have to keep a list of ""New Lists"" and who is in them manually I suppose. Your right, why change something that was working???????????

Helpful?

more options

the solution doesn't work, need to go back to allowing us to select BCC or CC for each email address. I tried building a distribution list but you can't bcc on the address. not sure why someone thought it was necessary to fix something that wasn't broken.

Helpful?

more options

It now works on my machine??????? The multiple addresses that is in any field, to, cc, bcc I did not do anything.

Helpful?

more options

Now I got it working. Start with filling in the to: adress, then hit CC and fill in the address in the old standard way. For the next cc's you have to go to the address book select the address you want, then click on the CC button the middle one of the three buttons ,To, CC and BCC which you see below.

Helpful?

more options

Hi b.dyk. I do not know what is going on but my e-mail fields are working exactly as they did before the upgrade. I suspect that a ""tweak"" has been done and no-one has told anyone. I did this:

To joelow@etc (selected the recipient from the drop down bow, typed in r next to the address already there and selected the recipient etc

Then I hit the CC tab and did the same and then I hit the BCC tab and did the same.

Helpful?

more options

Hi Brett, I do not know what is going on. I did what you wrote and it works. Whatever I try at this moment I works as before not any problem. I type the address via To: etc. then CC. type b and see all b adressees coming then I type S and see all s addressees coming as second CC.

Do we have a self learning system ???

Helpful?

more options

Nah, we have some sneaky people in the back ground who have fixed it and not bothered to tell anyone.

Helpful?

more options

The "solutions" offered do not work. This problem needs to be fixed by Thunderbird. Ridiculous that they would change what has been working just fine forever.

Helpful?

more options

Sorry guys for all the confusion. (Please do *not* start using semicolon to separate your recipients!)

Here comes the authoritative answer for all your questions (from someone who was involved in improving the new design):

As correctly mentioned in the current answer, the addressing area has been completely redesigned for Thunderbird 78, it's now much easier, more intuitive, and more efficient than before, so the behaviour has also changed. However, adding several recipients in TO/CC/BCC works almost exactly as before:

  • To add more recipients of the same type: Type (and autocomplete) recipient 1, press Enter (just once!). Type recipient 2, press Enter (once). Now you have two recipients of the same type in the same row.
  • If you need CC or BCC, click the disclosure buttons [CC] [BCC] next to From: field, or [>>] to open the input fields for other address types. There are many other ways and useful tricks, please find the full information here:

https://support.mozilla.org/en-US/kb/new-thunderbird-78#w_new-addressing-area https://support.mozilla.org/en-US/kb/addressing-email (make sure this article has a "Changes to the addressing area in Thunderbird 78" section, otherwise it's outdated).

I've linked the authoritative English version which has been updated, as updated localizations may not yet be available, and the first deep link may be different for other languages.

(This answer should be marked as accepted answer!)

Modified by thomas8

Helpful?

more options

I am getting used to the revisions but I now have to take an extra step to send email.

If I place a single recipient in the TO field, the SEND field remains grayed-out. If I click on CC or BCC to make either appear under the TO, the SEND field immediately works and I can send the email to the single recipient.

I can get used to that second step, but is that the way it's supposed to work?

Helpful?

more options

No, that's not how it's supposed to work... (It's arguably a bug, but...)

You just need to press Enter, Tab, or comma (in order of preference) after typing your recipient, or even just click anywhere else outside the recipient row so that it will lose focus, which triggers autocompletion and conversion into a proper recipient item. Plain-text recipients must turn into recipient items ("pills") before they work for sending.

Please avoid having any plain-text recipients when you choose [Send]. If there's just a single recipient pill anywhere, Thunderbird will silently discard all non-pillified recipients and you may never notice (Bug 1674054).

Helpful?

more options

Thank you for the quick and useful reply! It works and is definitely easier than what I've been doing.

Helpful?

more options

note, just my two cents, BUT REMOVING PRIMIARY VISIBLE BCC lines is NUTSSS !! This is a security issue, in my opinion. I use BCC almost exclusively, and to have to take a separate extra step to select this line, so that I can safely hide group lists, etc, is a step in the wrong direction.

I continually encourage others to use BCC as gropu option, and to remove this just so an interface looks pretty and easier, is nuts.

SECURITY is important, and to have emailers blindly enter stuff in the TO line, to me, is a wrong direction.

again, just my peon two cents.

Helpful?

  1. 1
  2. 2
  3. 3
  4. 4
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.