Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

add-on that work in v68 re vs. v78

  • 10 replies
  • 2 have this problem
  • 31 views
  • Last reply by Andrew

more options

When I upgraded from 60 to 68, I had to get all my add-ons back and some had not been updated to the new format. It took a bit of work and asking help on the forums. Will this happen again if I update to 78, i.e. will my add-ons that worked in 68 no longer be functional?

As a related issue, it appears that 78 is still very much a work in progress. For how long will 68 still be maintained an updated? I like it as is and am in no hurry to upgrade.

Thank you.

When I upgraded from 60 to 68, I had to get all my add-ons back and some had not been updated to the new format. It took a bit of work and asking help on the forums. Will this happen again if I update to 78, i.e. will my add-ons that worked in 68 no longer be functional? As a related issue, it appears that 78 is still very much a work in progress. For how long will 68 still be maintained an updated? I like it as is and am in no hurry to upgrade. Thank you.

All Replies (10)

more options

Here is a current list of 78-compatible add-ons:

https://cleidigh.github.io/ThunderKdB/xall/extension-list-tbmx.html

Auto-updates from 68 to 78 have begun in a gradual process, so updates to the 68 branch will soon end, although you can remain with it indefinitely if auto-updates are disabled on your setup.

more options

Actually, updates to 68 have already ended with 68.12.0 - there will be no more updates.

Reporter, it would be easier to address your needs if you listed your add-ons, and highlight the few that are most needed.

more options

Thank you both. I only use a few add-ons and they are these: FileLink Provider for Box HeaderTools Lite PopmailListRecipients

It looks like all but HeaderTools Lite are listed in the link that sfhowes provided. HeaderTools Lite is one I use regularly and would be very unhappy without it. I don't recall the name, but there was another header editing program that I tried when v68 came along (and broke prior add ons) but as I recall its changes would only apply to the machine on which the change was made and not to the imap database. At any rate I found it unsuitable. HeaderTools Lite is great.

Any help would be appreciated.

Also, apparently the only way to run of auto updates is to make a registry hack. Is that correct?

Any finally, why all the changes to TBird? It seemed like 68 made big changes that were not compatible and now again. It sure makes it difficult to just continue using and rely upon TBird without having to do all the fiddling.

Thank you.

more options

To your last question - change is inevitable, and necessary. Our underlying architecture changes, driven by changes made by Firefox. In the case of Thunderbird 78 it is a continuation of the changes that started in Thunderbird 68 - because unlike Firefox who finished their changes in 68 we lessened the pain in TB 68 by not forcing every change, so now Thunderbird is playing catch up. The good news is, that architectural change is now finished for Thunderbird.

Kinda like the other saying, time stand still for no man, aka time and tide wait for no man.

more options

In the absence of HeaderTools Lite for 78, there is an add-on that performs one function in 78:

https://addons.thunderbird.net/en-us/thunderbird/addon/edit-email-subject/

more options

Thank you. I wonder if it provides the same functionality as does headtoolslite for that one feature. I can I can uninstall headertoolslite and install the prior version of edit-email-subject in my v68 and check it out, to get some idea.

more options

This time around here are a lot of add-ons broken Some that add functionality that TB needs. Like better rules creation using Quickfilters and Lightning colours reminder. I really miss being able to sort my folders into something more sensible than alphabetic order with Manually sort folders. Which is an excellent example of something that should have been implemented in TB since forever. It's an option that hurts no one if they don't want to use it, but can be of very real use to many. But we have to use a third party add-on (now not working).

more options

The developer of quickFilters estimates the end of this month for a version for 78.

Account sorting is under development for the basic TB, but there is also a manual method.

A modified sort add-on for TB 78:

https://github.com/protz/Manually-Sort-Folders/issues/102#issuecomment-698442703

Modified by sfhowes

more options

I can not keep using a tool that keeps dropping it's add-ons that I was depending on. Development has to help add-on folks update their tools or integrate them into TB directly.

I restarted TB and ugh, it went for the upgrade I'd downloaded and now not much works. Several hours later I've reverted to 68.12.1 but several add-ons don't work there. And I'm not longer able to update because of v78.

It took hours to figure out to not copy the comparability file, so I don't get an error message.

  • Font and theme size changer - I picked TB because my eye strain is so much less when I can play with the email display fonts. That hasn't worked since v65.

V78

  • Folders have no colors, not even yellow.
  • Top lines were different - one was missing.

V68 -- Even in V68.12.1 add-ons are no longer working that I really liked/need

  • Ordering folders by my choices
  • Snap header to 1 line and expand again. Found a new add-on for that.
  • I liked send later & color folders.

I'm sure there's other things. Very frustrated. With FF too.

more options

Guess I was lucky - v68.x to v78.x om ubuntu 20.04 opened like a fresh install - all email accounts gone, well over 60,000 emails with them.. but switched back to the "other" Thunderbird (in Ubuntu "Software" that has 2 TB entries one is "latest ver" as v68 other is latest v78.) So lucky in that uninstalled v78 one, and re-installed v68 one and all was back as it was. However I do *need* to upgrade to v78. I went back and forth several times (backing up data dirs) and messing with trying to jam the v68 data in the v78 install data dir, but never any luck besides always being able to go back to v68 as it was. Any thoughts/suggestions/etc much appreciated! (If gogol doesn't ruin the world in a few months after firing 1 of the 2 leads of the Ethics team 5 months ago and firing the other (of 2) yesterday...) but hey.. G & Ethics? Isn't that like an oxymoron anyway? (Besides it was prob actually titled: "Ethics. (how to avoid at all costs)") - just IMHO of course.

Modified by Andrew