Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Spell checker is using the wrong language

  • 1 reply
  • 1 has this problem
  • 5 views
  • Last reply by oneoff01

more options

Firefox is spell checking using the wrong language. I'm using the latest version of Firefox (80.0) on Linux Mint 20 Cinnamon 4.6.7

Originally after installing Linux on the computer, Firefox which came pre-installed was correctly showing English (United Kingdom) on the options screen and spell checking the same.

Test with colour color <- here it is spell checking using American English. On other pages it tests using Canadian English or South African English!

How do I fix this problem so it spell checks using the language I've told it to spell check using, i.e. British English without it keep picking a different one at random?

Attached screenshots

All Replies (1)

more options

I'll just add that if I right click within the text box and show the languages, the long list of languages shows the random language it has chosen being ticked - I can't take a screen dump of this as the list collapses when I click the print screen button. (Picture taken using my phone instead attached...)

I'm also wondering why the Canadian English dictionary is also installed by default? It can't be removed either.