Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox v. 80 Ctrl+F5 and Web Developer Disable Cache Don't Work

  • No replies
  • 1 has this problem
  • 20 views
more options

Prior to Firefox v. 79, when I was developing a web site and needed to clear the cache of cached CSS and javascript files, I could quickly do so using Ctrl+F5.

When v. 79 came out, I had to go into the Web Developer Tools' settings and select "Disable HTTP Cache (when toolbox is open)" or check "disable cache" on the Network Tab. I could have lived with the latter, that's a pretty cool feature. However, with v. 80, that doesn't even work reliably. At times, I have to go into Firefox Preferences -> Privacy and Security -> Clear Data -> Uncheck "Cookies and Site Data" -> and click "Clear."

That's five clicks each time I need to clear the cache while I'm working, when it used to just take a quick Ctrl+F5 key combination.

I've seen some suggestions to disable Firefox caching altogether in about:config, but I don't want to do that because Firefox is my primary browser.

Are there any solutions, or is there a fix forthcoming? I checked Bugzilla and saw some reports of the problem, but didn't see a fix in the works.