Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unnecessary icons in Folder pane

  • 7 replies
  • 1 has this problem
  • 58 views
  • Last reply by Wrigh

more options

The Thunderbird folder pane shows the name of each entry as (icon) name, e.g.

(icon1) Inbox
(icon2) Drafts   etc

The icon is a waste of space. How can I just show the names of the folders? I did find a click box under view\layout\message pane\ (right click) that said text only as an option, but no effect - seems to work the title bar.

All Replies (7)

more options

In Thunderbird:

  • Help > Troubleshooting Information
  • click on 'Open folder' button

a new window opens showing the contents of your Profile folder.

  • Close Thunderbird now - this is important.
  • Create new folder and call it chrome note the spelling - use a lower case 'c' It should be in the same place as the 'Mail' folder.
  • open Notepad
  • Copy everything - all the text between lines below and paste it into the Notepad document.

/*
 
* Do not remove the @namespace line -- it's required for correct functioning
 */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 


/* removed Folder Pane icons and reduced margin*/

#folderTree treechildren::-moz-tree-image{
list-style-image: none !important;
margin-left: -20px;
}


  • Save the document as filename userChrome.css in the 'chrome' folder. Note the spelling all lower case except for the 'C'.

Start Thunderbird.

Please check the code you see in received email with code displayed in the forum as there used to be reports that part of the code which said  !important; had not been correctly sent in email.

Helpful?

more options

Sorry, I've carefully done that, but no change

Helpful?

more options

Then you have not done something correctly.

Please check that the 'userChrome.css' file is spelt correctly and that it is not saved as a text file eg: 'userChrome.css.txt' as I have had some people do that in the past.

Make sure the name and Type column headers are visible Please post image showing where you created the 'chrome' folder Please post image showing where you stored the 'userChrome.css' file Please post image showing all the contents of the 'userChrome.css' file.

In the past I've seen incorrect copies and also some code missing - on same line as: list-style-image: none There should be the word important with an exclamation mark just before it, but for some reason this part of the code has sometimes not been included in the email you get whilst it is shown correctly in the forum.

I could do with knowing if the comment you received in an email that contained the code, has some section of code missing when you compare it to the code as shown in this forum.

Helpful?

more options

Sorry, still no action Thanks for your careful explanation. What have I missed? I can see no difference in the two sets of code. I attach a pic copy of the emailed code as well

Helpful?

more options

I've tested this in Windows 10 on two different profiles: version 68.12.0 and also version 78.1.1 on two separate profiles and both work.

Please confirm: What OS and what version of Thunderbrd are you using?

Confirm you did exit Thunderbird, create all the necessary folders and files and then restart Thunderbird after completing the userChrome.css file. Otherwise Thunderbird would be still running without the chrome folder being known.

The profile name that Thunderbird is running is 8wpatovd.default ? How many 'profile name' folders are there in the Roaming/Thunderbird/Profiles folder ? You should see '8wpatovd.default' folder, but are there more ?

In Thunderbird Help > Troubleshooting Information Bottom of Application Basics: click on 'about:profiles'

Is there more than one profile ?

Helpful?

more options

Check that toolkit.legacyUserProfileCustomizations.stylesheets is true in Options/Advanced/General/Config. editor.

Helpful?

more options

Many thanks to you both. Solved - but your steer to find the variable toolkit....stylesheet - it took a bit of guesswork! The sequence was

   Tools/Options/General/Config Editor
    Accept Dragons warning
     scroll to toolkit.legacyUserProfileCustomizations.stylesheet
    click on this if required to change to TRUE   (it was FALSE)
    Restart Thunderbird

Unless you search on Advanced, there is no mention on the Config Editor button of 'Advanced'

The answers to Toad-Hall's queries (checked after the change above is made)

   Windows 7, 78.2.0 (32-bit)     Exit Thunderbird confirmed

Roaming/Thunderbird/Profiles folder contains:

 8wpatovd.default,  
 8wpatovd.default.old,   
 cwry7tgp.default-release

'About profiles' gives 2 profiles Profile in use 8wpatovd.default 2nd profile available is cwry7tgp.default-release

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.