Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Display security question

  • 1 reply
  • 1 has this problem
  • 11 views
  • Last reply by FredMcD

more options

Ecosia search engine blocked my IP address. To unblock it I have to answer a security question. But this question is not displayed in firefox. How to get it to display? Hint: Am in China, displays in Chrome but I do not want to install it. Linux Mint 20, Firefox 79.0.

Ecosia search engine blocked my IP address. To unblock it I have to answer a security question. But this question is not displayed in firefox. How to get it to display? Hint: Am in China, displays in Chrome but I do not want to install it. Linux Mint 20, Firefox 79.0.

All Replies (1)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop