Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Freezes when uploading photos

  • 3 replies
  • 1 has this problem
  • 456 views
  • Last reply by FredMcD

more options

At first, it was only occasionally. Now Firefox freezes every time I try to upload a photo, and it is a big problem for me! It does it in Facebook, Messenger and even Kijiji. I need to fix this!

Can anyone help? I've reported this to Mozilla more times than I can count.

I have an iMac running El Capitan.

At first, it was only occasionally. Now Firefox freezes every time I try to upload a photo, and it is a big problem for me! It does it in Facebook, Messenger and even Kijiji. I need to fix this! Can anyone help? I've reported this to Mozilla more times than I can count. I have an iMac running El Capitan.

Chosen solution

tmcnamee said

I've reported this to Mozilla more times than I can count.

How have you reported this?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

tmcnamee said

I've reported this to Mozilla more times than I can count.

How have you reported this?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

So far, so good! It appears to have worked. Thank you!

more options

Glad to help. Safe Surfing.