Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Did you mean to go to..." prompt redirects to centurylink.

  • 14 replies
  • 1 has this problem
  • 40 views
  • Last reply by CHduckie

more options

For quite a while now, I've had this issue where at seemingly arbitrary intervals with seemingly arbitrary queries, Firefox will generate a prompt underneath my address bar asking whether I wanted to go to "http://<searchquery>" where <searchquery> is, well, my search query.

This only occurs in a search in the address bar, and any future queries identical to the original <searchquery> will either redirect to a centurylink search engine, or take me to "<searchquery>.com".

This has occurred independent of the operating system (I've discovered this on both Windows and Linux.) This has occurred before on a completely fresh install of Firefox (default settings and no extensions), and a fresh install of either operating system. (So it's probably not some virus or misconfiguration.)

Another common response I've found is that it's something related to the ISP. For that I can't answer for sure, but I can clarify that my current ISP is Telus.

This doesn't bother me too much, as it's a bug that can be mitigated by just ignoring the prompt. But it's just such an odd inexplicable inconsistency that rarely occurs and I've yet to come across a solution that does properly explain it.

Attached screenshots

Modified by CHduckie

Chosen solution

Alright, so I was finally able to re-encounter and record a unique instance. Although I am at a bit of a loss regarding why it's redirecting.

I can clearly see several error 302s which took me to Centurylink, but double checking, I am still in fact using a Cloudflare DNS, no VPN connected or anything that might otherwise modify the DNS.

This redirection issue seems ubiquitous across browsers (aside from the prompt.)


Alas, it would appear that it was an issue with my dual-network adapters. It seems that my DNS was only ever set for one of them, and was defaulting to the wrong one...

Thanks for your time, I apologize for the otherwise elementary issue, I should have caught this earlier. I'll mark this as resolved.

...

Even stranger is that Windows was reporting my default network adapter correctly, and from what I can tell, it was using the proper adapter too (since I've recently noticed what might be a driver or hardware issue with the bandwidth of the other network adapter, which has distinctly poorer performance, and I would have immediately noticed on a network benchmark.)

After fiddling with the DNS of the incorrect network adapter and eventually leaving it back to automatic, both interfaces are correctly not redirecting to any Centurylink service, and this whole solution has left me more confused than prior to solving it.

Read this answer in context 👍 0

All Replies (15)

more options

I believe the feature was originally added as we'd defaulted to searching in more situations, and some users of intranets / local networks actually wanted to be able to visit the sites with just one word.

As a result, Firefox does a look up to see if that exists or not, and prompt it.

You can turn this off by changing your configuration. In order to change your Firefox Configuration, please do the following:

  1. In the address bar, type about:config and press the Enter key.
    • The about:config warning page may appear. Click Accept the Risk and Continue to continue to the about:config page.
  2. Enter `browser.urlbar.dnsResolveSingleWordsAfterSearch` in the search box.
  3. You should see it has a value of `1` which is the default.
  4. Click the little pen icon at the end, and change the number to `0`, then press enter.

I think it will take effect straight away, but if not, you may need to restart Firefox.

Helpful?

more options

This explanation does make a bit more sense. I'm still unsure as to why it sometimes redirects to a centurylink search engine, regardless of any DNS configuration.

Upon further testing, it seems that I'm still getting redirected to a web address of my query, even after disabling the about:config key, and restarting Firefox.

Helpful?

more options

The scenario in your original post often indicates that your current DNS service provider is dishonest. An honest DNS will simply indicate that your query text is not a know hostname on the internet. But dishonest DNS services will send Firefox an address of a server that hosts pay-per-click advertising to "help" you find what you're looking for. Perhaps you've seen that page if you ever typo'd an address?

On that page, check for a link near the upper right or at the bottom like:

  • Opt out
  • Why am I getting this page

That usually leads to information on how to disable this function.

Another option, if you don't rely on a local hosts file, is to use DNS over HTTPS to bypass Centurylink: Firefox DNS-over-HTTPS.


I'm not sure what you mean by:

CHduckie said

Upon further testing, it seems that I'm still getting redirected to a web address of my query, even after disabling the about:config key, and restarting Firefox.

Did Firefox stop searching DDG first?

Helpful?

more options
Did Firefox stop searching DDG first?

Yes

The scenario in your original post often indicates that your current DNS service provider is dishonest. An honest DNS will simply indicate that your query text is not a know hostname on the internet. But dishonest DNS services will send Firefox an address of a server that hosts pay-per-click advertising to "help" you find what you're looking for.

I believed so to be the case at first, but my default DNS provider is set to Cloudflare. And upon enabling DNS over HTTPS, I'm still redirected to webaddress equivalents of my search query.

Perhaps you've seen that page if you ever typo'd an address?

I don't recall a time where that's happened. Usually, I'll get a page notifying me that I can't connect to that URL.

The occasional webhelper.centurylink.com redirection would not appear to have any opt out buttons, or just about any obvious indication that this was not typical behaviour. Here's the page I did get redirected to, prior to any identical future queries sending me to a literal address with a .com extension.

Helpful?

more options

Regarding the failure to search, are you sure you didn't accidentally set the following preference to false true (false is good, true is bad):

browser.fixup.dns_first_for_single_words

On the CenturyLink page, try the F.A.Q. link on the right side.

Modified by jscher2000

Helpful?

more options

I don't believe I've set the aforementioned preference. And upon further verification, it is indeed set to false.

The Centurylink FAQ only seemed to contain one relevant link to some kind of preference, which has been, and is still set to "Off."

Helpful?

more options

Ohhhh... if you used the button indicating you meant to visit that site instead of search it, Firefox probably stored an exception. You can search for part of the site name in about:config to find that preference and remove it.

Helpful?

more options

Well, that seems to resolve any current domains that auto-redirect. Do you happen to know why queries sometimes redirect to Centurylink, or add themselves as exceptions?

Helpful?

more options

You shouldn't get an exception if you don't click the button on the bar indicating that you meant to go to the site.

If you disabled the background lookup using the steps from Standard8, then I don't know why the bar still appears, but I haven't tested that setting myself.

Helpful?

more options

Alright, so the prompt is meant to just randomly appear? I suppose I could deal with that, as I always have. Just curious about the criteria required for it to appear.

If I could get to the root of why I get redirected to Centurylink afterwards, that would also be interesting, but I suspect it may be more difficult to diagnose from just the browser logs itself.

Modified by CHduckie

Helpful?

more options

The feature is intended to facilitate access to real servers you might have on a local network, such as http://intranet/. The button should not appear when the DNS server honestly reports that http://intranet/ doesn't exist.

If you plan to use the Network Monitor for exploration, make sure to open it before clicking and turn on Persist Logs to follow the redirects.

https://developer.mozilla.org/docs/Tools/Network_Monitor

Helpful?

more options

Am having a similar problem, I was redirected even though the URL was correct. When I got the centurylink page, I copied the url, closed out firefox, re-opened it, pasted the url, and it took me to the correct site. Panic set in and I've been searching for the cause since.

Helpful?

more options

Hi pastormark, is CenturyLink your ISP?

If you go to an example diversion page and click F.A.Q. and try the steps to opt out, does it work?

Example diversion page: http://webhelper.centurylink.com/search/?q=http://example/

Some of the hijackers, I mean, helpful search services, will divert even if there is a typo in an embedded image URL in a page. Not sure whether that explains any odd behaviors for this particular ISP.


You also might check whether this is influenced by an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

Helpful?

more options

Thanks for the suggestion, I'll try to reproduce and see what I find.

Helpful?

more options

Chosen Solution

Alright, so I was finally able to re-encounter and record a unique instance. Although I am at a bit of a loss regarding why it's redirecting.

I can clearly see several error 302s which took me to Centurylink, but double checking, I am still in fact using a Cloudflare DNS, no VPN connected or anything that might otherwise modify the DNS.

This redirection issue seems ubiquitous across browsers (aside from the prompt.)


Alas, it would appear that it was an issue with my dual-network adapters. It seems that my DNS was only ever set for one of them, and was defaulting to the wrong one...

Thanks for your time, I apologize for the otherwise elementary issue, I should have caught this earlier. I'll mark this as resolved.

...

Even stranger is that Windows was reporting my default network adapter correctly, and from what I can tell, it was using the proper adapter too (since I've recently noticed what might be a driver or hardware issue with the bandwidth of the other network adapter, which has distinctly poorer performance, and I would have immediately noticed on a network benchmark.)

After fiddling with the DNS of the incorrect network adapter and eventually leaving it back to automatic, both interfaces are correctly not redirecting to any Centurylink service, and this whole solution has left me more confused than prior to solving it.

Modified by CHduckie

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.