Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The "New" GSuite Chat support?

  • 3 replies
  • 2 have this problem
  • 101 views
  • Last reply by Hab

more options

TB chat support for Google is now noticeably outdated (GTalk logo and protocol). Does anyone know in which release channel or planned version TB chat support for Google will be updated to support the new GSuite for Business Hangouts Chat ? And if there's a workaround in the interim, like an Add-On?


Background: Thanks to posts like this: https://support.mozilla.org/en-US/questions/1279990 , I've had no problems pulling and sending mails with Thunderbird, since TB saved my password and Oauth token... for a google MAIL account.

But now I'm trying to add a Chat account in TB belonging to the same Gsuite account, but it's falling into the ol' insecure trap and Google isn't authorizing it. I can't have the organization lower their Gsuite security settings to allow less secure apps, as it's a paranoid company not in my control.

I received the notorious 'Critical Security Thread' email from Google that a sign-in attempt was blocked (Someone just used your password to try to sign in to your account from a non-Google app. Google blocked them, but you should check what happened. Review your account activity to make sure no one else has access.) -> Was this you? Yes, it was me - continue -> (Less secure app blocked. Google blocked the app you were trying to use because it doesn't meet our security standards. Some apps and devices use less secure sign-in technology, which makes your account more vulnerable. You can turn off access for these apps, which we recommend, or turn on access if you want to use them despite the risks. Google will automatically turn this setting OFF if it's not being used. Suggested solution: Use 2FA and an App-Specific password Other relevant resources on this exact issue:

Chosen solution

I can not find anything concrete, but from some of the bug I looked at there was a suggestion that using an app password works. But the issue is really that is is using some broken something at google that allows hangouts folks to chat with the not defunct system. This is why the icons etc are all old. Thunderbird does not actually have support for hangouts in it's current form.

Read this answer in context 👍 1

All Replies (3)

more options

Hab said

I can't have the organization lower their Gsuite security settings to allow less secure apps, as it's a paranoid company not in my control.

Annnnnnd since June , Google removed the feature for admins to reduce the security settings entirely for Gsuite for Business accounts. So TB support for Google Chat is completely broken in its current incarnation, as far as enterprise users are concerned.

Helpful?

more options

Chosen Solution

I can not find anything concrete, but from some of the bug I looked at there was a suggestion that using an app password works. But the issue is really that is is using some broken something at google that allows hangouts folks to chat with the not defunct system. This is why the icons etc are all old. Thunderbird does not actually have support for hangouts in it's current form.

Helpful?

more options

Confirmed--- I've set up 2FA and indeed an App Password lets me authorize through by adding the Chat account in TB , thank you!

But... as you wrote, I'm still having trouble actually joining a room thereafter. For example, I've been added by the organization whose Gsuite account I've been invited to a Hangouts chatroom with 3 words and spaces between -- for sake of example-- ' Tom & Jerry chat ' . In google's browser interface I see I'm in there. I tried to join the same channel in TB Chat by pressing 'Join Chat' , then putting ' Tom & Jerry chat ' under Room field, and tried both Groupchat.Google.com .. and Groupchat.(orgdomain) under Server per https://superuser.com/questions/563384/chat-room-in-thunderbird-with-google-chat... result is nothing,just an endless spinning wheel under Conversations.

Before calling it quits, I wonder if a minor syntax tweak could be the magic fix (I tried %20 between the spaces)?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.