Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ebay Pages not loading/displaying correctly Please Help

  • 6 replies
  • 1 has this problem
  • 2 views
  • Last reply by chunter2

more options

While working with my listings on ebay all ebay pages just stopped displaying properly. I hope someone can solve this for me, can't live with out Firefox ! Here is a screen shot: ok that doesn't work... would be nice to be able to share that way  ;)

OK so my whole ebay pages display like this I can't do anything like sign in, browse, etc etc

Home Saved Motors Parts & Accessories

   All Parts & Accessories
   Car & Truck Parts
   Motorcycle Parts
   Automotive Tools & Supplies
   Apparel & Merchandise
   Motors Deals
   My Garage

Vehicles

   Cars & Trucks
   Classics
   Motorcycles
   Powersports
   RVs & Campers
   Trailers & Other Vehicles
   Boats

Fashion Top Categories

   Women's Clothing
   Women's Shoes
   Men's Clothing
   Men's Shoes

All Replies (6)

more options

Hi chunter2, to share a screenshot, you first need to save it to disk as an image file and then attach it.

I gather that you are getting raw, unstyled HTML.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

ok so i turned off Enhanced Tracking Protection from the shield icon and it works

Still a bit confused why it did this in the middle of a session? I also hate to let ebay run wild

Thanks so much for your help !

Helpful?

more options

O I spook too soon went to sign in and back to the raw, unstyled HTML.

Helpful?

more options

Hmm, I don't see the ebaystatic.com domain getting blocked by either the "Standard" or the "Strict" level of Enhanced Tracking Protection. I'm not sure why your Firefox is blocking it. ??

Helpful?

more options

Hi chunter2, has this issue resolved for you yet? Firefox has a more aggressive style sheet cache in Firefox 79, so you may need to hold down the Shift key when clicking the Reload button after modifying Enhanced Tracking Protection for a page.


After much testing, the only way I could break the eBay page was Strict on the Options page, and privacy.annotate_channels.strict_list.enabled to true in about:config (see attached screenshot).

But then it stopped being broken after 10 minutes of testing, so I'm not sure what is going on. Maybe it was a glitch in the files that got updated in the profile I was testing in?

Anyway, if you use "Strict" tracking protection (instead of Standard or Custom), could you check this, too:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste strict_list and pause while the list is filtered

Firefox has a built-in preference named

privacy.annotate_channels.strict_list.enabled

that is normally set to false. Is yours set to true?

Helpful?

more options

1st let me say again how much I appreciate your effort ! I am set to standard tracking protection. I did check though privacy.annotate_channels.strict_list.enabled

that is normally set to false. Is yours set to true? Mine is False

It's been sporadic Yesterday I had to turn off tracking protection to display ebay pages, today it's working in standard mode. This did start before the latest firefox update. Then I updated in hopes that would cure it.

At least I can get on again, I did see some comments from the users on the ebay forum that were having the same problem as me.

from a user: Same issue. Sometimes it works, other times not. I would prefer not to switch to a browser that uses more resources and lacks features - Chrome.

Yes, we have restarted computers and cleared cache. I don't know about the original poster, but its not my first day on the internet. I'm a certified IT technician. Something between eBay and Mozilla no longer play nice, and if eBay appreciates the thousands of dollars of free money I grace them with I'd like it if the Firefox problems could be resolved.

One more from another ebay user :   

Got the same issue here as well.

Firefox 79 is having the same exact issues as the original poster.

Happened on the 7th same as them and today.

Seemed to work just the other day though on Firefox.

Using Microsoft Edge browser to thumb through Ebay and type this comment, seems to have no issues with Edge that I can see.

Thanks Again !

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.