Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Coloring Text in Emails

  • 14 replies
  • 1 has this problem
  • 30 views
  • Last reply by Lobo

more options

When composing emails, I usually change the color of the text. This works fine for text but if the text contains "bullets", the bullets are always black.

All Replies (14)

more options

re :the bullets are always black.

That's probably because your default setting for body text is black and this will be in the html code. When you highlight text and choose to change colour of text, it sets a font color for the text itself. the html code will start a font color at the beginning of each part of text and also close the font colour at the end.

Helpful?

more options

Thank you very much for the solution. It worked

Helpful?

more options

I have tested again the proposed solution and It does not work.

When I chose the color in Preferences => Preferences => composition,

The selected color is ignored by the reader (tested by sending an email to a Gmail account and also in Outlook).

If I mark the text and I change the color. It works.

Probably this is the proper behavior (preserve readers settings) but It does not fulfill the intended behavior (display my email in an specific color).

Thanks for your answer.

Modified by Lobo

Helpful?

more options

You might be creating emails using html, but are you sending emails in html and plain text or only plain text ? When you receive the email is it in html or plain text. That info will be in the source code of the received email.

If using version 68* Preferences => Preferences => composition > General tab click on 'Send Options' button Select: 'Send the message in both Plain Text and HTML' click on 'OK'

Make sure your email addresses which may be in one of your address books does not state you prefer to receive in Palin Text. Select 'unknown' and then both get sent.

Helpful?

more options

Hello!

Thank you very much for your detailed answer.

I am sending the emails both in text and HTML.

Attached, I am sending you a screenshot of the the email that l have sent (Thunderbird). As you can see, the text of the email is displayed in black but the html code of the email contains the coloring information.

This means that the coloring information when applied in this way is not even recognized by Thunderbird.

Thank you very much.

Best Regards.

Helpful?

more options

What settings have you got in Preferences > Display > Formatting click on 'Colours' Please post image showing settings.

If you have 'Text' set as black AND you have 'Override the colours specified by the content with my selections above:' set as 'Always' then this would explain why your computer is not displaying the expected colour. Suggest you change settings to 'Only with high contrast themes' OR 'Never'.

Helpful?

more options

Hello

I believe it was already configured as you noted down... See screenshot. I didnt change anything. Anyway, the color configuration is not considered neither in Outlook nor in the Gmail web interface.

Helpful?

more options

Please send me the same test email to this email address: mail at anje dot co dot uk Email address written phonetically so to avoid spam bots in public forums.

Helpful?

more options

As you have issue with Thunderbird , Outlook and Gmail where email still shows black text then this has to be a setting on your computer. That's why I asked you to send same test email to me, so I can view same test email outside of your computer.

In Thunderbird: Do you have this setting: View > Message Body as > Original HTML

Preferences > Display > Formatting click on 'Colours' 'Override the colours specified by the content with my selections above:' set as 'Never'

Restart TB


Are you using a high Contrast theme on computer? In Thunderbird, are you using the thunderbird 'Dark' theme or the 'default' theme with operating system colours ? Please select Thunderbird dark.

Helpful?

more options

Hello,

I have just sent you an email to the given email address.

I BCC the same email to my GMAIL account and the text is displayed in black. Please give me a feedback on how it looks in your computer.

PS: I open my Gmail account in a Windows computer (Mozilla) it still looks not ok


Thanks for your help Regards

Helpful?

more options

I'm on Windows OS 1909 Running two versions of Thunderbird, 68.11.0 and 78.1.0

Windows has a system mode and an app mode. Both are set as 'Dark'. Version 68.11.0 is running the Thunderbird theme 'Light' mode. Version 78.1.0 is running the Thunderbird theme 'Dark' mode.

I make use of 'userChrome.css' file to specify a particular colour of blue. In the image you see version 78* on the left and version 68* on the right. The upper images show my choice of blue effecting and overriding your choice of blue. The lower part of image shows your choice of blue - (I enabled Safe Mode to show it).

This proves your email is creating the colours as you intended. I presume this is what you see when you are composing the email.

However, you have a setting on your computer which can override whatever you compose, thus showing only a black text version.

check you are creating in html, but are you are sending out in both HTML and Plain Text. Yes is good.

check all of your Address Books for your own email address details to see if it specifies you only want 'Plain Text'. Need to chose 'unknown' to send both.

Check: Do you have this setting: View > Message Body as > Original HTML you may be sending in html, but are you reading in html ?

check the 'display' setting 'Override the colours specified by the content with my selections above:' If set to 'Always' override content with a black text - then change to 'Only with high contrast themes' . If that change does not work then ask: 'Are you running a 'High Contrast' theme on your computer ? If yes, then this would explain why everything is only showing black text, not just in Thunderbird, but everything.

In Thunderbird, Try changing to 'Never' and see if this effects the view in Thunderbird, although it would not effect the view in other apps. Please report back on results.

If that works, then Stop using a High Contrast theme on your computer.

Finally I would ask if you had a 'userChrome.css' file that might have code to override - just like I do.


So really, go throught the above. Do you have this setting: View > Message Body as > Original HTML

Preferences > Display > Formatting click on 'Colours' 'Override the colours specified by the content with my selections above:' set as 'Never'

Restart TB

Otjherwise, something is effecting all of your computer - not just Thunderbird, so are you using a high Contrast theme on computer?

Helpful?

more options

Hello,

Thanks for your detailed answer.

I guess, I know why it does not work. I found the following:

Always use inline CSS

   Most webmail clients (Outlook.com, Yahoo.com, Gmail, etc) will strip CSS out when stripping the head and body tags.

https://sendgrid.com/docs/ui/sending-email/cross-platform-html-design/

I guess, this is the reason why I cant see the proper coloring scheme when checking my GMAIL account via Web interface.

I also discovered that my emails get properly displayed in Outlook. The problem was that for the tests I was using a Web interface to an exchange mail server (Microsoft - Outlook.com) and I was assuming that It would display the emails in the same manner than Outlook.

Could you confirm?

Thanks

Helpful?

more options

Hello there Lobo we try to help you. Do you have more questions?




Greetings Firefox volunteer.

Modified by День сумо

Helpful?

more options

Dear all,

I discovered why Thunderbird didn't display properly the colors.

I am using the plugging: Conversations. This plugging modifies how the body of the messages are displayed...

I unmarked a configuration option and now it works. See attached picture.

I have learned that the web interfaces of most of the mail providers strip tags in the body and in the header, implying that the coloring gets lost and therefore not displayed..... :( I would propose that Thunderbird should give the option of adding these properties as inline properties....

Thank you very much for your help and the dedication shown. It is the first time I post a question and I am really delighted.

Regards.

Modified by Lobo

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.