Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Change Thunderbird's default font and font colour

  • 8 replies
  • 1 has this problem
  • 2276 views
  • Last reply by Stans

more options

Is there a way to change the system font and colour (not message)?

Thanks.

Is there a way to change the system font and colour (not message)? Thanks.

Chosen solution

Proceed as follows:

  • Open the Config Editor, search for toolkit.legacyUserProfileCustomizations.stylesheets and toggle it to true
  • Use the following code in your userChrome.css file:
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
*{ font-size: 9pt !important; font-family: Roboto !important; color: #808080; !important; }
  • Restart Thunderbird.

Omit the font-size line if you don't wish to change the size. 9pt is the default size in Windows. Change the color code to a shade of gray that you want. This may help. You must of course install Roboto first. Attached is a screenshot of the result on my end.

Read this answer in context 👍 2

All Replies (8)

more options

The font face or size?

more options

Well, I wanted the Roboto font for the entire UI and grey colour instead of the default black. Thanks.

Modified by Rasheed A.Z.

more options
more options

Thanks for replying but it looks like that addon is not available any more. I also tried the userChrome.css method but nothing changed :(

more options

Chosen Solution

Proceed as follows:

  • Open the Config Editor, search for toolkit.legacyUserProfileCustomizations.stylesheets and toggle it to true
  • Use the following code in your userChrome.css file:
@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");
*{ font-size: 9pt !important; font-family: Roboto !important; color: #808080; !important; }
  • Restart Thunderbird.

Omit the font-size line if you don't wish to change the size. 9pt is the default size in Windows. Change the color code to a shade of gray that you want. This may help. You must of course install Roboto first. Attached is a screenshot of the result on my end.

more options

Thanks for the excellent answer Stans. It finally worked. Part of the problem was with Windows - just installing the font set one one didn't seem to work until I copied and pasted the whole font family into the Windows font folder.

I'm astonished at how much difference just a font and colour change did to the look! It's looking a little less dated and more like Mailspring now. I decided on this btw:

  • {

font-size: 12pt !important; font-family: Roboto Light !important; color: #404040; !important; }

Modified by Rasheed A.Z.

more options

I have the same question/problem. Where is userChrome.css located?

I'm using Win 10 x64.

Modified by Tony

more options

Tony said

I have the same question/problem. Where is userChrome.css located?

It doesn't exist by default. You have to create it, then save it inside your Tbird profile folder in a subfolder called chrome. See https://developer.mozilla.org/en-US/docs/Mozilla/Thunderbird/Thunderbird_Configuration_Files