Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to change what Firefox does when you click on an entry in the Downloads selection?

more options

When I click on a link to a document (a PDF in my case), I'm asked for a location to store it. That's fine.

Now, if I click on the Downloads button in the Toolbar, a selection with all downloaded files opens. How do I specify/change the application used to open the file if I select it there?

Firefox 78.0.2 (64-bit) Mozilla Firefox for Ubuntu canonical - 1.0

Attached screenshots

Chosen solution

I've changed the entry in mimeinfo.cache manually to

  • application/pdf=okularApplication_pdf.desktop;gimp.desktop;gv.desktop;libreoffice-draw.desktop;net.sourceforge.gscan2pdf.desktop;

and that seems to solve the problem. But why the corret result of xdg_mime? And how would I have changed it the correct, i.e., tool way?

Read this answer in context 👍 0

All Replies (4)

more options

On Linux, firefox uses xdg-open to determine how to open different mimetypes. You can check what is currently being used by running: $ xdg-mime query default application/pdf Then, assuming your app makes a standard .desktop entry in /usr/share/applications, you can set it by doing $ xdg-mime default <app>.desktop application/pdf If you need to manually set it, the file that sets these are in $HOME/.config/mimeapps.list

If you're referring to internally how firefox handles files, that can be changed in about:preferences .

Helpful?

more options

$ xdg-mime query default application/pdf yields okularApplication_pdf.desktop, so that seems to be right. I've attached my settings in about:preferences as picture. So, what else could be the reason? (Actually, I would like okular to open pdf files but gimp is used instead)

The only suspicious entries in /usr/share/applications with gimp and pdf are (/usr/share/applications$ grep gimp * | grep pdf)

  • gimp.desktop:MimeType=image/bmp;image/g3fax;image/gif;image/x-fits;image/x-pcx;image/x-portable-anymap;image/x-portable-bitmap;image/x-portable-graymap;image/x-portable-pixmap;image/x-psd;image/x-sgi;image/x-tga;image/x-xbitmap;image/x-xwindowdump;image/x-xcf;image/x-compressed-xcf;image/x-gimp-gbr;image/x-gimp-pat;image/x-gimp-gih;image/tiff;image/jpeg;image/x-psp;application/postscript;image/png;image/x-icon;image/x-xpixmap;image/x-exr;image/x-webp;image/heif;image/heic;image/svg+xml;application/pdf;image/x-wmf;image/jp2;image/x-xcursor;
  • mimeinfo.cache:application/pdf=gimp.desktop;gv.desktop;libreoffice-draw.desktop;net.sourceforge.gscan2pdf.desktop;okularApplication_pdf.desktop;

Maybe it's the mimeinfo.cache entry. But why then the correct result of xdg-mime query?

Modified by scholz

Helpful?

more options

Chosen Solution

I've changed the entry in mimeinfo.cache manually to

  • application/pdf=okularApplication_pdf.desktop;gimp.desktop;gv.desktop;libreoffice-draw.desktop;net.sourceforge.gscan2pdf.desktop;

and that seems to solve the problem. But why the corret result of xdg_mime? And how would I have changed it the correct, i.e., tool way?

Helpful?

more options

Please see the man page for xdg-mime; it describes what the query option actually does. I'm glad to see a manual edit fixed your issue.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.