Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Email backgrounds and text colors have inverted

  • 14 replies
  • 5 have this problem
  • 2116 views
  • Last reply by Toad-Hall

more options

My Thunderbird updated today, and suddenly all of my emails are showing white text on black backgrounds, except for those incoming emails that have their own color schemes. In those cases, the text appears pretty dark against the black background. Changing themes doesn't seem to make a difference. Was there something in the update that made this happen? How do I fix it?

Chosen solution

See this topic: https://support.mozilla.org/en-US/questions/1295378

Set the default app mode to Light in W10 Settings, Personalization, Colors. Default Window mode can be Light or Dark.

Read this answer in context 👍 1

All Replies (14)

more options

By the way, the version upgrade was to 78.0.1 (32-bit).

more options

Chosen Solution

See this topic: https://support.mozilla.org/en-US/questions/1295378

Set the default app mode to Light in W10 Settings, Personalization, Colors. Default Window mode can be Light or Dark.

more options

Wow, that's really messed up. But it works. Thanks for the help!

more options

Hi there, I have got the same issue and even worse now. I went into the preferences and I found where it was the problem. I changed the text in dark and the background in white. The matter is that it saved only the background. And now my preferences are a whiteboard. In addition, since it is impossible to highlight buttons and texts I cannot navigate back to the settings and adjust the situation.

Is there a way to reset Thunderbird's system appearances?

Luckily, I had chosen a theme for reading emails and this change did not affect it, but the entire preferences pages are white, see the attachment.

Thank you.

Cheers, S.

- TB 78 on macOS Catalina 10.15.5

more options

@sag167 I suspect your issue is slightly different, because mine was caused by a bug/design issue in the way that Windows "dark" schemes are designed to operate. Since you are on a Mac, that likely does not apply.

more options

I had a dark background and white texts as well, and it was related to my dark theme in the Mac. I wanted to invert them but it went wrong and now I have another issue for sure.

Now the problem is that I can't read anything the preferences pages and some email because it is all white.

I cannot find a way to restore Thunderbird as it was. I tried to install the last version over mine, but obviously it took the previous settings.

S.

more options

I opened the file prefs.js, looked for the right line and changed the colour from white to black and saved.

S.

more options

I don't want some weird workaround, some hack, some tweak to fix this, I want to know what happened. I changed nothing except upgrading to the latest Thunderbird, now all of a sudden the background of the message editor is black instead of white. First I want to know why this was changed, then if I know that it is a bug that will be fixed I will just live with it until that time, or if this is a change in the functionality, for some reason, what was that reason? WE SHOULD NOT HAVE TO CHANGE THE WINDOWS SETTING FOR APP FROM DARK TO LIGHT - THAT AFFECTS ALL THE OTHER APPLICATIONS ON THE COMPUTER, NOT JUST THUNDERBIRD. Does anyone know what caused this and whether it will be fixed? Or do we have to change the settings for ALL THE APPS ON OUR COMPUTER just to get Thunderbird e-mail to display the message editor pane background white with black letters?

more options

This problem only happened to me over night with update to 78.2.1! Giving the black background for a new message and then the white text on white in the messages, correspondents etc columns. That changes to black once it turns to read. I've changed it in defaults but it doesn't stay, just goes right back as soon as you try and compose a new message or forward one on.

I'm not wanting to change my theme in windows to light! Surely there's been a fix for this issue by now without doing that?

more options

The person who originally posted this question has marked a comment as a chosen solution.

When you post comments you are sending those comments to the person who originally posted the question.

If chosen solution comment does work for you or it's an option you do not want to use, then please create your own question so everyone has the opportunity to see your question. I'm sure the original postee does not want to keep getting your comments.

more options

Hi, I am on Windows 10 Pro. NEVER used dark mode, I hate it. Please help me with the settings so I can have the light mode again. Urgent help is needed with step by step changes to be done. Please correct this all messed up change in the app. !

Thank you,

more options

vfomino Please read my previous comment dated 8/30/20 as it applies to you.

more options

I have the same problem but on a mac. I receive emails like before, black on white, but in compose it is white on black. Very awkward when trying to reply, because some of their writing appears black on black. I tried to go through preferences and change the background color but it does not save my selection. It appears to be a glitch, but has been like this for some time. Does Thunderbird not know that this is a problem and why don't they fix it?? Any solutions???

more options

This question was created back in July. Since then there has been several modifications and fixes for various things over several versions of Thunderbird. At the time, the question owner selected a 'Chosen Solution' which worked for them baring in mind the OS they used and the version of Thunderbird at the time.

This means the solution may no longer apply to everyone.

Please do not post any more comments as they are being sent to the person who originally asked the question.

Please create a new question stating OS and version of Thunderbird.