Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

TBird78: blank header, grayed-out Send button, and empty address book

  • 7 replies
  • 4 have this problem
  • 270 views
  • Last reply by Hilarion

more options

The recent update to Thunderbird 78 has caused numerous problems on my Windows 10 system.

Received emails: -The header field is blank for To, From, Date etc. information. Picture attached. -There is no reply-all button in the header pane; instead, there are two Reply buttons Note: I used to have the CompactHeader Add-On installed. It had been disabled for some time, and there's no evidence of its presence any more, but perhaps there is lingering conflicting code? I tried toggling View --> Headers --> All/Normal. That collapsed the header, and now it won't expand regardless of the All/Normal setting. The attached picture was taken before this happened.

Sending emails (and this is the most critical issue): - I can manually type in valid addresses (see address book issues below), but when I press Enter, nothing happens. Thus, the Send button stays grayed out, so I am unable to send emails. The problem seems to be that it is not accepting the email addresses as input, so it stays in a perpetual state of "there are no recipients listed". Even when I use Reply or Reply-All, it seems to ignore the recipients, and the Send button stays grayed out.

The address book: - Is empty. It does not appear to have converted my local address book to the new format. - My company's address book on the LDAP server is also not being accessed.

I can submit these as separate issues if you like, but I wanted you to see all of them together in case some have a common cause.

Thank you for your help!

Attached screenshots

All Replies (8)

more options

To test a fix:

   download and extract https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/WAxn9pUkSVix7EHar9_6PA/runs/0/artifacts/public/build/target.zip
   Navigate to the Thunderbird directory and run thunderbird.exe directly from there
   Please post your results.

After testing, at the point where you want to get back to version 78 or 68, you'll need to use --allow-downgrade at the dos command prompt.

Helpful?

more options

I wasn't able to run the thunderbird.exe that came in target.zip. Windows popped up a message: Windows protected your PC Microsoft Defender SmartScreen prevented an unrecognized app from starting. Running this app might put your PC at risk. App: thunderbird.exe Publisher: Unknown publisher

Helpful?

more options

lferro4 - I'm still on the dinosaur version of Windoze (Win7) so only had to tell the OS not to ask me for permission and run the program. Win10 is a little more anally-retentive, but you should be able to get past it. I use Win10 as well, but I don't know enough to tell you exactly how it's done.

However, if you can get past the UAC (user account control) it's worth it. See

https://winaero.com/blog/how-to-turn-off-and-disable-uac-in-windows-10/

It's a work-around, but it should get your emails back. Desperate times need desparate actions :-)

Helpful?

more options

Wayne Mery,

                     Yes I can know see address book and send emails by running from the extracted Thunderbird ( using my original profile).

W10 64 bit

Just need to workout how to replace the install.

Thanks

Andy

Helpful?

more options

Rode: Thank you for offering a suggested solution to the test-fix being blocked by Win10. Unfortunately, UAC seems to be a separate program from the one I'm encountering, which is Microsoft Defender SmartScreen. I was able to find the settings for this. Unfortunately, I'm using a corporate machine, and these settings are controlled by the corporate admins and I can't change them, but I will post the information in case it's useful for others:

Go to Windows Security --> App & browser control --> Check apps and files You will see three options: Block, Warn, Off

Helpful?

more options

Update: Version 78.1 was released on July 30, and that seems to have solved most of the problems I was having. The email header is back, there's only one reply button, and I can send email ! A BIG THANK YOU to volunteer Mozilla programmers! Still one lingering issue that I haven't yet attempted to solve: although the address book has been restored, it's not being accessed when I address emails.

Helpful?

more options

I actually seem to have a variation of this problem. I'm already on TB 78.3.1. I'm not sure when exactly it happened, but I'm sure it was not there when I was on TB 68 and it was definitely already there on the previous version I had: 78.2.2.

As for the symptoms:

In the message preview pane (not sure if this is the correct name, as I use Thunderbird in Polish):

  • My screenshot would be basically identical, to what Lee has attached (except for Polish translations of the button and field labels).
  • The headers section is basically blank, i.e. the "From", "Subject", "Reply-To", "To", "CC", "BCC" fields appear with blank value.
  • The fields even appear, when they were not used in the message (e.g. when "CC" is empty in the message source).
  • I know, that some fields should not be empty, as the message list does show the correct values for "From", "To", "Subject" correctly and I can access the message source.
  • The "Subject" field does get populated for some messages (not sure what's different about those) - in such case, the "Subject" field retains the subject value of such message, when I switch to other messages.
  • I have two "Reply" buttons in there. I do have the "Followup" drop-down button, (with "Reply" and "Reply all" as drop-down options), the Forward button, the Archive button, the Junk button, the Delete button and the "More" menu button.
  • The Junk button does not change to not-Junk button, when a message already marked as junk is previewed. In general it seems, that the buttons' state is "frozen" in some initial state.
  • The show normal/all headers switch in the view menu does work, i.e. additional header fields do appear in the "all" mode, but they also do not always reflect values of the currently previewed message. When I switch back to "normal", only the "From" field remains, but the situation goes back to what I described above after TB restart.

Composing messages:

  • This seems to work OK, i.e. I can type the e-mail addresses and the Send button does enable.

The address book:

  • Is empty and I had quite a lot of contacts accumulated there.
  • I don't use LDAP - only a local address book.

Others:

  • I don't use TB's calendar or tasks yet, so am not sure if those are affected.


I have tried running TB with all add-ons disabled and in the safe mode, but it does not resolve the problem.

I don't think this the TB installation/binaries issue, as a different user of the same Windows 10 PC, so using a separate Windows account, so with a separate TB profile, but using the same shared TB installation ("C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe"), does not experience the problem. I'm guessing that after updating TB version, when TB was upgrading my profile, it got somehow corrupted for the message preview setup and for the address book. The actual contents of the mailboxes seem to be intact.

Modified by Hilarion

Helpful?

more options

Also the error console shows some errors (part 1):

21:47:13.425 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] 2 L10nRegistry.jsm:658:19 21:47:13.735 Successfully loaded OpenPGP library rnp.dll from C:\Program Files (x86)\Mozilla Thunderbird\rnp.dll RNPLib.jsm:46:13 21:47:13.738 public keys: 0, secret keys: 0 RNPLib.jsm:194:15 21:47:13.739 0 protected and 0 unprotected keys BondOpenPGP.jsm:99:13 21:47:13.997 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] 2 L10nRegistry.jsm:658:19 21:47:14.616 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] 2 L10nRegistry.jsm:658:19 21:47:15.589 NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIAbDirectory.getIntValue] AddrBookManager.jsm:199 21:47:15.590 Exception { name: "NS_ERROR_NOT_INITIALIZED", message: "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIAbDirectory.getIntValue]", result: 3253927937, filename: "resource:///modules/AddrBookManager.jsm", lineNumber: 199, columnNumber: 0, data: null, stack: "get directories/<@resource:///modules/AddrBookManager.jsm:199:25\nget directories@resource:///modules/AddrBookManager.jsm:198:10\n_rebuild@chrome://messenger/content/addressbook/menulist-addrbooks.js:136:22\nconnectedCallback@chrome://messenger/content/addressbook/menulist-addrbooks.js:34:12\n@chrome://global/content/customElements.js:217:21\n", location: XPCWrappedNative_NoHelper } customElements.js:220:19 21:47:15.714 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] 2 L10nRegistry.jsm:658:19 21:47:15.717 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] 2 L10nRegistry.jsm:658:19 21:47:16.734 1601408836734 tbsortfolders.folderPane DEBUG Init 21:47:16.734 1601408836734 tbsortfolders.folderPane DEBUG Add observer 21:47:17.474 Successfully loaded OTR library libotr-5.dll from C:\Program Files (x86)\Mozilla Thunderbird\libotr-5.dll OTRLib.jsm:43:13

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.