Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can I change the font size of the Message List in Thunderbird?

  • 10 replies
  • 5 have this problem
  • 659 views
  • Last reply by sfhowes

more options

I've played with the various font controls under Preferences->Display->Formatting, including the Advanced options. None of them seem to have an effect on the size of the font in either the Message List or the sidebar. Is this possible?

All Replies (10)

more options

To increase all the fonts, see this topic about changing a single preference:

https://support.mozilla.org/en-US/questions/1269361

The discussion includes a method to adjust just the message list (Threads Pane font) or the Folder Pane with css:

https://support.mozilla.org/en-US/questions/1269361?page=2#answer-1274848

more options

Dear sfhowes,

Thanks for the information. I tried the Config editor approach, changing "layout.css.devPixelsPerPx" to a larger value. That helped only slightly and larger numbers have no effect. I'm on a Macbook for what it's worth.

There is another method to put a bit of CSS into a subfolder, but I haven't tried it yet. The direction is to call the subfolder "chrome," so I was wondering if that was application specific to the Chrome browser, though I don't know why that should be. . . . ?

Modified by pschwebe

more options

Chrome, in this case, refers to styles, and is not related to the Chrome browser, and predates it by several years. A css file in a chrome subfolder is also used with Firefox, which shares a code base with TB.

more options

Thanks! I'll apply the CSS and see how it works and let you know.

more options

If you're using TB 78, you will have to double-click toolkit.legacyUserProfileCustomizations.stylesheets to true in Config. editor, under Preferences/General.

more options

I've done all the above, but the text in both the sidebar and the message list refuses to get bigger. The text in the body of the emails is huge, but I can go back into prefs and reduce them. Thanks anyway. It's as if there's something in Catalina that is over-riding the app preferences for those particular text areas. Either that, or TB doesn't want me to change them. . .

more options

There are several pitfalls in applying css: the folder must be named chrome, and it must be a subfolder of the profile folder; the file in chrome must be named userChrome.css and be a css (Cascading Style Sheet) file type, not plain text, and the preference must be switched to true. If you select Help/Troubleshooting, click Show in Finder, the profile folder will open, so you can check that chrome and userChrome.css are in the right place.

more options

The problem I see with both of the proposed resolutions is that they only address part of problem. The font height changes but the line spacing is spread too much. The .css line-height property doesn't seem to be effective (see spaces identified by the arrows in the uploaded image).

more options

sfhowes said

If you're using TB 78, you will have to double-click toolkit.legacyUserProfileCustomizations.stylesheets to true in Config. editor, under Preferences/General.

So....where is this most important file toolkit.legacyUserProfileCustomizations.stylesheets? Did a find on the mac, no results.

If you're going to post file names, post the entire path.

more options

murphey said

sfhowes said

If you're using TB 78, you will have to double-click toolkit.legacyUserProfileCustomizations.stylesheets to true in Config. editor, under Preferences/General.

So....where is this most important file toolkit.legacyUserProfileCustomizations.stylesheets? Did a find on the mac, no results.

If you're going to post file names, post the entire path.

It's not a file, it's a preference in the TB Config. editor. Open Preferences in TB, type config in the search.