Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDF download button needs Save As

  • 4 replies
  • 2 have this problem
  • 94 views
  • Last reply by m6_dodds

more options

I'm on Mac. When I open a PDF in Firefox I get a print button and a download button. The download button does not offer a Save As option. It simply uses the name used in the browser - often this is a number or day or some other appellation that is less useful than allowing me to rename the PDF myself. Chrome offer to rename the file before saving but I hate Chrome.

Maybe I'm overlooking something?

All Replies (4)

more options

I have a Mac also and I know what you mean but what I have done is the Free Version of PDF Reader from Kdan from the App Store and tell Firefox to open the PDF file in the PDF Reader instead of saving it and use the Save As function in the App. Any PDF Reader App should do the trick.

Helpful?

more options

Thanks for the suggestion, which also apparently confirms that there is no built-in Save As hidden away in Firefox.

Helpful?

more options

While contemplating Tom J's answer to my query, I came up with this solution:

Select the Firefox PDF print button, then in the Mac print dialog, select the PDF popup menu in the lower left, where there is a Save As option. Not as elegant as a direct Save As button in Firefox itself, but it works.

Voila!

I use this for Etsy invoices that I sometimes print but always save as PDF's for reference.

Helpful?

more options

Same problem...but

Under Options - General - Downloads is Applications.

Go to PDF listing....next column change to "Always ask".

Now the "Save File" option will appear and you can rename it upon download.

Go figure that Downloads does not warn you that the Applications overrides the Downloads Options.

You need to do this for all file types listed in the Applications that you want that control of.

If you check the lower box...do this automatically from now on...it changes it in the Applications instead.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.