Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google News doesn't load completely or update in Firefox on either Windows 10 or OpenSuSE Tumbleweed

  • 1 reply
  • 1 has this problem
  • 4 views
  • Last reply by FredMcD

more options

For the last few Firefox versions (currently running 78), Google news doesn't load completely unless I immediately scroll down to the bottom of the page after accessing the site. If I wait a few minutes and scroll down, thumbnails are missing on several stories, and many of the stories don't load. All I see is a rotating arrow, as though something is waiting to load, but nothing more happens. If I scroll down all the way to the bottom of the page, every story loads normally. This happens with Win 10 and OpenSuSE Tumbleweed, both with the most recent updates this week, and others over the past few months.

Do I need to change settings? Any suggestions would be appreciated.

For the last few Firefox versions (currently running 78), Google news doesn't load completely unless I immediately scroll down to the bottom of the page after accessing the site. If I wait a few minutes and scroll down, thumbnails are missing on several stories, and many of the stories don't load. All I see is a rotating arrow, as though something is waiting to load, but nothing more happens. If I scroll down all the way to the bottom of the page, every story loads normally. This happens with Win 10 and OpenSuSE Tumbleweed, both with the most recent updates this week, and others over the past few months. Do I need to change settings? Any suggestions would be appreciated.

All Replies (1)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link}
by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh).
Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}