Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hide Firefox titlebar (border) in Linux (Openbox)

  • 1 reply
  • 1 has this problem
  • 1096 views
  • Last reply by ron80

more options

I use openbox as my windowmanager with NO desktop environment on Archlinux.

I want to hide the titlebar (border) but when using openbox this option is NOT SHOWN. It is shown when i use another Desktop Environment like xfce4 or Gnome.

In the past i found out that a variable like DESKTOP_ENVIRONMENT, DE or XDG_SESSION_DESKTOP could be set with the value of another Desktop Environment to mislead Firefox.

However, i can't find the right variable any more and i have been googling and googling for days :-(

Please help, i like openbox & firefox (without titlebar)

I use openbox as my windowmanager with NO desktop environment on Archlinux. I want to hide the titlebar (border) but when using openbox this option is '''NOT SHOWN'''. It is shown when i use another Desktop Environment like xfce4 or Gnome. In the past i found out that a variable like ''DESKTOP_ENVIRONMENT'', ''DE'' or ''XDG_SESSION_DESKTOP'' could be set with the value of another Desktop Environment to mislead Firefox. However, i can't find the right variable any more and i have been googling and googling for days :-( Please help, i like openbox & firefox (without titlebar)

Chosen solution

I found the answer, another one then the one I used before. The best solution is:

Add this to /home/user/.config/openbox/environment

export MOZ_GTK_TITLEBAR_DECORATION=client

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

I found the answer, another one then the one I used before. The best solution is:

Add this to /home/user/.config/openbox/environment

export MOZ_GTK_TITLEBAR_DECORATION=client