Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Gator designer

  • 8 replies
  • 1 has this problem
  • 17 views
  • Last reply by jscher2000

more options

I"m having trouble with Gator designer on Firefox? Weird text and controls don't render correctly. See screen shots. Any ideas?

Attached screenshots

Chosen solution

I'm puzzled there are no font requests. Here are a couple things to check:

Extensions

Some extensions block webfonts, also known as remote fonts. For example, the popular uBlock Origin and NoScript extensions can do that.

Font Settings

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Command+r or the circling arrow button, to see any difference)?


There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Was it any of those things?

Read this answer in context 👍 1

All Replies (8)

more options

One of those four is definitely a mess. I notice the shield icon is lit up purple at the left end of the address bar. Could you check whether Enhanced Tracking Protection is blocking something important used in the page? In particular, some web fonts?

Sorry, forgot to use the phrase: Please click that icon and check the drop-down.

Modified by jscher2000

Helpful?

more options

Hi and Thanks for your reply. Turning off enhanced tracking protections had no effect. Gave Gator.com freedom around cookies but no effect.

One suggestion from Gator is not enough line speed. But that doesn't seem right when Chrome is doing so well.

Hmmmmm

Helpful?

more options

Thanks for your suggestion. I turned it off and got the gray version with the cross bar. No effect. Gator has suggested line speed. My line speed doesn't hurt Chrome? I'll have to go somewhere to test line speed. Thanks again:)

Helpful?

more options

Where do the fonts load from? I don't know how you choose them, whether it is just a setting in the platform or you need to enter paths for those.

To investigate further, could you open the Network Monitor tool in the lower part of the tab (other browsers have a similar tool when you press F12). Either:

  • "3-bar" menu button > Web Developer > Network
  • (menu bar) Tools > Web Developer > Network
  • (MacOS) Command+Alt+e

When you reload the page (Command+r), Firefox should start listing all the files it is requesting, along with information about whether the request was successful. Above the list there are little filter buttons, so you can click on Fonts to narrow down what is shown.

Are there a lot of failures, or does the font file retrieval seem to be working normally?

Next, you could click over to the Console tab in the Developer Tools. Are there any error messages related to fonts here?

Helpful?

more options

I have included some screen shots. There is only one 404. Which is supposed to be cached? The Icons on the left side of the designer are missing and maybe setting off the problem? There are about double what you can see in the console shot. I can brag the my internic handle was once GLK3 but that was a very long time ago. I appreciate your expertise:)

Helpful?

more options

Chosen Solution

I'm puzzled there are no font requests. Here are a couple things to check:

Extensions

Some extensions block webfonts, also known as remote fonts. For example, the popular uBlock Origin and NoScript extensions can do that.

Font Settings

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Command+r or the circling arrow button, to see any difference)?


There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Was it any of those things?

Helpful?

more options

Bingo! You nailed it Big Guy. It was checking the box for "Allow pages to choose their own fonts, instead of your selections above" I'll let Gator.com know. I don't know the etiquette here, can I snail mail you some stickers?

Helpful?

more options

Glad to hear it works now. I'm not a huge user of stickers, but thank you for the offer. I hope the rest of your site building goes smoothly.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.