Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Importing contacts won’t keep phone numbers

  • 14 replies
  • 1 has this problem
  • 27 views
  • Last reply by sfhowes

more options

I tried importing my contacts as a vCard. It wont keep my contacts phone numbers. I also tried it as a CSV, but there’s no form field for a birthday

I tried importing my contacts as a vCard. It wont keep my contacts phone numbers. I also tried it as a CSV, but there’s no form field for a birthday

All Replies (14)

more options

The birthday fields are included in the import dialog, so you should be able to import them as well as phone numbers (see picture).

http://kb.mozillazine.org/Import_address_list_from_text_file

Modified by sfhowes

more options

I don't get the birthday options.

more options

Look at your csv in a text editor - the input fields in the right column are seldom aligned with the TB fields on the left without applying Move Up/Down.

more options

That's weird. I edited my CSV file and searched for Birth, but I found nothing (and saw no birthdays). I made the CSV file by converting a vCard to CSV. The vCard keeps the birthdays and phone numbers; the CSV keeps the phone numbers but not birthdays.

more options

How did you convert from vCard to csv? It looks like it omitted the birthday data.

more options

I uploaded it to Google Drive then downloaded it as CSV. I just ended up manually typing birthday data.

more options

Maybe it has to do with how the Birthday field is used. Does Thunderbird see the field as just one "Birthday" or three separate fields of "Birth Month", "Birth Day", and "Birth Year"?

more options

As you can see in the picture I posted above, there are 3 fields for the birthday. Exporting a contact as a csv from Google Contacts places the birthday in a single column field.

more options

Hi,

Sorry for the delay. I manually typed birthday data into Outlook as well, however I exported the Outlook contacts as a CSV file. If I open the CSV file with Excel, I can see a Birthday field, as well as multiple phone number and email fields. I see none of that in the Address Book fields when I import into Thunderbird.

edit: I also tried importing with Outlook, but it found nothing.

Modified by baseballruns

more options

I think there's a limit to the number of columns in a csv that can be imported, and Outlook csvs store some data in the 37th column or so. The best option is to rename the column names to match the TB layout, e.g.

First Name,Last Name,Display Name,Nickname,Primary Email,Secondary Email,Screen Name,Work Phone,Home Phone,Fax Number,Pager Number,Mobile Number,Home Address,Home Address 2,Home City,Home State,Home ZipCode,Home Country,Work Address,Work Address 2,Work City,Work State,Work ZipCode,Work Country,Job Title,Department,Organization,Web Page 1,Web Page 2,Birth Year,Birth Month,Birth Day,Custom 1,Custom 2,Custom 3,Custom 4,Notes,

more options

Do you recommend keeping blank spots, even if they aren't filled at all? I have no Fax Numbers, but should I add them in with Excel and save it?

more options

If your column names are the same as the ones in TB, you can delete empty, unused columns, but keeping them will make the input fields align with the address book fields more easily when you import.

more options

I just tried importing as CSV and it didn't work at all. I deleted the unused columns, and they have the same names. It completely ignores the names, leaving some contacts as blank and some contacts as having the name as the first part of the email address.

I think it might be because of the encoding of the file itself. Is there anything I can do to check about that?

more options

Open the csv in a text editor and check that the field names are separated by commas, not semi-colons. When you import to TB and see the window with the TB fields on the left and the input fields on the right, you have to check the relevant boxes and use the Move Up/Down buttons to align the two columns. It's difficult for me to advise when I don't know exactly what you're doing, but the import does work if done correctly.