Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox browser loads garbage text after 77.0.1 update

  • 9 replies
  • 1 has this problem
  • 75 views
  • Last reply by Felis-2

more options

My Firefox browser won't load any websites correctly after I closed and reopened it today and updated it to 77.0.1. All sites load as nothing but garbage text, preventing me from accessing ANYTHING, not even Google; it just appears as a white page filled with random garbage text, some as question mark squares. I have tried the following already, they have not worked:

  • Firefox is the only browser affected, IE works fine
  • I am connected to the internet just fine
  • I ran malware/virus scans, nothing came up
  • I disabled extensions and add ons, nothing changed
  • It still happens in Firefox Safe Mode and in Windows Safe Mode with Networking
  • sfc /scannow didn't fix it
  • Turning Hardware Acceleration on/off does nothing
  • Changing Unicode does nothing
  • Tracking Protection on/off does nothing

Please help me, I'd rather not have to resort to Refresh, System Restore or uninstall/reinstall Firefox over this issue given that it'd be difficult to get everything back.

Chosen solution

Hi Felis-2, someone on Reddit mentioned turning off a new feature to resolve this issue. There's a note in the code that this preference means "use DocumentChannel with parent process' sDocShell" but I don't know the consequences of changing it, so you may want to research it further:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste ppdc and pause while the list is filtered

(3) Double-click the browser.tabs.documentchannel.ppdc preference to switch the value from true to false

You may need to do a regular exit and restart of Firefox before that takes effect.

More info on about:config: Configuration Editor for Firefox.

Read this answer in context 👍 1

All Replies (9)

more options

Hi, felis-2

I don't know how but there was a variable automatically created in System properties/advanced system settings/advanced/environment variables/ called MOZ_FORCE_DISABLE_E10S so, just remove it and the problem will be solved.

Hope it helps you.

Thank you

more options

Himanshu prabhakar said

Hi, felis-2 I don't know how but there was a variable automatically created in System properties/advanced system settings/advanced/environment variables/ called MOZ_FORCE_DISABLE_E10S so, just remove it and the problem will be solved. Hope it helps you. Thank you

Can you please tell me how to access that? Is it in a file on my computer somewhere or?

more options

hello Felis,

please follow the steps Felis easy to resolved your problem:

Do you possibly have disabled multi-process in Firefox by using the MOZ_FORCE_DISABLE_E10S=1 environment variable?

Bug 1638652 - Content-Encoding not honored when e10s is turned off via browser.tabs.remote.autostart=false or MOZ_FORCE_DISABLE_E10S=1' (please do not comment in bug reports

[https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)]

tell me when resolved your problem and mark solution.

Thank you!

more options

You can access environment variables via the Windows Control Panel.

  • Control Panel > System > Advanced > Environment variables
  • Right-click My Computer > Properties > Advanced > Environment variables

You can clear the value on a specific variable to remove this environment variable.

more options

ARMAN KHAN said

hello Felis, please follow the steps Felis easy to resolved your problem: Do you possibly have disabled multi-process in Firefox by using the MOZ_FORCE_DISABLE_E10S=1 environment variable? Bug 1638652 - Content-Encoding not honored when e10s is turned off via browser.tabs.remote.autostart=false or MOZ_FORCE_DISABLE_E10S=1' (please do not comment in bug reports [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html)] tell me when resolved your problem and mark solution. Thank you!

cor-el said

You can access environment variables via the Windows Control Panel.
  • Control Panel > System > Advanced > Environment variables
  • Right-click My Computer > Properties > Advanced > Environment variables
You can clear the value on a specific variable to remove this environment variable.

I think I remember setting this up before. I'm afraid I can't remove browser.tabs.remote.autostart=false or MOZ_FORCE_DISABLE_E10S because my computer can't handle more than 1 firefox process running, and I've been told it was ok to set this. I don't want that issue again.

more options

I have now tried Refresh, uninstall and reinstall to no avail. These don't work, and I don't want to remove MOZ_FORCE_DISABLE_E10S if it means overheating my computer with more processes.

Funny that I find later that someone had the same issue after updating to 77 like me and yet IT HASN'T EVEN BEEN FIXED SINCE. This is a serious issue and yet it has to be fixed by reintroducing another glaring issue?

I can't believe I have to do a System Restore to fix this.

more options
  1. Bug is fixed in version 78. While waiting for update, you can remove the environment variable and limit a number of content processes in Options.
  2. They're going to drop support for MOZ_FORCE_DISABLE_E10S soon.
  3. Things are getting optimized, everything's smoother than two years ago.
more options

Chosen Solution

Hi Felis-2, someone on Reddit mentioned turning off a new feature to resolve this issue. There's a note in the code that this preference means "use DocumentChannel with parent process' sDocShell" but I don't know the consequences of changing it, so you may want to research it further:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste ppdc and pause while the list is filtered

(3) Double-click the browser.tabs.documentchannel.ppdc preference to switch the value from true to false

You may need to do a regular exit and restart of Firefox before that takes effect.

More info on about:config: Configuration Editor for Firefox.

more options

jscher2000 said

Hi Felis-2, someone on Reddit mentioned turning off a new feature to resolve this issue. There's a note in the code that this preference means "use DocumentChannel with parent process' sDocShell" but I don't know the consequences of changing it, so you may want to research it further: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box in the page, type or paste ppdc and pause while the list is filtered (3) Double-click the browser.tabs.documentchannel.ppdc preference to switch the value from true to false You may need to do a regular exit and restart of Firefox before that takes effect. More info on about:config: Configuration Editor for Firefox.

Thank you, it's fixed!