Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

all addons suddenly stopped working

  • 6 replies
  • 2 have this problem
  • 21 views
  • Last reply by kahlan1227

more options

About 30 seconds after opening the browser, my theme blinked off. The text color stays, but no graphics. Also my multirow bookmark toolbar addon suddenly disappeared. They are still enabled, they just don't do anything. I have already downloaded all current updates, and checked for updates on my addons. I have tried safe mode, disabling all, reenabling all. I have changed the prefs.js file (a fix on one of the posts). I have restarted the computer, windows xp, opened and closed browser. I can look at other themes, and the text color will change, but nothing else.

Chosen solution

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 👍 1

All Replies (6)

more options

Did you delete the prefs.js file to reset all the prefs?


It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

more options

Thanks, but unfortunately that didn't do it.

more options

Chosen Solution

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Attaching a screen shot. This is the theme "pink radiance" which certainly used to be pink, and with multirow bookmark addon set to 3 rows. Could this have anything to do with sync? i just created an account to link two computers, and now they both have this same problem. i havent tried creating a new profile yet, I'll try that next. Thanks!

more options

I'm not finding this theme via a search on the Add-ons website.

Are you sure that this theme is still available?

Only the image files of the currently selected Persona are stored in the Firefox profile folder. All other Personas are loaded from the server if you choose another Persona. So if the image files are no longer on the server then you only get the default text and background as specified and stored in the lightweightThemes.usedThemes pref as you can find on the about:config page.

more options

I created a new profile and transferred my bookmarks, history, etc. The new one works perfectly, and all my addons are functioning again. (btw, it was ALL themes that quit displaying, and Pink Radiance is still available, I have it on the new profile). Thank you SOOOOO much for your help. This was an extremely frustrating problem and your help was invaluable!!! Thank you!! Manda