X
Tap here to go to the mobile version of the site.

Support Forum

all addons suddenly stopped working

Posted

About 30 seconds after opening the browser, my theme blinked off. The text color stays, but no graphics. Also my multirow bookmark toolbar addon suddenly disappeared. They are still enabled, they just don't do anything. I have already downloaded all current updates, and checked for updates on my addons. I have tried safe mode, disabling all, reenabling all. I have changed the prefs.js file (a fix on one of the posts). I have restarted the computer, windows xp, opened and closed browser. I can look at other themes, and the text color will change, but nothing else.

About 30 seconds after opening the browser, my theme blinked off. The text color stays, but no graphics. Also my multirow bookmark toolbar addon suddenly disappeared. They are still enabled, they just don't do anything. I have already downloaded all current updates, and checked for updates on my addons. I have tried safe mode, disabling all, reenabling all. I have changed the prefs.js file (a fix on one of the posts). I have restarted the computer, windows xp, opened and closed browser. I can look at other themes, and the text color will change, but nothing else.

Chosen solution

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Next Generation Java Plug-in 10.67.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.11
  • Google Update
  • Creative Cloud Desktop Plugin.v_2_0_0_0
  • iTunes Detector Plug-in
  • GEPlugin
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 31.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
  • Support URL: https://support.mozilla.org/1/firefox/31.0/WINNT/en-US/

Extensions

  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • Multirow Bookmarks Toolbar 5.0.1 ({FBF6D7FB-F305-4445-BB3D-FEF66579A033})
  • OpenDownload² 4.0.0 ({210249CE-F888-11DD-B868-4CB456D89593})
  • StumbleUpon 4.16 ({AE93811A-5C9A-4d34-8462-F7B864FC4696})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Multirow Bookmarks Toolbar Plus 1.2 ({4c7097f7-08f2-4ef2-9b9f-f95fa4cbb064}) (Inactive)
  • Norton Toolbar 2014.7.6.15 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Toolbar - Big Fish Games 2.2 ({6847DFAE-037A-400c-A524-27F0A281B692}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 560 Ti
  • adapterDescription2:
  • adapterDeviceID: 0x1082
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1280
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-18-2013
  • driverDate2:
  • driverVersion: 9.18.13.1106
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage: http://www.google.com/ig|about:home
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 31.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1409530195
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1388159930

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17473 solutions 157934 answers

Did you delete the prefs.js file to reset all the prefs?


It is possible that there is a problem with the file(s) that store the extensions registry.

Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

See "Corrupt extension files":

If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

Did you delete the prefs.js file to reset all the prefs? ---- It is possible that there is a problem with the file(s) that store the extensions registry. Delete the extensions.* files (e.g. extensions.json, extensions.sqlite, extensions.ini) and compatibility.ini in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons If you see disabled or not compatible extensions in "Firefox/Tools > Add-ons > Extensions" then click the Tools button at the left end of the Search bar to check if there is a compatibility update available.

Question owner

Thanks, but unfortunately that didn't do it.

Thanks, but unfortunately that didn't do it.
cor-el
  • Top 10 Contributor
  • Moderator
17473 solutions 157934 answers

Chosen Solution

Can you attach a screenshot?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem *Use a compressed image type like PNG or JPG to save the screenshot *Make sure that you do not exceed the maximum size of 1 MB ---- Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

Attaching a screen shot. This is the theme "pink radiance" which certainly used to be pink, and with multirow bookmark addon set to 3 rows. Could this have anything to do with sync? i just created an account to link two computers, and now they both have this same problem. i havent tried creating a new profile yet, I'll try that next. Thanks!

Attaching a screen shot. This is the theme "pink radiance" which certainly used to be pink, and with multirow bookmark addon set to 3 rows. Could this have anything to do with sync? i just created an account to link two computers, and now they both have this same problem. i havent tried creating a new profile yet, I'll try that next. Thanks!
cor-el
  • Top 10 Contributor
  • Moderator
17473 solutions 157934 answers

I'm not finding this theme via a search on the Add-ons website.

Are you sure that this theme is still available?

Only the image files of the currently selected Persona are stored in the Firefox profile folder. All other Personas are loaded from the server if you choose another Persona. So if the image files are no longer on the server then you only get the default text and background as specified and stored in the lightweightThemes.usedThemes pref as you can find on the about:config page.

I'm not finding this theme via a search on the Add-ons website. Are you sure that this theme is still available? Only the image files of the currently selected Persona are stored in the Firefox profile folder. All other Personas are loaded from the server if you choose another Persona. So if the image files are no longer on the server then you only get the default text and background as specified and stored in the lightweightThemes.usedThemes pref as you can find on the <b>about:config</b> page.

Question owner

I created a new profile and transferred my bookmarks, history, etc. The new one works perfectly, and all my addons are functioning again. (btw, it was ALL themes that quit displaying, and Pink Radiance is still available, I have it on the new profile). Thank you SOOOOO much for your help. This was an extremely frustrating problem and your help was invaluable!!! Thank you!! Manda

I created a new profile and transferred my bookmarks, history, etc. The new one works perfectly, and all my addons are functioning again. (btw, it was ALL themes that quit displaying, and Pink Radiance is still available, I have it on the new profile). Thank you SOOOOO much for your help. This was an extremely frustrating problem and your help was invaluable!!! Thank you!! Manda