Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Version 77.0beta broke my message body colors + text color

  • 17 replies
  • 4 have this problem
  • 32 views
  • Last reply by bobn9lvu

more options

In all previous versions I was able to use my color setup but still keep my colors working. This current email has changed the color on a lot of my emails and made some nearly impossible to read. Some text will be white and I have to highlight it to read and the message body of reading emails will be black regardless of what I change it to. The only way I have been able to fix this was by overriding the colors with a high contrast theme but it's not pleasant on the eyes.

Changing the text and background colors do nothing and changing the themes do nothing as well. I'm currently using a userChrome.css to change the color on some things but it isn't creating any conflicts. The problems still persist even after removing the file all together.

The only thing I can think of creating the problem could be that I'm using a dark theme for windows which is making the text to default to white. The black text body could be due to me using a registry edit for a custom color on my task as well, but neither of these were a problem until this beta.

In all previous versions I was able to use my color setup but still keep my colors working. This current email has changed the color on a lot of my emails and made some nearly impossible to read. Some text will be white and I have to highlight it to read and the message body of reading emails will be black regardless of what I change it to. The only way I have been able to fix this was by overriding the colors with a high contrast theme but it's not pleasant on the eyes. Changing the text and background colors do nothing and changing the themes do nothing as well. I'm currently using a userChrome.css to change the color on some things but it isn't creating any conflicts. The problems still persist even after removing the file all together. The only thing I can think of creating the problem could be that I'm using a dark theme for windows which is making the text to default to white. The black text body could be due to me using a registry edit for a custom color on my task as well, but neither of these were a problem until this beta.

All Replies (17)

more options

I have the same problem. Plain text messages that come in all have black backgrounds which I can't override (not sure what the userChrome settings would be).

HTML formatted emails seem fine though.

more options
more options

Composition colors work fine for me, it's only when reading.

more options

re :The only thing I can think of creating the problem could be that I'm using a dark theme for windows

Are you using a more recent version of Windows 10 ?

If yes, there are two options, one is windows default and the other is default app mode.

  • Settings > Personalisation > Colours > Choose your colour > select 'Custom'

You will now see options for 'Choose your default Windows mode' and also 'Choose your default App mode'.

The 'Choose your default App mode' can influence Thunderbird. For example: If you use a 'Light Mode' in Thunderbird and a 'dark default app mode' in Windows, you will find some parts of Thunderbird acting like dark mode.

more options

Hi, thank you for the detailed reply. I can confirm it is the default app mode being set to dark causing the issue. I am on the most up to date public release version of windows 10. Windows dark apps was still working properly before this latest beta release of Thunderbird. It seems that Thunderbird will default to windows app settings on basic html messages no matter what your color settings are.

more options

Just upgraded to 77.0b2 for Mac. Have the same problem viewing incoming emails. I already had the black on white paper mode selected on previous upgrades for drafting new emails, but this is definitely new to the latest release.

more options

Please try this info and report back on results.

set 'ui.systemUsesDarkTheme'=1 when the dark theme is set and 'ui.systemUsesDarkTheme'=0 when the light theme is set (to override a dark system theme).

If you do not see 'ui.systemUsesDarkTheme' then you can create it.

Windows OS:

  • Menu app icon > Options > Options > Advanced > General

MAC OS:

  • Thunderbird > Preferences > Advanced > General

Linux OS:

  • Edit > Preferences > Advanced > General

click on 'Config Editor' button and accept risk

If search does not locate 'ui.systemUsesDarkTheme', then create it by right click in the list and * select 'New' > 'Integer'

  • Enter preference name: ui.systemUsesDarkTheme
  • click on OK
  • then set Value as 0 or 1 as approriate.
  • click on OK

Modified by Toad-Hall

more options

Okay so on Windows it semi works. The command is also ui.systemUsesDarkTheme without the ' .

ui.systemUsesDarkTheme=0 fixed my inbox and emails but now my options screen is using the light theme. I guess I can live with a light theme options menu but it still doesn't resolve the initial bug.

more options

I am now running 77.0b3 on my Mac (10.14.6)

I do not see the selection sequence Thunderbird > Preferences > Advanced > General.

It goes Thunderbird > Preferences > General with nothing that reveals any advanced choices. No hint of ui files in a search.

I vaguely recall choosing the dark mode many revisions ago, but don't see even a way to switch that back, assuming that is the only way to get readable text in the email space. (My Write window still shows black print on white paper as requested.)

more options

Can anyone explain these about:config color options to me. I'm somewhat familiar with hex and know how to edit this stuff in Firefox config. Specifically, I looking for light white/gray text on a dark gray background, both for mailbox display and inside each email. Naturally I also want any highlighting color to be visible by contrast. The simple background and foreground are obvious but the 'focus', 'anchor' etc aren't obvious.

more options

set 'ui.systemUsesDarkTheme'=1 when the dark theme is set and 'ui.systemUsesDarkTheme'=0 when the light theme is set (to override a dark system theme). This setting makes no difference to me (WN10 (20H2), TBird 78.3.2 (32-bit).) The only way I can fix incoming mail white-on-white subject lines and black background in mail composition is to switch to WN10 light mode. However, I prefer Windows Dark Mode. This problem occurred in previous versions of TBird but someone, somewhere, posted a fix which worked. I'd been running Windows Dark mode with TBird version 78.2 without this problem. v.78.3.2 changed this.

I'll try to find the fix I mentioned. It's probably on a drive in one of my many folders.

My instructions for Windows Menu app icon > Options > Options > Advanced > General would be.. Open TBird > Tools Menu > Options > General > Config Editor (scroll to bottom of page) Accept Risk Copy and paste set ui.systemUsesDarkTheme'=1 (or 'ui.systemUsesDarkTheme'=0') To change values, right click command and modify. When giving instructions it pays to remember the least experienced should be able to follow them. This is not a forum for experts though there may be some on board.

more options

Add I decided to install TBird v.76.0b3 x64 https://ftp.mozilla.org/pub/thunderbi.../en-US/ and have no problems with Dark Mode (Windows) affecting TBird's colors. You could try a more recent version, but not the latest, which may work, e.g. v.78.0.1. I think this was the version I was using without issues before the latest upgrade. I've gone further back to make sure. link text That these older versions (or this one) is problem free with WN10 20H2 (the latest public release suggests TBird v.78.3.2 is buggy (?) I'll not upgrade again until there's a post stating the TBird problems in this forum have been solved in a new version.

more options

The Dark theme works fine for displaying the dark colors - nice! - when looking at the mailBOX contents panel. I want the same colors when looking at an open Message. The ui.systemUsesDarkTheme is set to 1, but messages still are black text on white.

more options

re :I do not see the selection sequence Thunderbird > Preferences > Advanced > General......It goes Thunderbird > Preferences > General

That's because the original issue was in version 68*, thus: Thunderbird > Preferences > Advanced > General click on 'Config Editor' button

In version 78* it would be Thunderbird > Preferences > General Scroll down to very bottom click on 'Config Editor' button


re :but messages still are black text on white. I do believe this was set as a default to get around the issue of black or dark grey text on black background.

I can swap to seeing white text on black background (see instructions below), which is perfectly ok for plain text emails or emails that were sent as html but did not contain html code to force a colour in the email. But with emails sent to you that contained html css in the code which used black or darker grey text and which did not specify background as white (the sender assumed you used white background), then it raises the problem of black/grey on black which is undesireable. Hence why the default setting of forcing black text on white background.

BUT and this is your choice....if you choose to view those types of emails using 'Menu app icon' > 'View' > 'Message Body as' > 'Simple HTML' then the following instructions will work for you in all emails.

  • In Menu app icon > Options/Preferences > General
  • Scroll down to 'Language & Appearance' section
  • under 'Fonts & colours' sub section
  • click on 'Colours..' button
  • Set 'Text' as 'White'
  • Set 'Background' as 'Black'
  • click on 'OK'

Modified by Toad-Hall

more options

So you can set to use Black text on White background as per instructions in previous comment. But if you get an email where the sender used dark text and you cannot read it without highlighting that bit of text, then use:

'Menu app icon' >  'View' > 'Message Body as' > 'Simple HTML' 

You can choose to remain using that mode of viewing for all emails or only use it on those emails that are a problem reverting back to the 'Original HTML' option afterwards.

more options

Hmm, now that this has been pointed out I'll probably stick with black on white. If there were a simple toolbar icon toggle extension such as Dark Background and Light Text or better yet Dark Reader for Firefox I'd go for that, but I don't want to have to go into these internal options to do switching. Thanks, I'll think about it.

more options

A quick fix is to restart Thunderbird in safe mode with all add-on's disabled, then do a restart again with all enabled, somehow this fixes the white text on white background problem until you upgrade Thunderbird again, then you rinse-repeat to fix display. The above works fine on my Win 10 Pro set to dark Windows and light apps.