Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Latest version of Firefox causes intermittent lag spikes

  • 2 replies
  • 1 has this problem
  • 665 views
  • Last reply by vk2farg

more options

I have the latest version (76.0.1) and I've noticed that the browser itself is giving me problems with my ping - specifically a high ping spike every 5 seconds. At first I thought it might be my wireless receiver playing up on me (I don't have a hardline connection, it's not an option) as I use a 4G router or my phone as a 4G access point.

While doing troubleshooting and trying to find ways of making the lag minimise or stop altogether, I upgraded the wireless receiver's drivers and restarted the system. All started out well as it rebooted, I had Pingplotter up and testing a ping to Google, was looking good as the ping stayed mostly in the green (I'm in Australia, high ping is a thing here). So I booted up Firefox, and the ping started going back to the way it was before I rebooted the system, ie. a high ping spike (in the red) every 5 seconds. There's a definite pattern to it as well, as I have saved graphs showing what's going on.

I'm using Chrome for the time being, but I've been using Firefox for years prior and very minimal hiccups to speak of, until now. This is a BIG hiccup for me, as I use my PC for gaming online, and this ping spike every 5 seconds is unacceptable.

I'm willing to try out any possible fixes, but at this point it's DEFINITELY a Firefox issue reacting badly with my internet connection.

I have the latest version (76.0.1) and I've noticed that the browser itself is giving me problems with my ping - specifically a high ping spike every 5 seconds. At first I thought it might be my wireless receiver playing up on me (I don't have a hardline connection, it's not an option) as I use a 4G router or my phone as a 4G access point. While doing troubleshooting and trying to find ways of making the lag minimise or stop altogether, I upgraded the wireless receiver's drivers and restarted the system. All started out well as it rebooted, I had Pingplotter up and testing a ping to Google, was looking good as the ping stayed mostly in the green (I'm in Australia, high ping is a thing here). So I booted up Firefox, and the ping started going back to the way it was before I rebooted the system, ie. a high ping spike (in the red) every 5 seconds. There's a definite pattern to it as well, as I have saved graphs showing what's going on. I'm using Chrome for the time being, but I've been using Firefox for years prior and very minimal hiccups to speak of, until now. This is a BIG hiccup for me, as I use my PC for gaming online, and this ping spike every 5 seconds is unacceptable. I'm willing to try out any possible fixes, but at this point it's DEFINITELY a Firefox issue reacting badly with my internet connection.

Chosen solution

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button Fx57Menu, click Help Fx57Help and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Fx68SafeMode

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Hello,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button Fx57Menu, click Help Fx57Help and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

Fx68SafeMode

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

I think I managed to nut this one out, thanks to the above guide. It seems to be the weather extension causing this ping spike, after a lot of testing and fault-finding.

Now I have to be the bearer of bad news to poor Tim because his extension (for some reason) doesn't play nicely with this version of Firefox.