Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

messages move to junk with filter rule and manually moved to inbox are immediately sent back to junk

  • 4 replies
  • 1 has this problem
  • 80 views
  • Last reply by Mark Foley

more options

We are using spamassassin on the email server to mark messages as spam. This is done by adding "[SPAM]" to the subject line of the message. I have a filter rule in TB to move messages with "[SPAM]" in the subject to the junk folder. Of course, sometimes there are false positives and the user(s) want to move these message back to the inbox. However, after doing so the message is immediately moved back to junk because the subject still contains "[SPAM]". The filter has "Apply when Getting New Mail" checked. This is not new mail. I would assume the "getting new mail" bit applies when retrieving new mail from the server, but apparently "getting new mail" doesn't mean that. Users aren't normally able to modify the subject text. Is there any way for these message to be moved back to the inbox and not be re-processed as junk?

All Replies (4)

more options

When you set / enable Thunderbird to trust spamassassin, I don't think you can unjunk a message. So if you put in back into Inbox I would expect it to move again. What happens if you move it to a non-Inbox folder?

Helpful?

more options

Moving to to a non-inbox folder leaves it there. I assume the filter rule "Getting New Mail" checkbox implies the inbox only, at least it appears to.

Well, you're probably right. It would be nice if the "getting new mail" setting applied only when retrieving new mail from the server, not mail already retrieved, read and moved into the inbox folder. That would be a useful feature. Spamassassin is widely used on mail servers so as to control spam at the enterprise level and not just at the user level. Something for the suggestion box.

I'll give this a day or two in case anyone knows of a magical setting, or something in the config editor.

Helpful?

more options

I used SA a lot in the past, and with Thunderbird. But not with recent versions of TB. but I know the TB behavior / code has NOT changed.

In short, when you set it to "trust" SA you're stuck with it. If you need adjustments, it must be done on the SA side - whitelists, blacklists, score weights, etc

Helpful?

more options

Yes, in fact I've set the particular sender in question to be whitelisted, but that doesn't help with the messages already received. I'll suggest as a solution to the user to move such messages to some other folder than the inbox. I might also propose to Mozilla to not re-process filter rules marked as "when getting new mail", unless the user manually runs the rule.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.