Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mi sitio web no se muestra correctamente en Firefox

more options

Buenas tardes, antes de nada, gracias por leerme. Os cuento mi sitio web que os muestro a continuación, se muestra bien en otros navegadores, pero está algo más que roto en Firefox. He adjuntado 2 capturas de pantalla de cómo se ve, en mi versión última de Firefox, navegando desde España. La dirección de mi web por si queréis probar vosotros es la siguiente: https://www.convertidor.es

Como puede ver, se ve algo raro y roo. He leído bastante sobre cuál podría ser el problema, pero todas las sugerencias que he encontrado no me quedan muy claras la verdad ... Por ejemplo, vaciar el caché, borrar las cookies, verificar el zoom, actualizar el navegador etc.… Si alguien le ha pasado antes, la verdad es que agradecería que me ayudase si es posible a como poder solventar el problema.

Cualquier ayuda sería de bastante utilidad para mí la verdad.

Un saludo.

Attached screenshots

Chosen solution

Hola, El caso esta abierto desde hace unos meses en el foro de Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=1626997 Según veo la característica esta disponible pero no viene habilitado por defecto en el Firefox porque se esta verificando y probando: Si se cambia el valor network.preload a true tu pagina carga y se ve correctamente.

Puedes ayudar para que dicha características este disponible por defecto votando y aportando tu pagina para realizar pruebas de compatibilidad en el enlace que te pase anteriormente

Finalmente completa esta consulta como resuelta para que sirva a otros usuarios y continua el caso en el foro de Bugzilla. Gracias!

Read this answer in context 👍 0

All Replies (6)

more options

¡Hola Jesús!

Te recomiendo validar el HTML y CSS con las siguientes herramientas:

Las intenté utilizar pero parece que el sitio está fuera de línea actualmente:

   500 Can't connect to www.convertidor.es:443 (Name or service not known)

Por favor dinos si esto resuelve tu pregunta.

¡Gracias!

more options

Hola Alex.

Prueba de nuevo por favor.

Pero, no, eso no resuelve mi pregunta.

Gracias.

Modified by Jesús Porras

more options

Hola Jesús, Lo que te comenta Alex es para que verifique tu sitio en el validador de sitios Webs de W3 y en el caso de encontrar errores intenta corregirlos y probar de nuevo. Veo que muchas veces el sitio tarda mucho en cargar (de 2 a 3 minutos) tanto que el validador no puede chequear el sitio. Otra prueba que puedes hacer es usar la consola y el inspector del Firefox, en la consola me aparece este error: TypeError: can't access property "innerHTML" .... En cuanto a las recomendaciones de borrar cache, cookies, etc eso es cuando el problema ocurre en una determinada Computador o Firefox, acá el problema me ocurre a mi también, por lo tanto o es algo de la pagina o es algo general del Firefox (pero esto es poco probable).

Bueno mientras escribía esto el validador logro cargar la pagina, aparecen varios errores y uno justamente esta referido al elemento que no se ve correctamente (segun logre ver con el inspector):

Error: Element li not allowed as child of element span in this context. (Suppressing further errors from this subtree.)..... Saludos

Modified by GerardoPcp04

more options

Estás utilizando la siguiente línea para cargar tu archivo CSS:

<link rel = "preload" href = "/ css / style.css" as = "style" onload = "this.rel = 'stylesheet'">

Esta es una característica experimental. La precarga del valor rel no es compatible con Firefox y solo es compatible con Google Chrome. Por lo tanto, Firefox no puede ver su archivo CSS y sus elementos no están diseñados correctamente.

more options

Cuando implementará firefox la nueva tecnología para que se vea bien ?


https://support.mozilla.org/en-US/questions/1248200

more options

Chosen Solution

Hola, El caso esta abierto desde hace unos meses en el foro de Bugzilla: https://bugzilla.mozilla.org/show_bug.cgi?id=1626997 Según veo la característica esta disponible pero no viene habilitado por defecto en el Firefox porque se esta verificando y probando: Si se cambia el valor network.preload a true tu pagina carga y se ve correctamente.

Puedes ayudar para que dicha características este disponible por defecto votando y aportando tu pagina para realizar pruebas de compatibilidad en el enlace que te pase anteriormente

Finalmente completa esta consulta como resuelta para que sirva a otros usuarios y continua el caso en el foro de Bugzilla. Gracias!

Modified by GerardoPcp04