Search Support

My Samsung smart tv says the browser needs updated, yet the automatic update says no update available.

  • 2 replies
  • 1 has this problem
  • 129 views
  • Last reply by tulsamike

more options

Samsung UN60KU6270F. 2016 model. Current version 1241

Which Firefox version do I need to download? The mozilla site defaulted to offering the Linux 64 bit version.

Newbie here needing pointed to proper version.

Thanks

x @aol.com


edited email address from public and search/spam bots view.

Modified by James

Chosen solution

Hi Mike

Firefox is not available for the Samsung Smart TV. You will need to use an Amazon Fire TV device to have Firefox on your TV.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hi Mike

Firefox is not available for the Samsung Smart TV. You will need to use an Amazon Fire TV device to have Firefox on your TV.

Helpful?

more options

Thank you

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.