Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After update Debian 10 Firefox only recognizes English layout keyboard. Others softwares work well.

  • 3 replies
  • 3 have this problem
  • 54 views
  • Last reply by maurrox

more options

Good afternoon!

After an update has occurred in my Debian 10, Firefox now recognizes only the US English keyboard layout. in short, I can not type anything with accent. My keyboard layout is "Brazilian Portugueses ABNT 2" and now I have to go looking for where the necessary keys are. And even finding the location of the keys still can not put the appropriate accents in words. For now, I only detected this problem in Firefox. Constantly, I use GEdit and Libreoffice and both work well. including, so that the text of this situation, I'm posting here, get all cute with sharp words and so on, had to do everything in GEdit, copy and paste here on this site.

For if I did not do so could not emphasize the words. I believe the problem is in Firefox, then I downloaded the latest version on the site yesterday (03/27/2020), the 74.0 version, but it doesn't works too. I configured Firefox language to Brazilian Portuguese, but it doesn't work tool.

The operating system is all right, because, as mentioned above, the other softwares are seeing the correct layout of the keyboard (Brazilian Portuguese ABNT 2). If anyone has any hint of what might be done to the Firefox pass to see the keyboard layout set in the operating system and can post here, will be of great help. Therefore, I did not want to install another browser.

Beforehand, thank you!

Chosen solution

Same problem here running on Debian 10, GNOME 3, Firefox version 74.0.1 with Swiss German keyboard layout.

Temporary fix (until next system reboot): In GNOME 3 settings: - add and change to english keyboard layout - change back to your previous keyboard layout - remove english keyboard layout

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Same problem here running on Debian 10, GNOME 3, Firefox version 74.0.1 with Swiss German keyboard layout.

Temporary fix (until next system reboot): In GNOME 3 settings: - add and change to english keyboard layout - change back to your previous keyboard layout - remove english keyboard layout

Helpful?

more options

Note that you should always be able to enter accented character on Linux by using a compose key combination.

Helpful?

more options

Same problem after update in Debian 9. I have a apple keyboard and the problem disappear when i put compatibility option in Tweak ... see image.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.