Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

sidebar spontaneously opens by itself rapidly even when the shortcut is not on the toolbar .

  • 5 replies
  • 1 has this problem
  • 23 views
  • Last reply by McCoy

more options

-This is on the most current version of Firefox. - This occurs anywhere in Firefox not on a particular website. - even after refreshing Firefox or reinstalling Firefox the bug is still present. - Clearing cookies,history, or cache does not do anything. - Hiding sidebar shortcut in the 'customize' option doesn't resolve the error

Chosen solution

Bummer !

Two more things I would like you to try :

In the profile folder, rename "xulstore.json" to something else, e.g. "xulstore.json.old" and if that doesn't make a difference :

Let's try Firefox in Safe Mode :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

And : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems


It can't be because you restore the previous session, as this doesn't just happen on startup, right ?

Read this answer in context 👍 1

All Replies (5)

more options

Hello oscarrivas480,

Would you please type in the address bar about:support
(press Enter) => Profile Folder => Open Folder

Then check if you have a user.js file in your Firefox profile
folder, and if so : rename it or remove it.

(you'll have to close Firefox first)

Any luck ?

Helpful?

more options

Hi McCoy! Thanks for your help today !

Unfortunately there was no user.js on the Profile Folder.

Is there anything else I can do?

Helpful?

more options

Chosen Solution

Bummer !

Two more things I would like you to try :

In the profile folder, rename "xulstore.json" to something else, e.g. "xulstore.json.old" and if that doesn't make a difference :

Let's try Firefox in Safe Mode :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

And : https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems


It can't be because you restore the previous session, as this doesn't just happen on startup, right ?

Helpful?

more options

Changing xulstore.json to xulstore.old restored it! Everything looks good now!

Thanks for your assistance McCoy!

Helpful?

more options

oscarrivas480 said

Changing xulstore.json to xulstore.old restored it! Everything looks good now!

Thanks for your assistance McCoy!

    My pleasure - I'm so glad that worked; well done !

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.