Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox update signed me out of all websites.

  • 4 replies
  • 1 has this problem
  • 25 views
  • Last reply by jscher2000

more options

I am not keen on saving all login information to the master password. Firefox update never did this to me, until yesterday on 03/12/20, it did. Is there a way to prevent this from happening again, or is resistance futile?

Chosen solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

FredMcD said

Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out. Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings. Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Thank you so much.

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution.

Thank you for contacting Mozilla Support.

more options

Hi Jettugi, did you install the Facebook Container add-on around the time this happened? A couple of users have reported that their cookies were removed when they did that, but it might be a coincidence.