Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Creates multiple copies of drafts

  • 9 replies
  • 2 have this problem
  • 1005 views
  • Last reply by iluvemail

more options

Thunderbird is making tons of 'draft' copies of emails I write. Basically if I don't quick complete an email within minutes...a draft copy is saved. And it keeps saving additional draft copies until I send the email!! Is there a setting so drafts just get overwritten to 1 copy (like every other email program in the world)... and then will disappear after the email gets sent? I constantly get interrupted so the draft folder ends up with TONS of drafts and makes me question whether or not I actually sent the email!! yikes thanks for any help

Thunderbird is making tons of 'draft' copies of emails I write. Basically if I don't quick complete an email within minutes...a draft copy is saved. And it keeps saving additional draft copies until I send the email!! Is there a setting so drafts just get overwritten to 1 copy (like every other email program in the world)... and then will disappear after the email gets sent? I constantly get interrupted so the draft folder ends up with TONS of drafts and makes me question whether or not I actually sent the email!! yikes thanks for any help

Chosen solution

Is this an IMAP account? Multiple drafts often happen when the drafts are stored on the IMAP server, meaning they have to be uploaded to the server. If you don't need to access drafts on other computers, try setting the Drafts folder to Local Folders in the Copies & Folders section of Account Settings, and see if drafts work as expected.

Read this answer in context 👍 2

All Replies (9)

more options

Chosen Solution

Is this an IMAP account? Multiple drafts often happen when the drafts are stored on the IMAP server, meaning they have to be uploaded to the server. If you don't need to access drafts on other computers, try setting the Drafts folder to Local Folders in the Copies & Folders section of Account Settings, and see if drafts work as expected.

more options

Thank you sfhowes!!! That works perfectly!

)
more options

Is there a fix for if I DO need the drafts to backup to gmail?

Problem here is my husband is old school, hates computers, doesn't understand Word and uses his email (closest i could find to Windows Live Mail) to do what he should be doing in Word.

That means he needs his drafts to backup so I use the IMAP as his safety net. This way if his system crashes or the email crashes or does something funky he still has a backup of his sent and draft emails on a separate gmail account.

I wasn't having the problem with multiple drafts until about a month ago. Now it's driving him bananas to see 30 copies of the same draft email in his inbox. When it's sent he has 1 sent and 29 copies to manually delete.

Is there any solution that will still allow for a backup ?????!!!!!?????

more options

If you are worried about losing drafts due to a system or email crash, using IMAP drafts is probably the least reliable method. One doesn't need to choose between Word and email to ensure safe backups. There are plenty of text editors and simple word processors with autosave options, e.g. EditPad Lite. The autosave option is user-set and entirely local, and doesn't depend on the performance of email apps or network connections. Simply copy the content into a new TB message when the final version is ready to send. Gmail automatically copies sent messages to the Sent folder, as a secondary backup besides the text document.

more options

I'm using IMAP because he doesn't understand any other program outside of his offline email. He can't retrieve messages and I retrieve them online and hardcopy print them for him.

I think I found a solution. I went into Tools > Account Settings then Synchronization and Storage. Under Message Synchronizing I clicked Advanced then unclicked the [Gmail]/Drafts folder. I have All Mail unclicked as well. I notice that the drafts keep piling up online in the gmail account, but only the most current is saved offline so that seems to have solved the problem.

When I click on the ALL MAIL all the drafts do show up and I'm not sure why, but as long as he can't see them from the DRAFTS folder it solves my problem.

My husband --- We do things the dumbest (and most illogical) way possible because it's easier for him. Sometimes you just have to do it that way.

more options

I have this same problem, but it's not on an IMAP account it's on a POP. I do have several accounts on my machine and a few are IMAP. But it's on my POP account when I'm writing an email, and it just keeps saving multiple versions of the email as i'm writing (almost like an increment and save feature). I could have swore on the older thunderbirds it just kept overwriting whatever temp draft message it created instead of creating new copies? And then once you sent the drafts went away? Currently, even when I send all the old drafts it created are still there. Any ideas? Can I make it just keep auto saving over the same draft email as opposed to making several copies?

(And currently my POP is set to my local drafts folder).

more options

I have the same problem, but an error message appears : Votre brouillon n’a pas été copié dans votre dossier Brouillons (Brouillons) en raison d’un problème d’accès au réseau ou au fichier. Vous pouvez recommencer ou enregistrer le brouillon en local dans Dossiers locaux/Brouillons-mnnn@nnn.fr.'' 3 options under the message : Réessayer, Enregistrer, Ne pas enregistrer. If I choose the 1st or the 3rd, Thunderbirds aborts. The sending can take up to 1 minute or more, then message appears : "Votre message a été correctement envoyé et enregistré, cependant une erreur est survenue lors de l’application des filtres de messages sur ce dernier." The message is then sent twice  !!!!

It takes ages to send

I just changed back to SMTP again, hope it will work better

Thanks a lot in advance for your reply DP

more options

I have this same problem. I don't mind the multiple copies a much as the fact that it doesn't clean up after itself when you actually send the message ... you have to go manually delete them. So my drafts keeps having a badge that says there are "unread" messages in there so I keep thinking I haven't finished a message, when in fact I have. It's quite annoying.

That behavior has only been happening in the last month or so (I'm guessing because with the pandemic I kind of have a warped sense of time at the moment). It's like something has changed in how it handles it or there's a new config parameter that changed defaults or something. Does anyone have any ideas?

Mine is IMAP and I need to keep it IMAP since I need it on multiple devices so the chosen solution doesn't work for me. I would really like to know why this suddenly stopped working as before and how to fix it.

Thanks.

more options

After I posted that I found this thread:

https://support.mozilla.org/en-US/questions/1282944

It's about someone having the same problem with POP but it worked for IMAP as well making the appropriate adjustments to the sub-folder names.

This method fixed my problem ... no idea why it did, but it did.

Hopefully it will help y'all as well