Search Support

I have changed the language of Firefox but it does not apply to some parts

  • 4 replies
  • 2 have this problem
  • 119 views
  • Last reply by McCoy

more options

I have changed Firefox language to English from Preferences > Language However, in some part of Firefox it is still Turkish (The country I have downloaded it from). For example, Firefox menu is all Turkish. But File menu is all English. Also most of in-app dialogues are Turkish.

Chosen solution

Hello pixelgravity,

Maybe you'd like to download Firefox in en_US using this link :

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

(make sure to select Mac OS ... )

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Hello pixelgravity,

Maybe you'd like to download Firefox in en_US using this link :

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

(make sure to select Mac OS ... )

Helpful?

more options

You can check all installed language packs under on "about:addons -> Languages" and make sure they have been updated to the current release (cogwheel button -> Check for updates).

You may also have to start Firefox once with the -purgecaches command line switch to refresh the startup caches. Make sure that Firefox is closed via "Firefox -> Quit Firefox".

On Mac you need to open a terminal window to be able to enter this command.

  • Mac HD -> Applications -> Utilities -> Terminal

Helpful?

more options

McCoy said

Hello pixelgravity, Maybe you'd like to download Firefox in en_US using this link : https://www.mozilla.org/en-US/firefox/all/#product-desktop-release (make sure to select Mac OS ... )

Thanks it worked!

Helpful?

more options

pixelgravity said

Thanks it worked!

    My pleasure - I'm glad it worked !

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.