Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

local folders don't show up after moving profile

  • 2 replies
  • 1 has this problem
  • 56 views
  • Last reply by GayzeN

more options

I was using the Thunderbird 68.4.2 on Windows 7 on my PC laptop. I had my profile folder within OneDrive so it would create automatic cloud backups. There were some glitches early on after instigating this process, but I worked them out, and it was running smoothly. After being nagged constantly by the "We've Abandoned 7" blue screen, I upgraded the PC to 8.1 the other day. I reinstalled Thunderbird fresh, and created a new profile pointing to my previously working folder. It worked fine. For a day.

Late in the second day, after answering some email and closing Thunderbird, I opened it again a few hours later to find it was a blank box, a non-working menu across the top, and an empty folders panel and main mail panel. Nothing clicked, nothing worked. I spent the rest of that evening and the following morning attempting many of the solutions for similar problems found here, to no avail. Many of what I found pointed to Windows 8.1 and OneDrive not playing together nicely. Today, I decided to just create a new profile on my C drive in the default location for Thunderbird. I began with a fresh profile, and recreated all of my mail accounts. I reinstalled all of the add-ons I use every single day. All was working just fine until I copied my local folders from my old profile directory. (Note, nothing I did to try to remedy the initial problem touched those folders.)

None of my copied local folders are showing up within Thunderbird's folder tree. I copied all of the .sbd files as well as the .msf files that go with them. I've checked, and all folders and subfolders are there, and all of my saved emails appear to be right where they should be. So far I have tried:

--Deleting foldertree.json and letting it recreate itself --Going into the account settings for Local Folders and pointing the Browse function to the correct Local Folders directory --Creating a new local subfolder from within Thunderbird and restarting. The new folder is in the directory in Windows Explorer, and it shows up in Thunderbird just fine, but none of my copied-over folders show up.

I've searched the archives, and found numerous instances of the same thing happening to others, but I've yet to find one that was quite the same as my situation (the above suggestions all appear to have worked for someone else). I have not tried using Import/Export tools yet, because I'm not sure if it will import entire folders that are already in their correct location, or if it will duplicate everything on me. I need to keep researching this. I really need those local folders, though, and the process I used to copy them should have worked (I've done the same thing successfully a few times in the many many years I've used Thunderbird ... I think since version 1).

Any suggestions?

Modified by GayzeN

Chosen solution

you copies the MSF and SDB. did you actually copy the mail files. They have the same name as the MSF files (which are not required) and have no file extension.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

you copies the MSF and SDB. did you actually copy the mail files. They have the same name as the MSF files (which are not required) and have no file extension.

more options

That did it. Thank you!

I spaced on the fact that Windows Explorer doesn't show all files by default.

Modified by GayzeN