X
Tap here to go to the mobile version of the site.

Support Forum

Firefox block autoplay not working, preferences are showing "Block Audio and Video"

Posted

Hi there!

I have been having trouble with Firefox continuing to autoplay videos even with preferences set to "Block Audio and Video."

If I go to twitter.com or elsewhere Firefox will show that auto play is disabled, but videos will autoplay with no audio. I would just like to get this feature working as autoplaying videos are incredibly annoying!

Thanks for any help!

Firefox 72.0.1

Hi there! I have been having trouble with Firefox continuing to autoplay videos even with preferences set to "Block Audio and Video." If I go to twitter.com or elsewhere Firefox will show that auto play is disabled, but videos will autoplay with no audio. I would just like to get this feature working as autoplaying videos are incredibly annoying! Thanks for any help! Firefox 72.0.1

Chosen solution

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 5 [0:allow; 1:blockAudible; 5:blockAll]
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17866 solutions 161679 answers

Chosen Solution

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 5 [0:allow; 1:blockAudible; 5:blockAll]
  • media.autoplay.allow-extension-background-pages = false
  • media.autoplay.block-event.enabled = true
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

You can look at these prefs on the about:config page to see if these values work for you. *media.autoplay.default = 5 [0:allow; 1:blockAudible; 5:blockAll] *media.autoplay.allow-extension-background-pages = false *media.autoplay.block-event.enabled = true *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you.
Was this helpful to you? 1
Quote

Question owner

Settings have been changed and are working for all media. Thank you so much!

Settings have been changed and are working for all media. Thank you so much!

Modified by GuyManSir657438

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.