X
Tap here to go to the mobile version of the site.

Support Forum

Signature always that the bottom of a reply

Posted

I've tried all variations in Account Settings / Composition & Addressing. I've tried shutting down and restarting Thunderbird in Safe Mode, but my signature ALWAYS gets placed below the message I'm replying to. In short, I get this:

-My reply -Original message -My signature

when I expect this:

-My reply -My signature -Original message

Here's what I've got set: When quoting: Start my reply above the quote and place my signature: Below my reply (but above the quote)

It just doesn't work. I have to cut and paste my signature from the bottom of the message every time.

(Thunderbird version 68.2.2, running on Linux.)

I've tried all variations in Account Settings / Composition & Addressing. I've tried shutting down and restarting Thunderbird in Safe Mode, but my signature ALWAYS gets placed below the message I'm replying to. In short, I get this: -My reply -Original message -My signature when I expect this: -My reply -My signature -Original message Here's what I've got set: When quoting: Start my reply above the quote and place my signature: Below my reply (but above the quote) It just doesn't work. I have to cut and paste my signature from the bottom of the message every time. (Thunderbird version 68.2.2, running on Linux.)
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

Toad-Hall
  • Top 10 Contributor
1867 solutions 12650 answers

I have a signature set up in the Account Settings for a mail account. I have setup the same settings as you. When I reply, it is in the expected order. -My reply -My signature -Original message

However, I also use an addon called 'Signature Switch'. When I use that addon to apply the signature in a Reply then it will always remove my auto signature and add the selected signature to the bottom below the quote, so I either live with it or manually cut and paste.

Do you use 'Signature Switch' addon?

Do you get the same results when you start Thunderbird in SAfe Mode?

I have a signature set up in the Account Settings for a mail account. I have setup the same settings as you. When I reply, it is in the expected order. -My reply -My signature -Original message However, I also use an addon called 'Signature Switch'. When I use that addon to apply the signature in a Reply then it will always remove my auto signature and add the selected signature to the bottom below the quote, so I either live with it or manually cut and paste. Do you use 'Signature Switch' addon? Do you get the same results when you start Thunderbird in SAfe Mode?
Was this helpful to you?
Quote

Question owner

Thanks for your reply.

No, I didn't use the 'Signature Switch" addon, so I tried it. I set it up with a couple of sigs, but it still puts the sig at the bottom of the message. In other words, I get:

-My reply -Original message -My signature

(And yes, I did try Thunderbird in Safe Mode before installing Signature Switch, and the behavior was just the same.

Thanks for your reply. No, I didn't use the 'Signature Switch" addon, so I tried it. I set it up with a couple of sigs, but it still puts the sig at the bottom of the message. In other words, I get: -My reply -Original message -My signature (And yes, I did try Thunderbird in Safe Mode before installing Signature Switch, and the behavior was just the same.
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1867 solutions 12650 answers

re: When quoting: Start my reply above the quote and place my signature: Below my reply (but above the quote)

  • Edit >Preferences > Advanced > 'General' tab
  • click on 'Config Editor' button
  • In search type: bottom

For each mail account set up with preference to put signature below reply above quote. The mail identity for sig_bottom should appear as False and in bold font because it is a user setting. eg:

  • mail.identity.id1.sig_bottom Value false

However, I'm assuming you can see it is already set as False for the identity. So, something is overriding your setting. Check the default setting:

  • mail.identity.default.sig_bottom

The Value may be set to 'True' and causing the problem (it should not be, but I think it is) Double click on that line to toggle the value to 'False', so you have this:

  • mail.identity.default.sig_bottom Value = False
  • Exit the 'about: config' window by clicking on the top right X

Note: This will not change anything in any currently opened Reply Write window.

  • Close any currently opened Write window.
  • select email and click on 'Reply'.

If signature switch is disabled then it will not interfere and the signature should always appear correctly.

Unfortuantely, although 'Signature switch' is really useful, it's one problem is with 'Reply' and 'Forward' in that it does not put any selected 'Signature Switch' signature above the quote. So, you click on Reply or Forward and the default one as set in Account Settings is correct, but you want to modify, so you use Signature Switch. It removes the default set in account settings and puts the selected signature below the quote. But otherwise it is a great addon.

Please try this info and report back on whether changing the default sig_bottom setting worked.

re: ''When quoting: Start my reply above the quote and place my signature: Below my reply (but above the quote) '' * Edit >Preferences > Advanced > 'General' tab * click on 'Config Editor' button * In search type: bottom For each mail account set up with preference to put signature below reply above quote. The mail identity for sig_bottom should appear as False and in bold font because it is a user setting. eg: * mail.identity.id1.sig_bottom Value false However, I'm assuming you can see it is already set as False for the identity. So, something is overriding your setting. Check the default setting: * mail.identity.default.sig_bottom The Value may be set to 'True' and causing the problem (it should not be, but I think it is) Double click on that line to toggle the value to 'False', so you have this: * mail.identity.default.sig_bottom Value = False * Exit the 'about: config' window by clicking on the top right X Note: This will not change anything in any currently opened Reply Write window. * Close any currently opened Write window. * select email and click on 'Reply'. If signature switch is disabled then it will not interfere and the signature should always appear correctly. Unfortuantely, although 'Signature switch' is really useful, it's one problem is with 'Reply' and 'Forward' in that it does not put any selected 'Signature Switch' signature above the quote. So, you click on Reply or Forward and the default one as set in Account Settings is correct, but you want to modify, so you use Signature Switch. It removes the default set in account settings and puts the selected signature below the quote. But otherwise it is a great addon. Please try this info and report back on whether changing the default sig_bottom setting worked.
Was this helpful to you?
Quote

Question owner

Thanks for that, but no luck.

Both :

  • # mail.identity.id1.sig_bottom
  • # mail.identity.default.sig_bottom

are set to false (and didn't need changing), so that's not the cause of the problem.

As you'll see from the attached image, I still get:

  • my reply
  • original message
  • my signature

(This occurs whether I use a plain text sig or an HTML one.)

It seems there's something fundamental broken in Thunderbird.

Thanks for that, but no luck. Both : * # mail.identity.id1.sig_bottom * # mail.identity.default.sig_bottom are set to '''false''' (and didn't need changing), so that's not the cause of the problem. As you'll see from the attached image, I ''still'' get: * my reply * original message * my signature (This occurs whether I use a plain text sig or an HTML one.) It seems there's something fundamental broken in Thunderbird.
Was this helpful to you?
Quote
orbitalpunk 0 solutions 3 answers

I have this problem too. It started after the last update. and my signature duplicates with each reply in a single row at the bottom. People think im crazy now when i reply several times in a conversation and i have 10 signature images at the bottom of the email next to each other.

I have this problem too. It started after the last update. and my signature duplicates with each reply in a single row at the bottom. People think im crazy now when i reply several times in a conversation and i have 10 signature images at the bottom of the email next to each other.
Was this helpful to you?
Quote

Question owner

There is definitely something wrong here, but it's getting seriously weird.

I did a clean install of Thunderbird on a different machine, set up the same account, etc. and still have the same problem. However, when I create a new instance on my current machine (with "thunderbird -ProfileManager -new-instance") and set up the same account again, the problem disappears.

There's a difference between the two setups. The current machine is running version 68.4.1, the new machine is running 68.5.0. So when I get a chance I'll downgrade the new machine to 68.4.1 and see if that fixes it.

The weirdness comes in with my current machine and current setup. Even start in Safe Mode I get the problem with 68.4.1. Only by setting up a new profile under a new instance did it disappear.

There is definitely something wrong here, but it's getting seriously weird. I did a clean install of Thunderbird on a different machine, set up the same account, etc. and still have the same problem. However, when I create a new instance on my current machine (with "thunderbird -ProfileManager -new-instance") and set up the same account again, the problem disappears. There's a difference between the two setups. The current machine is running version 68.4.1, the new machine is running 68.5.0. So when I get a chance I'll downgrade the new machine to 68.4.1 and see if that fixes it. The weirdness comes in with my current machine and current setup. Even start in Safe Mode I get the problem with 68.4.1. Only by setting up a new profile under a new instance did it disappear.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3398 solutions 23554 answers

Have the signature switch addon installed? Disable it.

Have the signature switch addon installed? Disable it.
Was this helpful to you? 0
Quote

Question owner

No, it's not installed. Besides, all addons are disabled when starting in Safe Mode and the problem persists in Safe Mode.

No, it's not installed. Besides, all addons are disabled when starting in Safe Mode and the problem persists in Safe Mode.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3398 solutions 23554 answers

firefox474 said

No, it's not installed. Besides, all addons are disabled when starting in Safe Mode and the problem persists in Safe Mode.

One of the reasons you will often see folks asked to use the operating systems safe mode with networking is that While Thunderbird disables addons, there is other software that injects their code into a running instance, not always successfully.

Why is everyone looking for something outside of Thunderbird? because it works for me. I just changed the setting while typing this and it worked.

I suggest first things first. The current version is 68.5 so make sure it is the version you are texting against. (there are no bug fixes for old versions even if you identify a problem there.)

''firefox474 [[#answer-1291581|said]]'' <blockquote> No, it's not installed. Besides, all addons are disabled when starting in Safe Mode and the problem persists in Safe Mode. </blockquote> One of the reasons you will often see folks asked to use the operating systems safe mode with networking is that While Thunderbird disables addons, there is other software that injects their code into a running instance, not always successfully. Why is everyone looking for something outside of Thunderbird? because it works for me. I just changed the setting while typing this and it worked. I suggest first things first. The current version is 68.5 so make sure it is the version you are texting against. (there are no bug fixes for old versions even if you identify a problem there.)
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.