X
Tap here to go to the mobile version of the site.

Support Forum

Send Unsent Messages disabled

Posted

I've just upgraded both a W10Home and a W10Pro system (both 1903) from TB 60.9.1 to 68.3.1 then immediately to 68.4.1.

On both systems when writing/replying/forwarding a message and using File->Send Later the message goes into the Outbox fine, but then, more often than not, File->Send Unsent Messages is disabled. Even if I Send Later several messages into the Outbox still Send Unsent Messages stays disabled.

When it's like that (messages in Outbox but File->Send Unsent Messages disabled) right-click on Outbox shows Send Unsent Messages as enabled in the popup menu, but selecting it does nothing. The only way I've found to send the messages in the Outbox is to go Offline and then back online, at which point it asks if I want to send unsent messages and if I click to do so it does then send them.

I've tried TB in Safe Mode with the same results, so it's not an add-on problem and, as I say, it's happening on both my W10Home laptop and W10Pro desktop, so it's not system specific.

Just occasionally I'll do a Send Later and File->Send Unsent Messages will be enabled and everything work as it should, but that's the exception, it usually just stays disabled and I've yet to spot any pattern or reason as to when it works and when it doesn't, indeed, if there is one.....

I've just upgraded both a W10Home and a W10Pro system (both 1903) from TB 60.9.1 to 68.3.1 then immediately to 68.4.1. On both systems when writing/replying/forwarding a message and using File->Send Later the message goes into the Outbox fine, but then, more often than not, File->Send Unsent Messages is disabled. Even if I Send Later several messages into the Outbox still Send Unsent Messages stays disabled. When it's like that (messages in Outbox but File->Send Unsent Messages disabled) right-click on Outbox shows Send Unsent Messages as enabled in the popup menu, but selecting it does nothing. The only way I've found to send the messages in the Outbox is to go Offline and then back online, at which point it asks if I want to send unsent messages and if I click to do so it does then send them. I've tried TB in Safe Mode with the same results, so it's not an add-on problem and, as I say, it's happening on both my W10Home laptop and W10Pro desktop, so it's not system specific. Just occasionally I'll do a Send Later and File->Send Unsent Messages will be enabled and everything work as it should, but that's the exception, it usually just stays disabled and I've yet to spot any pattern or reason as to when it works and when it doesn't, indeed, if there is one.....
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.3

More Information

sfhowes
  • Top 10 Contributor
1849 solutions 9168 answers

I wonder if corruption of the Outbox would cause the Send Unsent Messages command to be sporadic. If you select Help/Troubleshooting, click Open Folder to open the profile folder, close TB, open the Mail/Local Folders folder, and delete or rename Unsent Messages and Unsent Messages.msf, those files, i.e. Outbox, will be automatically recreated when you restart TB. If the problem remains, rebuilding the Outbox this way is obviously not the solution.

There is a very old bug that points to an incorrect preference caused during profile migration. In Tools/Options/Advanced/General/Config. editor, what is the value of mail.default_sendlater_uri? On my setup , it is: mailbox://nobody@Local%20Folders/Unsent%20Messages

I wonder if corruption of the Outbox would cause the Send Unsent Messages command to be sporadic. If you select Help/Troubleshooting, click Open Folder to open the profile folder, close TB, open the Mail/Local Folders folder, and delete or rename Unsent Messages and Unsent Messages.msf, those files, i.e. Outbox, will be automatically recreated when you restart TB. If the problem remains, rebuilding the Outbox this way is obviously not the solution. There is a very old [https://bugzilla.mozilla.org/show_bug.cgi?id=91936#c21 bug] that points to an incorrect preference caused during profile migration. In Tools/Options/Advanced/General/Config. editor, what is the value of mail.default_sendlater_uri? On my setup , it is: mailbox://nobody@Local%20Folders/Unsent%20Messages
Was this helpful to you?
Quote

Question owner

Thanks for the response.

I had already tried Repair Folder on the Outbox, to no avail, and it'd seem unlikely that it'd get corrupted on two systems at the same time, but nevertheless I've tried your suggestion of deleting the Outbox files but unfortunately the problem remains.

My mail.default_sendlater_uri is identical to yours.

Thanks for the response. I had already tried Repair Folder on the Outbox, to no avail, and it'd seem unlikely that it'd get corrupted on two systems at the same time, but nevertheless I've tried your suggestion of deleting the Outbox files but unfortunately the problem remains. My mail.default_sendlater_uri is identical to yours.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1849 solutions 9168 answers

It might be a bug in the current version, although I don't experience it myself and haven't seen similar reports. Before claiming it's a bug, I would recommend creating a new profile from Help/About Troubleshooting, about:profiles, adding an account, and seeing if the problem remains. The old profile is unaffected and can be opened also from about:profiles.

It might be a bug in the current version, although I don't experience it myself and haven't seen similar reports. Before claiming it's a bug, I would recommend creating a new profile from Help/About Troubleshooting, about:profiles, adding an account, and seeing if the problem remains. The old profile is unaffected and can be opened also from about:profiles.
Was this helpful to you?
Quote

Question owner

Aha! I've figured it out!

Send Unsent Messages is disabled whenever I have Local Folders or anything underneath it (including the Outbox of course) selected!

It definitely wasn't like that before my upgrades, 'cos my habit for years has been to "do emails" in one or two sessions a day, always using Send Later until I'd replied to/written all the ones I was going to in that session.

Then I'd go to the Outbox and review them all (to make sure I hadn't written any nonsense :-), and finally click to send them all and watch them disappear one by one out of the Outbox (the last bit not being any kind of needy confirmation but simply 'cos I was still in the Outbox when I clicked to send them :-).

It all works fine if I have any other account selected. How crazy is that? Send Unsent Messages is disabled when I'm looking at the list of unsent messages to be sent! :-)

Also broken is the Send Unsent Messages option in the right-click on Outbox popup context menu. It correctly becomes enabled/disabled depending on whether there are messages in the Outbox or not.

However, AFAICS, choosing it never sends them, and that's irrespective of which account or folder is selected.

BUT .... taking your suggestion and creating a new profile, none of that happens; everything works fine! File->Send Unsent Messages is enabled and works even when the Outbox is selected, and the popup context menu item works fine too.

So ... well I really don't want to try rebuilding my full profile from scratch, as I have some 8 accounts, all IMAP, with several Gb locally synced, and several dozen identities. And remember, I have the same issue on two systems (both of which are pretty much identically set up TB wise).

I'm assuming here you can't reproduce the behaviour I've described. Any suggestions (other than rebuild profile from scratch :-)?

Aha! I've figured it out! Send Unsent Messages is disabled whenever I have Local Folders or anything underneath it (including the Outbox of course) selected! It definitely wasn't like that before my upgrades, 'cos my habit for years has been to "do emails" in one or two sessions a day, always using Send Later until I'd replied to/written all the ones I was going to in that session. Then I'd go to the Outbox and review them all (to make sure I hadn't written any nonsense :-), and finally click to send them all and watch them disappear one by one out of the Outbox (the last bit not being any kind of needy confirmation but simply 'cos I was still in the Outbox when I clicked to send them :-). It all works fine if I have any other account selected. How crazy is that? Send Unsent Messages is disabled when I'm looking at the list of unsent messages to be sent! :-) Also broken is the Send Unsent Messages option in the right-click on Outbox popup context menu. It correctly becomes enabled/disabled depending on whether there are messages in the Outbox or not. However, AFAICS, choosing it ''never ''sends them, and that's ''irrespective ''of which account or folder is selected. '''BUT''' .... taking your suggestion and creating a new profile, none of that happens; everything works fine! File->Send Unsent Messages is enabled and works even when the Outbox is selected, and the popup context menu item works fine too. So ... well I really don't want to try rebuilding my full profile from scratch, as I have some 8 accounts, all IMAP, with several Gb locally synced, and several dozen identities. And remember, I have the same issue on two systems (both of which are pretty much identically set up TB wise). I'm assuming here you can't reproduce the behaviour I've described. Any suggestions (other than rebuild profile from scratch :-)?
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1849 solutions 9168 answers

On my current profile, the File menu item Send Unsent Messages works when Local Folders is selected, and the context menu item also works if Outbox is selected. I don't know what would need to be fixed in your original profile to restore the correct behavior. But if you add the accounts to the new profile, and don't want to resync all the IMAP folders, you could run the old profile and move mail from the IMAP folders to Local Folders, or unsubscribe from folders you don't want to re-download, or set the folders to download just the headers (uncheck Message Synchronizing in Account Settings/Synchronization & Storage). For the latter, I recommend you set up the account offline so the setting is in place before TB syncs with the server.

On my current profile, the File menu item Send Unsent Messages works when Local Folders is selected, and the context menu item also works if Outbox is selected. I don't know what would need to be fixed in your original profile to restore the correct behavior. But if you add the accounts to the new profile, and don't want to resync all the IMAP folders, you could run the old profile and move mail from the IMAP folders to Local Folders, or unsubscribe from folders you don't want to re-download, or set the folders to download just the headers (uncheck Message Synchronizing in Account Settings/Synchronization & Storage). For the latter, I recommend you set up the account offline so the setting is in place before TB syncs with the server.
Was this helpful to you?
Quote

Question owner

No, I think I'll just live with it. It's certainly a bit of a bizarre quirk but at least there's a quick and easy workaround.

Maybe some time when I have the time and inclination I'll have a poke around and see if I can find anything ... look at config settings, etc.

And who knows, as it appeared with a v60 to 68 upgrade it may disappear with some future one :-)

No, I think I'll just live with it. It's certainly a bit of a bizarre quirk but at least there's a quick and easy workaround. Maybe some time when I have the time and inclination I'll have a poke around and see if I can find anything ... look at config settings, etc. And who knows, as it appeared with a v60 to 68 upgrade it may disappear with some future one :-)
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.