X
Tap here to go to the mobile version of the site.

Support Forum

Open file association with Applications is not working. Firefox always uses Content Type of "file" to open files.

Posted

Even though the XLSX file in the example (images attached) is identified as such, when trying to open the file, the Launch Application window appears which is for files of "file" Content Type. This started occurring about 3 months ago, after a Firefox Update. I do not know to which version unfortunately. It affects all users so it's not profile related. I tried to Refresh Firefox and Restart with Add-ons Disabled from Tools > Help > Troubleshooting information but it didn't help.

Even though the XLSX file in the example (images attached) is identified as such, when trying to open the file, the Launch Application window appears which is for files of "file" Content Type. This started occurring about 3 months ago, after a Firefox Update. I do not know to which version unfortunately. It affects all users so it's not profile related. I tried to Refresh Firefox and Restart with Add-ons Disabled from Tools > Help > Troubleshooting information but it didn't help.
Attached screenshots

Chosen solution

Hello,

turns out it was a bug on the Firefox version I was using. As soon as updated to 68.4.2 issue is resolved.

https://www.mozilla.org/en-US/firefox/68.4.2/releasenotes/

"Fixed various issues opening files with spaces in their path"

Thank you RobertJ for all your help

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

OpenH264 Video Codec provided by Cisco Systems, Inc.

Widevine Content Decryption Module provided by Google Inc.

No extensions installed

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/79.0.3945.117 Safari/537.36

More Information

RobertJ
  • Top 10 Contributor
144 solutions 1466 answers

Hello Pavlos V,

Do you have your Applications handler set up properly?

This article should help with that: Change what Firefox does when you click on or download a file __________________________________________________________________

If nothing in the article helped you solve the issue, you can reset your Applications handler.

Type (or paste) about:support in the address bar and press Enter under Application Basics next to Profile Folder click the Open Folder button Close Firefox.

In your Profile Folder rename handlers.json to something like handlersOLD.json If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf

Close the folder window and launch Firefox. Your Applications handler will be reset to the default. You can set how to handle XLSX's and set how to handle other file types as you encounter them.

Hello Pavlos V, Do you have your Applications handler set up properly? This article should help with that: [https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file Change what Firefox does when you click on or download a file] __________________________________________________________________ If nothing in the article helped you solve the issue, you can reset your Applications handler. Type (or paste) about:support in the address bar and press Enter under Application Basics next to Profile Folder click the Open Folder button Close Firefox. In your Profile Folder rename handlers.json to something like handlersOLD.json If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf Close the folder window and launch Firefox. Your Applications handler will be reset to the default. You can set how to handle XLSX's and set how to handle other file types as you encounter them.
Was this helpful to you? 0
Quote

Question owner

RobertJ said

Hello Pavlos V, Do you have your Applications handler set up properly? This article should help with that: Change what Firefox does when you click on or download a file __________________________________________________________________ If nothing in the article helped you solve the issue, you can reset your Applications handler. Type (or paste) about:support in the address bar and press Enter under Application Basics next to Profile Folder click the Open Folder button Close Firefox. In your Profile Folder rename handlers.json to something like handlersOLD.json If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf Close the folder window and launch Firefox. Your Applications handler will be reset to the default. You can set how to handle XLSX's and set how to handle other file types as you encounter them.

Hello RobertJ,

thank you for that. My Application handlers are set up properly and renaming handlers.json file didn't help, unfortunately. I have done standard troubleshooting, investigation over the web, and I believe this is a bug rather than a profile issue.

Any more ideas are most welcome!

''RobertJ [[#answer-1281158|said]]'' <blockquote> Hello Pavlos V, Do you have your Applications handler set up properly? This article should help with that: [https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file Change what Firefox does when you click on or download a file] __________________________________________________________________ If nothing in the article helped you solve the issue, you can reset your Applications handler. Type (or paste) about:support in the address bar and press Enter under Application Basics next to Profile Folder click the Open Folder button Close Firefox. In your Profile Folder rename handlers.json to something like handlersOLD.json If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf Close the folder window and launch Firefox. Your Applications handler will be reset to the default. You can set how to handle XLSX's and set how to handle other file types as you encounter them. </blockquote> Hello RobertJ, thank you for that. My Application handlers are set up properly and renaming handlers.json file didn't help, unfortunately. I have done standard troubleshooting, investigation over the web, and I believe this is a bug rather than a profile issue. Any more ideas are most welcome!
Was this helpful to you?
Quote
RobertJ
  • Top 10 Contributor
144 solutions 1466 answers

Have you checked the file association in Windows? As far as XLSX files on your PC: go to any XLSX file, right click on it, select Open With and Choose Another App. In the selection window that opens select Excel and tick the checkbox next to Always Use This App To Open XLSX Files. If Excel isn't shown, Scroll down and click on More Apps... If it isn't in that list, scroll down and select Look for another app on this PC... In the Open With... window, find Excel select Excel and Open. If that still doesn't work, go to - Windows Settings -> Apps -> Default Apps (on the left) listed under the Reset button, you will see Choose Default Apps By File Type

You can also check: Choose Default Apps By Protocol

Have you checked the file association in Windows? As far as XLSX files on your PC: go to any XLSX file, right click on it, select Open With and Choose Another App. In the selection window that opens select Excel and tick the checkbox next to Always Use This App To Open XLSX Files. If Excel isn't shown, Scroll down and click on More Apps... If it isn't in that list, scroll down and select Look for another app on this PC... In the Open With... window, find Excel select Excel and Open. If that still doesn't work, go to - Windows Settings -> Apps -> Default Apps (on the left) listed under the Reset button, you will see Choose Default Apps By File Type You can also check: Choose Default Apps By Protocol

Modified by RobertJ

Was this helpful to you?
Quote
RobertJ
  • Top 10 Contributor
144 solutions 1466 answers

Sorry, double-check the edit of that last reply

Sorry, double-check the edit of that last reply
Was this helpful to you?
Quote

Question owner

Hello RobertJ,

I have checked file association for Windows, nothing out of the ordinary there.

I have investigated further and realized that Firefox Open file association with Applications is working fine on Windows Server 2012 but it's not working when Firefox is used as a RemoteApp.

So, I'm not entirely sure if the issue is related to Firefox or not but it did start when Firefox was updated.

Hello RobertJ, I have checked file association for Windows, nothing out of the ordinary there. I have investigated further and realized that Firefox Open file association with Applications is working fine on Windows Server 2012 but it's not working when Firefox is used as a RemoteApp. So, I'm not entirely sure if the issue is related to Firefox or not but it did start when Firefox was updated.
Was this helpful to you?
Quote
RobertJ
  • Top 10 Contributor
144 solutions 1466 answers

I agree with you: I'm not entirely sure if the issue is related to Firefox. I saw an Undocumented Hotfix for MS Office download early on the 11th and there have been quite a few posts in regard to Office files not opening properly since then. I didn't have any issues downloading and opening an XLSX from the same source as in your screenshot. If everything above checks out OK, you may have to take a look in the Registry. Let us know what you find.

I agree with you: I'm not entirely sure if the issue is related to Firefox. I saw an Undocumented Hotfix for MS Office download early on the 11th and there have been quite a few posts in regard to Office files not opening properly since then. I didn't have any issues downloading and opening an XLSX from the same source as in your screenshot. If everything above checks out OK, you may have to take a look in the Registry. Let us know what you find.
Was this helpful to you?
Quote
RobertJ
  • Top 10 Contributor
144 solutions 1466 answers

Go figure. I just now got an MS Office update from the 14th downloaded.

Go figure. I just now got an MS Office update from the 14th downloaded.
Was this helpful to you?
Quote
RobertJ
  • Top 10 Contributor
144 solutions 1466 answers

And still OK downloading and opening an XLSX from File Examples Download.

And still OK downloading and opening an XLSX from File Examples Download.
Was this helpful to you?
Quote

Chosen Solution

Hello,

turns out it was a bug on the Firefox version I was using. As soon as updated to 68.4.2 issue is resolved.

https://www.mozilla.org/en-US/firefox/68.4.2/releasenotes/

"Fixed various issues opening files with spaces in their path"

Thank you RobertJ for all your help

Hello, turns out it was a bug on the Firefox version I was using. As soon as updated to 68.4.2 issue is resolved. https://www.mozilla.org/en-US/firefox/68.4.2/releasenotes/ "Fixed various issues opening files with spaces in their path" Thank you RobertJ for all your help
Was this helpful to you?
Quote
RobertJ
  • Top 10 Contributor
144 solutions 1466 answers

I'm glad to hear that you figured out the problem. I was glad to see that fix, also.


Browse Safe !

I'm glad to hear that you figured out the problem. I was glad to see that fix, also. Browse Safe !
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.