Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search Bar No Longer Autocompletes URLs or Search Queries

more options

Running Firefox 71.0 on macOS Mojave and I have not been able to have my search bar either autocomplete, suggest, or state any previous URLs or search queries.

This feature worked earlier that day, all of my settings are exactly the same and I have double and tripled checked that it is not my preferences (as in my settings allow it, Firefox remembers my history to pull from, but still nothing). I cannot see any URL or search I have searched as I am completely used to as of even yesterday and this is very irritating issue to not have work. If I had a search engine side bar that works via the search engines suggestions/autocomplete, but I hate having too separate bars since it slows me down (and even doing so, the URL bar still doesn't autofill or suggest any URL).

Any ideas?

Chosen solution

If anyone stumbles upon this with a similar issue, I have now solved it which I will write below.

In sum, I deleted the file, "places.sqlite", in my Firefox files: https://support.mozilla.org/en-US/kb/cant-add-change-or-save-bookmarks

I was having trouble also adding a new bookmark and I sought to correct that issue (and URLs were still not autosuggesting). I found those instructions and when deleting that file fixed the issue of adding and editing bookmarks, so did autocompletes for URLs.

Read this answer in context 👍 0

All Replies (3)

more options

Hi there....


(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) If the browser.urlbar.autoFill preference is bolded and "user set" to false, double-click it to restore the default value of true

Is that what you had before? If you had full URL suggestions in the bar, it probably was a feature of an extension.

Next, about hiding the explanatory row:

   if you use Classic Theme Restorer, check 

the Location Bar (3) section of its settings dialog

   you can use a custom style rule with the Stylish 

extension (or a userChrome.css file if you prefer), for example https://userstyles.org/styles/122394/url-bar-tweaks-remove-visit-search-limit-width

more options

Hello Dinushi,

Unfortunately, after following these instructions the problem still persists.

To clarify, I have no extensions (that are new that would have obviously affected this feature of Firefox). In addition, it is not auto-completing URLs in the sense that if I have gone to facebook.com in the past and now in a blank URL I type "f" there is no suggestion for "facebook.com" or any site beginning with "f".

Still not quite sure where the issue lies as I even tried reinstalling Firefox. In addition, if I open a blank tab and see a drop down list of sites to type they are static. They are always the same no matter the history, all of which I have gone to but some of which I haven't gone to since the last time I cleared my history/cache (which was extremely recently since I was trying to resolve this problem).

more options

Chosen Solution

If anyone stumbles upon this with a similar issue, I have now solved it which I will write below.

In sum, I deleted the file, "places.sqlite", in my Firefox files: https://support.mozilla.org/en-US/kb/cant-add-change-or-save-bookmarks

I was having trouble also adding a new bookmark and I sought to correct that issue (and URLs were still not autosuggesting). I found those instructions and when deleting that file fixed the issue of adding and editing bookmarks, so did autocompletes for URLs.