Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prevent all pinned tabs from loading on start

  • 2 replies
  • 1 has this problem
  • 759 views
  • Last reply by Den

more options

Please make firefox to stop loading all my pinned tabs on start. Load them only when user goes there.

Attached screenshots

Modified by Den

Chosen solution

Hi denis, it's true, all the pinned tabs load automatically when you restore your previous session. But luckily there is a preference for that. Could you test this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste demand and pause while the list is filtered

(3) Double-click the browser.sessionstore.restore_pinned_tabs_on_demand preference to switch the value from false to true -- so they will behave like regular tabs and only load when activated

The similarly named browser.sessionstore.restore_on_demand preference is for the regular tabs and should retain its default value of true if you don't want them to all load.

Success?

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hi denis, it's true, all the pinned tabs load automatically when you restore your previous session. But luckily there is a preference for that. Could you test this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste demand and pause while the list is filtered

(3) Double-click the browser.sessionstore.restore_pinned_tabs_on_demand preference to switch the value from false to true -- so they will behave like regular tabs and only load when activated

The similarly named browser.sessionstore.restore_on_demand preference is for the regular tabs and should retain its default value of true if you don't want them to all load.

Success?

more options

Hi Jeff, thanks for your help. I can see those pined tabs are no longer loaded on start. Best Regards