X
Tap here to go to the mobile version of the site.

Support Forum

Can't open attachments when using Thunderbird under Fedora Silverblue

Posted

When running TB under Fedora Silverblue I can't open or save any attachments. Clicking on the attachment brings up a dialog asking if I'd like to open the file using System Handler. Clicking OK does nothing. If I select the alternate application drop down I get a choice of Help or Thunderbird, even though I have the required aps installed (Videos and VLC for mp4, Libreoffice for csv, which is the only two I've tried). I also cannot save the file anywhere. If I click Save I get a dialog asking me where to save the file, I select a directory (i.e. /home/Videos) and click Save, but then a dialog is displayed saying "Unable to save the attachment, please check your file name and try again later." I click OK on that dialog and another pops up saying "Unable to save the message. Please check your file name and try again later."

Is there a fix or workaround for this problem? Thanks, Ian

When running TB under Fedora Silverblue I can't open or save any attachments. Clicking on the attachment brings up a dialog asking if I'd like to open the file using System Handler. Clicking OK does nothing. If I select the alternate application drop down I get a choice of Help or Thunderbird, even though I have the required aps installed (Videos and VLC for mp4, Libreoffice for csv, which is the only two I've tried). I also cannot save the file anywhere. If I click Save I get a dialog asking me where to save the file, I select a directory (i.e. /home/Videos) and click Save, but then a dialog is displayed saying "Unable to save the attachment, please check your file name and try again later." I click OK on that dialog and another pops up saying "Unable to save the message. Please check your file name and try again later." Is there a fix or workaround for this problem? Thanks, Ian
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

Helpful Reply

Well maybe it's not a TB problem. Silverblue just did an upgrade and now I can save attachments. I still can't open them directly from TB, but half the problem has been solved. I think I can safely call this issue closed, if not completely solved. It seems to be a Silverblue issue. I'll wait for the next update and see what happens then.

-)
Well maybe it's not a TB problem. Silverblue just did an upgrade and now I can save attachments. I still can't open them directly from TB, but half the problem has been solved. I think I can safely call this issue closed, if not completely solved. It seems to be a Silverblue issue. I'll wait for the next update and see what happens then. ;-)
Was this helpful to you? 1
Quote
Toad-Hall
  • Top 10 Contributor
1843 solutions 12429 answers

Helpful Reply

Could you try this and tell me if it fixes the opening issue. Edit > Preferences > Advanced > General click on 'config editor' button set 'mail.server.default.mime_parts_on_demand' to 'false'. double click online will toggle the value from True to false. close window top right X depending upon version your are using...click on OK or Close Preferences tab. Restart Thunderbird.

Could you try this and tell me if it fixes the opening issue. Edit > Preferences > Advanced > General click on 'config editor' button set 'mail.server.default.mime_parts_on_demand' to 'false'. double click online will toggle the value from True to false. close window top right X depending upon version your are using...click on OK or Close Preferences tab. Restart Thunderbird.
Was this helpful to you? 1
Quote

Question owner

Thanks for the reponse @Toad-Hall. I tried your suggestion but it didn't change anything, I still can't open an attachment directly. But it could be a Silverblue problem...

-)
Thanks for the reponse @Toad-Hall. I tried your suggestion but it didn't change anything, I still can't open an attachment directly. But it could be a Silverblue problem... ;-)
Was this helpful to you? 1
Quote
sfhowes
  • Top 10 Contributor
1844 solutions 9127 answers

Try this: Edit/Preferences/Attachments/Incoming, click the Action drop-down for a file (content) type such as pdf, select Use other..., do not select the helper app from the list, click Browse... and select the helper app or exe directly, close Preferences. Follow the same procedure for file types that aren't shown in Attachments when you try to open an attachment in a message, or if you delete the action from the drop-down in order to reset it.

Try this: Edit/Preferences/Attachments/Incoming, click the Action drop-down for a file (content) type such as pdf, select Use other..., do not select the helper app from the list, click Browse... and select the helper app or exe directly, close Preferences. Follow the same procedure for file types that aren't shown in Attachments when you try to open an attachment in a message, or if you delete the action from the drop-down in order to reset it.
Was this helpful to you?
Quote

Question owner

Thanks @showes, I tried your suggestion, but when I selected "Use Other..." I got a long list of files from my home directory. After a bit of googling I learned that Gnome's video player is called Totem. I eventually found an executable called totem, (in /var/lib/flatpak/app/org.gnome.Totem/current/active/files/bin), clicked on it and selected "Open". However the Action for mpeg-4 was still "Always Ask". It didn't set it to totem. I still think this may be a problem with Silverblue. I've seen a few strange anomalies along the journey, and it certainly has a funny way of doing things sometimes, but I'm sticking with it for now as I like the concept of an immutable OS.

-)
Thanks @showes, I tried your suggestion, but when I selected "Use Other..." I got a long list of files from my home directory. After a bit of googling I learned that Gnome's video player is called Totem. I eventually found an executable called totem, (in /var/lib/flatpak/app/org.gnome.Totem/current/active/files/bin), clicked on it and selected "Open". However the Action for mpeg-4 was still "Always Ask". It didn't set it to totem. I still think this may be a problem with Silverblue. I've seen a few strange anomalies along the journey, and it certainly has a funny way of doing things sometimes, but I'm sticking with it for now as I like the concept of an immutable OS. ;-)
Was this helpful to you?
Quote

Question owner

Just to revisit this, the problem persists. It may be a problem with how TB is set up as a flatpak, or it may be a flatpak problem (it is apparently a bit flaky at times). Either way the problem has now become worse. A couple of weeks ago saving an attachment suddenly started working (Silverblue updates occur on an almost daily basis). Yesterday TB was updated, and now saving doesn't work any more, and opening an attachment still does not work. My suspicion is that it is not a problem with TB per se, but how it has been implemented as a flatpak as TB works fine on my other distros.

Just to revisit this, the problem persists. It may be a problem with how TB is set up as a flatpak, or it may be a flatpak problem (it is apparently a bit flaky at times). Either way the problem has now become worse. A couple of weeks ago saving an attachment suddenly started working (Silverblue updates occur on an almost daily basis). Yesterday TB was updated, and now saving doesn't work any more, and opening an attachment still does not work. My suspicion is that it is not a problem with TB per se, but how it has been implemented as a flatpak as TB works fine on my other distros.
Was this helpful to you?
Quote
Gugsa Beshir 0 solutions 2 answers

Hey i am using firefox.

Hey i am using firefox.
Was this helpful to you?
Quote
Gugsa Beshir 0 solutions 2 answers

My problem my matrial mobile no computer.

My problem my matrial mobile no computer.
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1843 solutions 12429 answers

Gugsa Beshir re: Hey i am using firefox. Firefox is a browser and nothing to do with Thunderbird.

re:My problem my matrial mobile no computer. Thunderbird is an email client that only runs on a computer eg: desktop, laptop etc.

This forum is only for issues with Thunderbird email client.

'''Gugsa Beshir''' re: ''Hey i am using firefox.'' Firefox is a browser and nothing to do with Thunderbird. re:''My problem my matrial mobile no computer.'' Thunderbird is an email client that only runs on a computer eg: desktop, laptop etc. This forum is only for issues with Thunderbird email client.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.