Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Duplicating Tabs or Opening a Link in a New Tab - Site Never Loads

  • 3 replies
  • 1 has this problem
  • 8 views
  • Last reply by Rachel

more options

I have only recently been having this problem. I have been using Firefox for about 9 months and been having this problem for less than a week. When I go to open a new link in a new tab, that tab never loads. I can open a blank tab and paste the link there, and it will load about 90% of the time.

I have 2 add-ons, the Multi-Account Containers add-on and a ColorPick Eyedropper. I tried turning off the Proxy setting, since I don't use one. And I have tried disabling the DNS prefetch thing. Neither of those suggestions have worked.

Does anyone have any other ideas? I would rather not go back to Chrome if possible. The multi-account container is a lifesaver.

All Replies (3)

more options

The newest update, 68.0.2 , says it was installed on Aug 21st (11 days ago), but I noticed that it also is saying that the status is Install Pending.

I don't know if this could be the issue. I'm also not sure how to get the update installed. It is stuck saying "downloading update" at 0 bytes.

more options

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

Thank you @cor-el for responding. I closed out all my tabs to boot my computer, and Firefox updated, and it is working fine now.

I have a problem with leaving my tabs open for multiple days in a row when I'm working on projects, so this was definitely my bad on an easy fix.

I'll have to remember to turn it off and back on again. I'll remember your suggest for future problems though. Thank you.