X
Tap here to go to the mobile version of the site.

Support Forum

When forwarding a mail use To: adress of original mails as From: address of forwarded mail

Posted

When I forward a mail I would like Thunderbird to forward the email using the address to which the original mails was sent. At the moment, Thunderbird uses my default email address as the From address of forwarded mail. e.g. mails sent from aa@a.com to bb@b.com , i want to forward this mail and have bb@b.com as the from address of the forwarded mail. At the moment, Thunderbird uses my DEFAULT from address as From address instead of bb@b.com and I have to manually change it each time

When I forward a mail I would like Thunderbird to forward the email using the address to which the original mails was sent. At the moment, Thunderbird uses my default email address as the From address of forwarded mail. e.g. mails sent from aa@a.com to bb@b.com , i want to forward this mail and have bb@b.com as the from address of the forwarded mail. At the moment, Thunderbird uses my DEFAULT from address as From address instead of bb@b.com and I have to manually change it each time
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

Matt
  • Top 10 Contributor
  • Moderator
3239 solutions 22250 answers

Perhaps you need to add an identity in the account settings for your second address.

Perhaps you need to add an identity in the account settings for your second address.
Was this helpful to you? 0
Quote

Question owner

I've done some more tests, I have 7 mail accounts set up with 20 or so identities. All mails arrive in ONE inbox, when I am in that inbox, and I forward a mail, it uses my main default email account as From Address. If I move the Email to a sub folder of the account the original mail was sent to, it uses the correct email address to Forward from. If I leave he mail in the INBOX of ALL accounts it uses my default address. This has to be an error ? or a setting I have missed How do I report this ? NOTE: All required identities are set up in each account configuration!

I've done some more tests, I have 7 mail accounts set up with 20 or so identities. All mails arrive in ONE inbox, when I am in that inbox, and I forward a mail, it uses my main default email account as From Address. If I move the Email to a sub folder of the account the original mail was sent to, it uses the correct email address to Forward from. If I leave he mail in the INBOX of ALL accounts it uses my default address. This has to be an error ? or a setting I have missed How do I report this ? NOTE: All required identities are set up in each account configuration!
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3239 solutions 22250 answers

is this the global inbox in local folders you are talking about? or another?

is this the global inbox in local folders you are talking about? or another?
Was this helpful to you?
Quote

Question owner

It goes wrong when I forward from this Inbox, see attachment!

Not in the individual email foders, this works as expected, Only from this combined Index!

It goes wrong when I forward from this Inbox, see attachment! Not in the individual email foders, this works as expected, Only from this combined Index!
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1741 solutions 11669 answers

Image explains you are using 'Unified' view and the issue only arises in the virtual 'Inbox' that shows everything combined but works correctly when you forward from the real Inbox for the account.

Tested this setup on my system and all 'forward' emails did use correct email address.

Perhaps your 'smart folder' is corrupt.

Please try this: Set the folders to the 'All' setting Menu icon > Folders > All

In Thunderbird Help > Troubleshooting Information click on 'Open Folder' a new window opens showing the contents of your profile name folder.

Exit Thunderbird now - this is important.

click on 'Mail' folder

Locate and delete 'smart mailboxes' folder.

Start Thunderbird

Set the folders to the 'Unified' setting Menu icon > Folders > Unified

Allow a little time smart mailboxes to be recreated and then test 'forward' of email to see what is put in the 'From'.

Please report back with results.

Image explains you are using 'Unified' view and the issue only arises in the virtual 'Inbox' that shows everything combined but works correctly when you forward from the real Inbox for the account. Tested this setup on my system and all 'forward' emails did use correct email address. Perhaps your 'smart folder' is corrupt. Please try this: Set the folders to the 'All' setting Menu icon > Folders > All In Thunderbird Help > Troubleshooting Information click on 'Open Folder' a new window opens showing the contents of your profile name folder. Exit Thunderbird now - this is important. click on 'Mail' folder Locate and delete 'smart mailboxes' folder. Start Thunderbird Set the folders to the 'Unified' setting Menu icon > Folders > Unified Allow a little time smart mailboxes to be recreated and then test 'forward' of email to see what is put in the 'From'. Please report back with results.
Was this helpful to you?
Quote

Question owner

It does not change anything.. as you can see form uploaded image!

NOTE, this problem occurs on Linux , Macos x and Chrome OS but I still tried your suggestion.

It does not change anything.. as you can see form uploaded image! NOTE, this problem occurs on Linux , Macos x and Chrome OS but I still tried your suggestion.
Was this helpful to you?
Quote
Matt
  • Top 10 Contributor
  • Moderator
3239 solutions 22250 answers

Chosen Solution

try this add-on https://addons.thunderbird.net/en-US/thunderbird/addon/reply-as-original-recipient/?src=search
Was this helpful to you?
Quote

Question owner

Thanks for your help Matt. Now that I know how it works I will live with the issue and be careful when I forward emails. In fact, the problem for me is more important when I forwarding SPAM to spamcop, so I have to be careful. I consider more of a bug, I can understand having a default email address for sending new mails but when it comes to replying and forwarding it should, IMHO use the original To and not the default to. It should be an option, that is why I posted this question in the first place, thinking there was an option somewhere I had not seen.

Thanks Matt, I'll live with it.

Thanks for your help Matt. Now that I know how it works I will live with the issue and be careful when I forward emails. In fact, the problem for me is more important when I forwarding SPAM to spamcop, so I have to be careful. I consider more of a bug, I can understand having a default email address for sending new mails but when it comes to replying and forwarding it should, IMHO use the original To and not the default to. It should be an option, that is why I posted this question in the first place, thinking there was an option somewhere I had not seen. Thanks Matt, I'll live with it.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.