Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why will Firefox will not update on my Windows 10 desktop?

  • 6 replies
  • 1 has this problem
  • 59 views
  • Last reply by AliceWyman

more options

When trying to update from 68.0 to 68.0.1, Firefox keeps saying my operating system is to old and wants me to download a version 52 ESR release. What is making Firefox think that I am not running Windows 10 1903? As I fill this out, I see below that Firefox thinks my operating system is Windows Vista. What's broken and how do I fix it? Thanks!

Chosen solution

Note that Firefox 68 doesn't run on Windows Vista (lat was Firefox 52.9.0), so it is likely that you run Firefox in compatibility mode.

Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Read this answer in context 👍 1

All Replies (6)

more options

Are you perhaps running Firefox on compatibility mode?

more options

No. I have a laptop that updates just fine. The problem is with my desktop only. I just re-installed 68.0 and was prompted to create a new profile. I've done that and will try to update to 68.0.x later to see if it works now. If it does, it was most likely a corrupted profile that made Firefox think I was on Win 7/XP, and wanted me to download a 52.x ESR version when I tried to manually update. Thanks for your reply!

more options

System details for your original post show this: User Agent: Mozilla/5.0 (Windows NT 6.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Windows NT 6.0 is Windows Vista. If you switch to your original profile (ref: Profile Manager - Create, remove, or switch Firefox profiles), see this article:

more options

Chosen Solution

Note that Firefox 68 doesn't run on Windows Vista (lat was Firefox 52.9.0), so it is likely that you run Firefox in compatibility mode.

Check that you do not run Firefox in compatibility mode. You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

more options

You're a genius! My shortcut for Firefox WAS set to compatibility mode. Don't have a clue how that happened. Fixed. Also reset useragent entries. Now I'll just wait till to next release and see if that worked. Probably does, as my laptop didn't have this issue or the compatibility mode and useragent SNAFU's. Thanks to everyone for your quick suggestions!

more options

dbcobb said

You're a genius! My shortcut for Firefox WAS set to compatibility mode. Don't have a clue how that happened. Fixed. Also reset useragent entries. Now I'll just wait till to next release and see if that worked. Probably does, as my laptop didn't have this issue or the compatibility mode and useragent SNAFU's. Thanks to everyone for your quick suggestions!

Thanks for posting back with the outcome. I'll mark the answer by cor-el as solving the problem.