X
Tap here to go to the mobile version of the site.

Support Forum

Ctrl + Arrow doesn't move to next special character, (slash, dot...)

Posted

I am used to user Ctrl + Arrow to move in a text, a search bar, etc with Ctrl + Right/Left, and this works with words, or some characters, such as slash or dot (/ .), but in firefox this only works for the words, that is, the space character. I want to be able to move to the next character of those, because for example in an URL like this

https://support.mozilla.org/en-US/questions/new/desktop/

If i use Ctrl + Right/Left, it moves to the end or start of the URL, not the the specific slash, and I would like that behavior.

I am used to user Ctrl + Arrow to move in a text, a search bar, etc with Ctrl + Right/Left, and this works with words, or some characters, such as slash or dot (/ .), but in firefox this only works for the words, that is, the space character. I want to be able to move to the next character of those, because for example in an URL like this https://support.mozilla.org/en-US/questions/new/desktop/ If i use Ctrl + Right/Left, it moves to the end or start of the URL, not the the specific slash, and I would like that behavior.

Chosen solution

Hi Mateo, on Windows the cursor stops just after the / in a URL. Could you check/experiment with the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste word_ and pause while the list is filtered

(3) If the layout.word_select.stop_at_punctuation preference is set to false, double-click it to toggle the value to true

There is also a preference related to underscores.

Any improvement?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Vue Devtools, AdBlocker Ultimate

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

jscher2000
  • Top 10 Contributor
8637 solutions 70650 answers

Chosen Solution

Hi Mateo, on Windows the cursor stops just after the / in a URL. Could you check/experiment with the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste word_ and pause while the list is filtered

(3) If the layout.word_select.stop_at_punctuation preference is set to false, double-click it to toggle the value to true

There is also a preference related to underscores.

Any improvement?

Hi Mateo, on Windows the cursor stops just after the / in a URL. Could you check/experiment with the following setting: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''word_''' and pause while the list is filtered (3) If the '''layout.word_select.stop_at_punctuation''' preference is set to false, double-click it to toggle the value to true There is also a preference related to underscores. Any improvement?
Was this helpful to you? 1
Quote

Question owner

That's exactly what I wanted, thanks.

That's exactly what I wanted, thanks.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.