X
Tap here to go to the mobile version of the site.

Support Forum

Thunderbird takes a very long time to receive an email, if that email is moved to a different folder due to server side filtering.

Posted

Just started using Thunderbird. Everything works well, except one thing. I have a few filters running on my email server (Zoho webmail), which move certain incoming emails to a different folder (e.g. folder X).

Being an IMAP connection, TB has the same set of folders on the client side.

When the filtering is triggered on the server side, I do not get any notification within TB client about the arrival of this email. There is no pop-up notification and there is also no bold-face new mail count increment (in parenthesis) for folder X within TB. It would remain like this for hours. But if I happen to click on folder X within TB, TB would then update and reflect everything correctly.

My setup: Windows 7 Pro. TB version 60.8.0 (32-bit). IMAP account server setting = check for msg every 1 minute.

Thx for your help.

Just started using Thunderbird. Everything works well, except one thing. I have a few filters running on my email server (Zoho webmail), which move certain incoming emails to a different folder (e.g. folder X). Being an IMAP connection, TB has the same set of folders on the client side. When the filtering is triggered on the server side, I do not get any notification within TB client about the arrival of this email. There is no pop-up notification and there is also no bold-face new mail count increment (in parenthesis) for folder X within TB. It would remain like this for hours. But if I happen to click on folder X within TB, TB would then update and reflect everything correctly. My setup: Windows 7 Pro. TB version 60.8.0 (32-bit). IMAP account server setting = check for msg every 1 minute. Thx for your help.

Chosen solution

By default Thunderbird only checks the Inbox for new mail as this is usually where new mail is received. However, there are cases when server side filtering alters this.

Try this: Right click on Folder X and select 'Properties' Select checkbox: 'When getting new messages for this account, always check this folder'. click on 'OK'

Repeat for any folder that gets server side filtering of new mail.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.87 Safari/537.36

More Information

Toad-Hall
  • Top 10 Contributor
1764 solutions 11865 answers

Chosen Solution

By default Thunderbird only checks the Inbox for new mail as this is usually where new mail is received. However, there are cases when server side filtering alters this.

Try this: Right click on Folder X and select 'Properties' Select checkbox: 'When getting new messages for this account, always check this folder'. click on 'OK'

Repeat for any folder that gets server side filtering of new mail.

By default Thunderbird only checks the Inbox for new mail as this is usually where new mail is received. However, there are cases when server side filtering alters this. Try this: Right click on Folder X and select 'Properties' Select checkbox: 'When getting new messages for this account, always check this folder'. click on 'OK' Repeat for any folder that gets server side filtering of new mail.
Was this helpful to you? 1
Quote

Question owner

Toad,

Thanks for the insight. This indeed solves the problem. Appreciate your help!

Toad, Thanks for the insight. This indeed solves the problem. Appreciate your help!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.